summaryrefslogtreecommitdiff
path: root/system/openrc
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-07-22 20:15:07 -0400
committerMax Rees <maxcrees@me.com>2019-07-22 20:15:07 -0400
commit2707df6cc761dcc2341faa8bafec5b4b4fa33e4d (patch)
tree9df7c2d2fd84f153634581ff4fb249b98bf34ffa /system/openrc
parentb7ffaa4d55e1faf4de0f8e6a2edf372fedfeaf71 (diff)
downloadpackages-2707df6cc761dcc2341faa8bafec5b4b4fa33e4d.tar.gz
packages-2707df6cc761dcc2341faa8bafec5b4b4fa33e4d.tar.bz2
packages-2707df6cc761dcc2341faa8bafec5b4b4fa33e4d.tar.xz
packages-2707df6cc761dcc2341faa8bafec5b4b4fa33e4d.zip
system/*, user/*: remove bashisms from initd scripts
Diffstat (limited to 'system/openrc')
-rw-r--r--system/openrc/APKBUILD6
-rw-r--r--system/openrc/modloop.initd7
-rw-r--r--system/openrc/sysfsconf.initd6
3 files changed, 10 insertions, 9 deletions
diff --git a/system/openrc/APKBUILD b/system/openrc/APKBUILD
index c59c0b642..6c41d9f99 100644
--- a/system/openrc/APKBUILD
+++ b/system/openrc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:
pkgname=openrc
pkgver=0.24.1
-pkgrel=7
+pkgrel=8
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="https://github.com/OpenRC/openrc"
arch="all"
@@ -95,6 +95,6 @@ d54630d40a2d6b10a325cb012d4efcda997a60c008ca953ce5d60059d3f267308a59dabddf93a5fc
99b542c0903ad6874b8c308b2e0660a4fe2ff9db962dfec65325cd12c368873a2ae800d5e6d42dc4deff775e1d5c0068869eb72581f7ab16e88d5738afe1d3dd hostname.initd
c06eac7264f6cc6888563feeae5ca745aae538323077903de1b19102e4f16baa34c18b8c27af5dd5423e7670834e2261e9aa55f2b1ec8d8fdc2be105fe894d55 hwdrivers.initd
b04058ec630e19de0bafefe06198dc1bff8c8d5d2c89e4660dd83dda8bb82a76cdb1d8661cce88e4a406aa6b4152e17efff52d3eb18ffaec0751d0b6cdbcc48a modules.initd
-92c0245ba4d7cc6828a9b68510fb541cf3b21b9b844a858336af60e84d1db62ddb4471aad0d82ef05d639335a81014f8350a71a746c2bcd90697daa6a8c03408 modloop.initd
+328e1f4cf3d9542ae47a517b900b57f383e0c0e24e24c52437667b72fa11d7986329dac176168ca9b6729cb412286f1ad8327771c85aa821c8b534b1bd860712 modloop.initd
aa702a7da8e6c0e5d8738febaf6b4e4cb021b30ce5c1809b530abf2b36739079446b16fc054740da8d86ed099942cf5deed6597cedb64c058f3def587a8b4689 modloop.confd
-d76c75c58e6f4b0801edac4e081b725ef3d50a9a8c9bbb5692bf4d0f804af7d383bf71a73d5d03ed348a89741ef0b2427eb6a7cbf5a9b9ff60a240639fa6ec88 sysfsconf.initd"
+02eb7a0b430f0dd985dc1a6cdcca41b1f0dca1a2c164364713ff6706511884295a1ccbd51c87686ffc197ca5cd093be5404fba98d21cf4e4076535706a67f106 sysfsconf.initd"
diff --git a/system/openrc/modloop.initd b/system/openrc/modloop.initd
index 9d664dd40..85ad2b165 100644
--- a/system/openrc/modloop.initd
+++ b/system/openrc/modloop.initd
@@ -24,9 +24,10 @@ mountdirs() {
find_modloop() {
local dir="$1"
- local kver=$(uname -r)
+ local kver="$(uname -r)"
local oifs="$IFS"
- IFS=$'\n'
+ IFS="
+"
set -- $(blkid "$dir"/boot/* "$dir"/*)
IFS="$oifs"
for line; do
@@ -42,7 +43,7 @@ find_modloop() {
find_backing_file() {
local dir="$1"
- local dev=$(df -P "$dir" | tail -1 | awk '{print $1}')
+ local dev="$(df -P "$dir" | tail -1 | awk '{print $1}')"
cat /sys/block/${dev#/dev/}/loop/backing_file 2>/dev/null
}
diff --git a/system/openrc/sysfsconf.initd b/system/openrc/sysfsconf.initd
index 433e51d63..5d4f9aeab 100644
--- a/system/openrc/sysfsconf.initd
+++ b/system/openrc/sysfsconf.initd
@@ -12,14 +12,14 @@ setval() {
local value="$1" attrib="$2"
# Some fields need a terminating newline, others
# need the terminating newline to be absent :-(
- echo -n "$value" > "$attrib" 2>/dev/null \
- || echo "$value" > "$attrib"
+ printf '%s' "$value" > "$attrib" 2>/dev/null \
+ || printf '%s\n' "$value" > "$attrib"
}
load_conffile() {
local file="$1"
while read line; do
- local line=${line%%#*}
+ local line="${line%%#*}"
local cmd= attrib= value=
set -- $line
if [ $# -eq 0 ]; then