summaryrefslogtreecommitdiff
path: root/system/patch/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-14 02:22:19 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-14 02:22:56 -0500
commitb1eb50599e4db7eb4501af75cbbfa22007081ea5 (patch)
treec94a34c882cc17adedd781e8c5f34349b2a62416 /system/patch/APKBUILD
parentb9e85bbdcf38547ef2ca4e5c2a6e6293bbcd2752 (diff)
downloadpackages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.tar.gz
packages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.tar.bz2
packages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.tar.xz
packages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.zip
The New Plan
all pkgs needed to bootstrap -> system others -> user
Diffstat (limited to 'system/patch/APKBUILD')
-rw-r--r--system/patch/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/system/patch/APKBUILD b/system/patch/APKBUILD
new file mode 100644
index 000000000..4c69c9273
--- /dev/null
+++ b/system/patch/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=patch
+pkgver=2.7.6
+pkgrel=2
+pkgdesc="Utility to apply diffs to files"
+url="https://www.gnu.org/software/patch/patch.html"
+arch="all"
+license="GPL-3.0+"
+depends=""
+makedepends=""
+checkdepends="bash ed"
+install=""
+subpackages="$pkgname-doc"
+source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
+ CVE-2018-6951.patch
+ "
+builddir="$srcdir"/$pkgname-$pkgver
+
+# secfixes:
+# 2.7.6-r2:
+# - CVE-2018-6951
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-nls
+ make
+}
+
+check() {
+ cd "$builddir"
+ make SHELL=bash check
+}
+
+package() {
+ make prefix="$pkgdir"/usr \
+ mandir="$pkgdir"/usr/share/man \
+ -C "$builddir" install
+
+ rm -f "$pkgdir"/usr/lib/charset.alias
+ rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
+}
+
+sha512sums="fcca87bdb67a88685a8a25597f9e015f5e60197b9a269fa350ae35a7991ed8da553939b4bbc7f7d3cfd863c67142af403b04165633acbce4339056a905e87fbd patch-2.7.6.tar.xz
+db51d0b791d38dd4f1b373621ee18620ae339b172f58a79420fdaa4a4b1b1d9df239cf61bbddc4e6a4896b28b8cffc7c99161eb5e2facaec8df86a1bf7755bc0 CVE-2018-6951.patch"