summaryrefslogtreecommitdiff
path: root/system/pcre
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-17 23:22:49 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-17 23:22:49 +0000
commit20051f4fda31ff81767e89b7ec74c56b1e6babda (patch)
tree909d95a4fd9b0155528f75b275eea0fdc8bf6f8b /system/pcre
parent02353fd420adab384e752477125bc140ea526134 (diff)
downloadpackages-20051f4fda31ff81767e89b7ec74c56b1e6babda.tar.gz
packages-20051f4fda31ff81767e89b7ec74c56b1e6babda.tar.bz2
packages-20051f4fda31ff81767e89b7ec74c56b1e6babda.tar.xz
packages-20051f4fda31ff81767e89b7ec74c56b1e6babda.zip
system/pcre: bump to 8.43, upstream ELFv2 fix (woo)
Diffstat (limited to 'system/pcre')
-rw-r--r--system/pcre/APKBUILD24
-rw-r--r--system/pcre/ppc64-elfv2-fix.patch25
2 files changed, 4 insertions, 45 deletions
diff --git a/system/pcre/APKBUILD b/system/pcre/APKBUILD
index eb2d468a9..0c0f36a10 100644
--- a/system/pcre/APKBUILD
+++ b/system/pcre/APKBUILD
@@ -1,20 +1,17 @@
# Contributor: Sergei Lukin <sergej.lukin@gmail.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=pcre
-pkgver=8.42
-pkgrel=1
+pkgver=8.43
+pkgrel=0
pkgdesc="Perl-compatible regular expression library"
url="http://pcre.sourceforge.net"
arch="all"
license="BSD-3-Clause"
depends=
makedepends=""
-checkdepends="paxmark"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools
libpcrecpp libpcre16 libpcre32"
-source="ftp://ftp.csx.cam.ac.uk/pub/software/programming/$pkgname/$pkgname-$pkgver.tar.bz2
- ppc64-elfv2-fix.patch
- "
+source="ftp://ftp.csx.cam.ac.uk/pub/software/programming/$pkgname/$pkgname-$pkgver.tar.bz2"
# secfixes:
# 8.40-r2:
@@ -22,10 +19,7 @@ source="ftp://ftp.csx.cam.ac.uk/pub/software/programming/$pkgname/$pkgname-$pkgv
# 7.8-r0:
# - CVE-2017-11164
-builddir="$srcdir/$pkgname-$pkgver"
-
build() {
- cd "$builddir"
local _enable_jit="--enable-jit"
[ "$CARCH" = "s390x" ] && _enable_jit=""
./configure \
@@ -46,19 +40,10 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
check() {
- cd "$builddir"
-
- # paxmark tests requiring JIT
- for fn in pcre_jit_test pcretest; do
- ./$fn &>/dev/null < /dev/null || true
- [ -x .libs/lt-$fn ] && paxmark -m .libs/lt-$fn
- done
-
# skip locale specific tests
sed -i -e 's/do3=yes//g' RunTest
@@ -89,5 +74,4 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="b47b923108f6ee0c31409b79d0888314271b482a22590e164d02f21d2112fba22dd0342c24f9ba0f5fcc5b8c65550bad08c476e30a2fc79b34ecf4601ed82f3d pcre-8.42.tar.bz2
-61f06b2fb1d1d0d512056da4b8eb4905948b45a26ee177b0bcc6d25a75ffbdaff29c4b52ec461a7287b4f47ae20dbec31382188934e855c960f5877c31948a4b ppc64-elfv2-fix.patch"
+sha512sums="3b4ac2c7ccd77c9575d07a33c3456f40b50731029e62d01fb8f2f5871d7118e12bc9e6bc7a8079769c765e38da5ecf98c4b261b10ff0a2f14f0881b434f67af7 pcre-8.43.tar.bz2"
diff --git a/system/pcre/ppc64-elfv2-fix.patch b/system/pcre/ppc64-elfv2-fix.patch
deleted file mode 100644
index 040f93ee9..000000000
--- a/system/pcre/ppc64-elfv2-fix.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -Naur pcre-8.42-original/sljit/sljitConfigInternal.h pcre-8.42/sljit/sljitConfigInternal.h
---- pcre-8.42-original/sljit/sljitConfigInternal.h 2018-03-13 16:15:23.000000000 +0000
-+++ pcre-8.42/sljit/sljitConfigInternal.h 2018-09-13 01:16:46.640000000 +0000
-@@ -530,7 +530,7 @@
- #endif /* !SLJIT_FUNC */
-
- #ifndef SLJIT_INDIRECT_CALL
--#if ((defined SLJIT_CONFIG_PPC_64 && SLJIT_CONFIG_PPC_64) && (defined SLJIT_BIG_ENDIAN && SLJIT_BIG_ENDIAN)) \
-+#if ((defined SLJIT_CONFIG_PPC_64 && SLJIT_CONFIG_PPC_64) && ((defined _CALL_ELF && _CALL_ELF == 1) || (!defined _CALL_ELF))) \
- || ((defined SLJIT_CONFIG_PPC_32 && SLJIT_CONFIG_PPC_32) && defined _AIX)
- /* It seems certain ppc compilers use an indirect addressing for functions
- which makes things complicated. */
-diff -Naur pcre-8.42-original/sljit/sljitNativePPC_common.c pcre-8.42/sljit/sljitNativePPC_common.c
---- pcre-8.42-original/sljit/sljitNativePPC_common.c 2018-01-08 10:25:56.000000000 +0000
-+++ pcre-8.42/sljit/sljitNativePPC_common.c 2018-09-13 01:21:00.360000000 +0000
-@@ -42,7 +42,8 @@
- #include <sys/cache.h>
- #endif
-
--#if (defined SLJIT_LITTLE_ENDIAN && SLJIT_LITTLE_ENDIAN)
-+#if (defined SLJIT_LITTLE_ENDIAN && SLJIT_LITTLE_ENDIAN) \
-+ || (defined _CALL_ELF && _CALL_ELF == 2)
- #define SLJIT_PASS_ENTRY_ADDR_TO_CALL 1
- #endif
-