summaryrefslogtreecommitdiff
path: root/system/perl-dbi
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-11-12 21:57:38 +0000
committerZach van Rijn <me@zv.io>2022-11-12 21:57:38 +0000
commitbfd5d459641570f515753567fe88836aa47e2479 (patch)
treebdbf6799b6d5c1663c152ae740dfb58b9b720a3b /system/perl-dbi
parentd69d0a69b3057ca44a7e54a967dfbb8b22145958 (diff)
downloadpackages-bfd5d459641570f515753567fe88836aa47e2479.tar.gz
packages-bfd5d459641570f515753567fe88836aa47e2479.tar.bz2
packages-bfd5d459641570f515753567fe88836aa47e2479.tar.xz
packages-bfd5d459641570f515753567fe88836aa47e2479.zip
system/perl-dbi: patch CVE-2014-10402. fixes #378.
Diffstat (limited to 'system/perl-dbi')
-rw-r--r--system/perl-dbi/APKBUILD9
-rw-r--r--system/perl-dbi/CVE-2014-10402.patch96
2 files changed, 102 insertions, 3 deletions
diff --git a/system/perl-dbi/APKBUILD b/system/perl-dbi/APKBUILD
index 972781f9b..fb928fa0a 100644
--- a/system/perl-dbi/APKBUILD
+++ b/system/perl-dbi/APKBUILD
@@ -6,7 +6,7 @@ _author=TIMB
_au=${_author%%"${_author#??}"}
_a=${_author%%"${_author#?}"}
pkgver=1.643
-pkgrel=0
+pkgrel=1
pkgdesc="Database independent interface for Perl"
url="https://metacpan.org/release/DBI"
arch="all"
@@ -14,7 +14,9 @@ license="GPL-2.0-only OR Artistic-1.0-Perl"
depends="perl"
makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz
+ CVE-2014-10402.patch
+ "
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
@@ -32,4 +34,5 @@ package() {
find "$pkgdir" -name perllocal.pod -delete
}
-sha512sums="03812f3eb1e43c8290dadb8cb14bbced9ec6e237228ea2a2ba91f22e52143906a91a7e82945dab30b1d1b9fc925073721111adafd9a09fac070808ab88f908b8 DBI-1.643.tar.gz"
+sha512sums="03812f3eb1e43c8290dadb8cb14bbced9ec6e237228ea2a2ba91f22e52143906a91a7e82945dab30b1d1b9fc925073721111adafd9a09fac070808ab88f908b8 DBI-1.643.tar.gz
+03abd86921c98a1d0b5fbe67af4e7b613832f7a29be544f1399b8a4ce93574e80313feba42a5ba650c42507670b1d528bb03e05c12520e369975e8e1a2292cc8 CVE-2014-10402.patch"
diff --git a/system/perl-dbi/CVE-2014-10402.patch b/system/perl-dbi/CVE-2014-10402.patch
new file mode 100644
index 000000000..bbe4d4963
--- /dev/null
+++ b/system/perl-dbi/CVE-2014-10402.patch
@@ -0,0 +1,96 @@
+From 19d0fb169eed475e1c053e99036b8668625cfa94 Mon Sep 17 00:00:00 2001
+From: Jens Rehsack <sno@netbsd.org>
+Date: Tue, 6 Oct 2020 10:22:17 +0200
+Subject: [PATCH] lib/DBD/File.pm: fix CVE-2014-10401
+
+Dig into the root cause of RT#99508 - which resulted in CVE-2014-10401 - and
+figure out that DBI->parse_dsn is the wrong helper to parse our attributes in
+DSN, since in DBD::dr::connect only the "dbname" remains from DSN which causes
+parse_dsn to bailout.
+
+Parsing on our own similar to parse_dsn shows the way out.
+
+Signed-off-by: Jens Rehsack <sno@netbsd.org>
+---
+ lib/DBD/File.pm | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/lib/DBD/File.pm b/lib/DBD/File.pm
+index fb14e9a..f55076f 100644
+--- a/lib/DBD/File.pm
++++ b/lib/DBD/File.pm
+@@ -109,7 +109,11 @@ sub connect
+ # We do not (yet) care about conflicting attributes here
+ # my $dbh = DBI->connect ("dbi:CSV:f_dir=test", undef, undef, { f_dir => "text" });
+ # will test here that both test and text should exist
+- if (my $attr_hash = (DBI->parse_dsn ($dbname))[3]) {
++ #
++ # Parsing on our own similar to parse_dsn to find attributes in 'dbname' parameter.
++ if ($dbname) {
++ my @attrs = split /;/ => $dbname;
++ my $attr_hash = { map { split /\s*=>?\s*|\s*,\s*/, $_} @attrs };
+ if (defined $attr_hash->{f_dir} && ! -d $attr_hash->{f_dir}) {
+ my $msg = "No such directory '$attr_hash->{f_dir}";
+ $drh->set_err (2, $msg);
+@@ -120,7 +124,6 @@ sub connect
+ if ($attr and defined $attr->{f_dir} && ! -d $attr->{f_dir}) {
+ my $msg = "No such directory '$attr->{f_dir}";
+ $drh->set_err (2, $msg);
+- $attr->{RaiseError} and croak $msg;
+ return;
+ }
+
+From 27b10b5c3aacabc091046beaba478e671bb6111c Mon Sep 17 00:00:00 2001
+From: Jens Rehsack <sno@netbsd.org>
+Date: Tue, 6 Oct 2020 08:23:55 +0200
+Subject: [PATCH] t/51dbm_file.t: add test from RT#99508
+
+Add test with f_dir="something-not-existing" as reported in RT#99508
+to verify when it's fixed for real.
+
+Signed-off-by: Jens Rehsack <sno@netbsd.org>
+---
+ t/51dbm_file.t | 23 +++++++++++++++++++++++
+ 1 file changed, 23 insertions(+)
+
+diff --git a/t/51dbm_file.t b/t/51dbm_file.t
+index d9824cf..686a3d2 100644
+--- a/t/51dbm_file.t
++++ b/t/51dbm_file.t
+@@ -15,6 +15,27 @@ use DBI;
+
+ do "./t/lib.pl";
+
++{
++ # test issue reported in RT#99508
++ my @msg;
++ eval {
++ local $SIG{__DIE__} = sub { push @msg, @_ };
++ my $dbh = DBI->connect ("dbi:DBM:f_dir=./hopefully-doesnt-existst;sql_identifier_case=1;RaiseError=1");
++ };
++ like ("@msg", qr{.*hopefully-doesnt-existst.*}, "Cannot open from non-existing directory with attributes in DSN");
++
++ @msg = ();
++ eval {
++ local $SIG{__DIE__} = sub { push @msg, @_ };
++ my $dbh = DBI->connect ("dbi:DBM:", , undef, undef, {
++ f_dir => "./hopefully-doesnt-existst",
++ sql_identifier_case => 1,
++ RaiseError => 1,
++ });
++ };
++ like ("@msg", qr{.*hopefully-doesnt-existst}, "Cannot open from non-existing directory with attributes in HASH");
++}
++
+ my $dir = test_dir();
+
+ my $dbh = DBI->connect( 'dbi:DBM:', undef, undef, {
+@@ -23,6 +44,8 @@ my $dbh = DBI->connect( 'dbi:DBM:', undef, undef, {
+ }
+ );
+
++ok( $dbh, "Connect with driver attributes in hash" );
++
+ ok( $dbh->do(q/drop table if exists FRED/), 'drop table' );
+
+ my $dirfext = $^O eq 'VMS' ? '.sdbm_dir' : '.dir';