summaryrefslogtreecommitdiff
path: root/system/perl-extutils-installpaths
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-16 17:32:05 -0400
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-17 13:45:34 -0400
commit8afb6ffbf97bc59a6b97d110bf88c9357be5ad83 (patch)
tree7ce023108734fe7872b54addbb4259050d6a0e0c /system/perl-extutils-installpaths
parente61f79983d1f626916f5f67e54b9d2ffecf4b2ee (diff)
downloadpackages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.gz
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.bz2
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.xz
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.zip
system/perl-*: modernise
Diffstat (limited to 'system/perl-extutils-installpaths')
-rw-r--r--system/perl-extutils-installpaths/APKBUILD22
1 files changed, 7 insertions, 15 deletions
diff --git a/system/perl-extutils-installpaths/APKBUILD b/system/perl-extutils-installpaths/APKBUILD
index df8d7dcf0..a76b4ea16 100644
--- a/system/perl-extutils-installpaths/APKBUILD
+++ b/system/perl-extutils-installpaths/APKBUILD
@@ -3,39 +3,31 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-extutils-installpaths
_pkgreal=ExtUtils-InstallPaths
+_author=LEONT
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.012
pkgrel=0
pkgdesc="Build.PL install path logic made easy"
url="https://metacpan.org/release/ExtUtils-InstallPaths"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
-cpandepends="perl-extutils-config"
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+depends="perl-extutils-config"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/L/LE/LEONT/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}