summaryrefslogtreecommitdiff
path: root/system/perl-extutils-installpaths
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 17:54:02 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 17:54:02 -0500
commit147207444432d8fd6f2723269076126f1f8cc9ec (patch)
treea8a27ad41af8f273d8bc0d7e1e04160beeeba6c1 /system/perl-extutils-installpaths
parent041bd4375b81ab80bb441183d2c3a8c7f965917d (diff)
downloadpackages-147207444432d8fd6f2723269076126f1f8cc9ec.tar.gz
packages-147207444432d8fd6f2723269076126f1f8cc9ec.tar.bz2
packages-147207444432d8fd6f2723269076126f1f8cc9ec.tar.xz
packages-147207444432d8fd6f2723269076126f1f8cc9ec.zip
system/perl-extutils-installpaths: pull in for perl-module-build-tiny
Diffstat (limited to 'system/perl-extutils-installpaths')
-rw-r--r--system/perl-extutils-installpaths/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/system/perl-extutils-installpaths/APKBUILD b/system/perl-extutils-installpaths/APKBUILD
new file mode 100644
index 000000000..459c61276
--- /dev/null
+++ b/system/perl-extutils-installpaths/APKBUILD
@@ -0,0 +1,43 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-extutils-installpaths
+_pkgreal=ExtUtils-InstallPaths
+pkgver=0.012
+pkgrel=0
+pkgdesc="Build.PL install path logic made easy"
+url="http://search.cpan.org/dist/ExtUtils-InstallPaths/"
+arch="noarch"
+license="GPL-2.0-only OR Artistic-1.0-Perl"
+cpandepends="perl-extutils-config"
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/L/LE/LEONT/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="92a4e9ebb387d330ae67b0716b96b27165d08503d2915d8301b3a6aa185f962940e761d21fd400033e6a814e276918e0662da3740ca2852a53cf0fe54f3d7660 ExtUtils-InstallPaths-0.012.tar.gz"