summaryrefslogtreecommitdiff
path: root/system/perl-file-listing/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 04:07:27 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 04:07:27 -0500
commitc108b3bc6b9b67afff24f73055987fe82a8a6413 (patch)
tree738f8dc0a79941d252e226709cbdbcb9e525b80b /system/perl-file-listing/APKBUILD
parent60d6c1258943d94a21a3746bbff87f91b24036f7 (diff)
downloadpackages-c108b3bc6b9b67afff24f73055987fe82a8a6413.tar.gz
packages-c108b3bc6b9b67afff24f73055987fe82a8a6413.tar.bz2
packages-c108b3bc6b9b67afff24f73055987fe82a8a6413.tar.xz
packages-c108b3bc6b9b67afff24f73055987fe82a8a6413.zip
system/perl-file-listing: add for lwp
Diffstat (limited to 'system/perl-file-listing/APKBUILD')
-rw-r--r--system/perl-file-listing/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/system/perl-file-listing/APKBUILD b/system/perl-file-listing/APKBUILD
new file mode 100644
index 000000000..4e36cd844
--- /dev/null
+++ b/system/perl-file-listing/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-file-listing
+pkgver=6.04
+pkgrel=2
+pkgdesc="File::Listing perl module"
+url="http://search.cpan.org/dist/File-Listing/"
+arch="noarch"
+license="GPL-2.0-only OR Artistic-1.0-Perl"
+depends="perl perl-http-date"
+makedepends="perl-dev"
+install=""
+replaces="perl-libwww"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/File-Listing-$pkgver.tar.gz"
+
+builddir="$srcdir"/File-Listing-$pkgver
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="a84198bc82003daaf88ed23218e34a7a1552dcd2855a9563e9609ce5df167a8295043501534c31614854fc8dd9c04b4af27b4d7320112c613914f94c86c2eeb2 File-Listing-6.04.tar.gz"