summaryrefslogtreecommitdiff
path: root/system/perl-file-listing/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-10-17 22:52:43 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-10-17 22:52:43 +0000
commit3401220890b38e9d9bd3c50bed2a88f98bc8e645 (patch)
tree3533c905623209cb1525c2c1a935d710b18d7efc /system/perl-file-listing/APKBUILD
parentc665adb6aa1d2253d650989bd6f72ceca79747d1 (diff)
parentb163eb1b88e25226d5a45816367522bffac0a978 (diff)
downloadpackages-3401220890b38e9d9bd3c50bed2a88f98bc8e645.tar.gz
packages-3401220890b38e9d9bd3c50bed2a88f98bc8e645.tar.bz2
packages-3401220890b38e9d9bd3c50bed2a88f98bc8e645.tar.xz
packages-3401220890b38e9d9bd3c50bed2a88f98bc8e645.zip
Merge branch 'perl.authors' into 'master'
Modernise Perl packages See merge request adelie/packages!367
Diffstat (limited to 'system/perl-file-listing/APKBUILD')
-rw-r--r--system/perl-file-listing/APKBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/system/perl-file-listing/APKBUILD b/system/perl-file-listing/APKBUILD
index db9ea786a..2f90ff91f 100644
--- a/system/perl-file-listing/APKBUILD
+++ b/system/perl-file-listing/APKBUILD
@@ -1,34 +1,32 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-file-listing
+_pkgreal=File-Listing
+_author=GAAS
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=6.04
pkgrel=2
-pkgdesc="File::Listing perl module"
+pkgdesc="Perl module for parsing directory lists in various formats"
url="https://metacpan.org/release/File-Listing"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
-depends="perl perl-http-date"
-makedepends="perl-dev"
-install=""
-replaces="perl-libwww"
+depends="perl-http-date"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/G/GA/GAAS/File-Listing-$pkgver.tar.gz"
-
-builddir="$srcdir"/File-Listing-$pkgver
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}