summaryrefslogtreecommitdiff
path: root/system/perl-lwp-mediatypes
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-16 17:32:05 -0400
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-17 13:45:34 -0400
commit8afb6ffbf97bc59a6b97d110bf88c9357be5ad83 (patch)
tree7ce023108734fe7872b54addbb4259050d6a0e0c /system/perl-lwp-mediatypes
parente61f79983d1f626916f5f67e54b9d2ffecf4b2ee (diff)
downloadpackages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.gz
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.bz2
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.xz
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.zip
system/perl-*: modernise
Diffstat (limited to 'system/perl-lwp-mediatypes')
-rw-r--r--system/perl-lwp-mediatypes/APKBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/system/perl-lwp-mediatypes/APKBUILD b/system/perl-lwp-mediatypes/APKBUILD
index b1042949d..d072a2935 100644
--- a/system/perl-lwp-mediatypes/APKBUILD
+++ b/system/perl-lwp-mediatypes/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-lwp-mediatypes
-_realname=LWP-MediaTypes
-_author1=O
-_author2=${_author1}A
-_author=${_author2}LDERS
+_pkgreal=LWP-MediaTypes
+_author=OALDERS
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=6.04
pkgrel=0
pkgdesc="Perl module - guess media type for a file or a URL"
@@ -12,29 +12,23 @@ url="https://metacpan.org/release/LWP-MediaTypes"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
depends="perl"
-makedepends="perl-dev"
+makedepends=""
checkdepends="perl-test-fatal"
-install=
-replaces="perl-libwww"
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/$_author1/$_author2/$_author/$_realname-$pkgver.tar.gz"
-builddir="$srcdir/$_realname-$pkgver"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
- # creates file collision among perl modules
find "$pkgdir" -name perllocal.pod -delete
}