summaryrefslogtreecommitdiff
path: root/system/perl-pod2-base
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-16 17:32:05 -0400
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-17 13:45:34 -0400
commit8afb6ffbf97bc59a6b97d110bf88c9357be5ad83 (patch)
tree7ce023108734fe7872b54addbb4259050d6a0e0c /system/perl-pod2-base
parente61f79983d1f626916f5f67e54b9d2ffecf4b2ee (diff)
downloadpackages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.gz
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.bz2
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.xz
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.zip
system/perl-*: modernise
Diffstat (limited to 'system/perl-pod2-base')
-rw-r--r--system/perl-pod2-base/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/system/perl-pod2-base/APKBUILD b/system/perl-pod2-base/APKBUILD
index 28d409678..5ba39c600 100644
--- a/system/perl-pod2-base/APKBUILD
+++ b/system/perl-pod2-base/APKBUILD
@@ -1,6 +1,10 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-pod2-base
+_pkgreal=POD2-Base
+_author=FERREIRA
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.043
pkgrel=0
pkgdesc="Base module for POD translations"
@@ -8,23 +12,21 @@ url="https://metacpan.org/pod/distribution/POD2-Base/lib/POD2/Base.pod"
arch="noarch"
license="Artistic-1.0-Perl AND GPL-2.0+"
depends="perl"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/F/FE/FERREIRA/POD2-Base-$pkgver.tar.gz"
-builddir="$srcdir/POD2-Base-$pkgver"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}