summaryrefslogtreecommitdiff
path: root/system/perl-test-exception
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 18:33:55 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 18:33:55 -0500
commit53a0d32b0bebcfcb7102b8f1143abd97f692cb6c (patch)
treef321f42e86d785b12dd6b9f8e6c61f7483642b1e /system/perl-test-exception
parentd3871c12919651e2fce3459195d36577c434e23f (diff)
downloadpackages-53a0d32b0bebcfcb7102b8f1143abd97f692cb6c.tar.gz
packages-53a0d32b0bebcfcb7102b8f1143abd97f692cb6c.tar.bz2
packages-53a0d32b0bebcfcb7102b8f1143abd97f692cb6c.tar.xz
packages-53a0d32b0bebcfcb7102b8f1143abd97f692cb6c.zip
system/perl-test-exception: add for perl-net-ssleay
Diffstat (limited to 'system/perl-test-exception')
-rw-r--r--system/perl-test-exception/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/system/perl-test-exception/APKBUILD b/system/perl-test-exception/APKBUILD
new file mode 100644
index 000000000..25a978be2
--- /dev/null
+++ b/system/perl-test-exception/APKBUILD
@@ -0,0 +1,38 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-test-exception
+_pkgreal=Test-Exception
+pkgver=0.43
+pkgrel=0
+pkgdesc="Perl module for testing exception-based code"
+url="http://search.cpan.org/dist/Test-Exception/"
+arch="noarch"
+license="GPL-2.0-only OR Artistic-1.0-Perl"
+cpandepends="perl-sub-uplevel"
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/E/EX/EXODIST/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="f5ab65ce7b142ab7a96b0075838826a7f6b975a151a285e00d99db307bea07b359d5ca44eb678ba93d97b2ae37a112f0002ae1c06bb6e5654b80ce8c5473aa20 Test-Exception-0.43.tar.gz"