summaryrefslogtreecommitdiff
path: root/system/perl-test-warnings
diff options
context:
space:
mode:
authorSíle Ekaterin Liszka <sheila@vulpine.house>2022-12-11 16:08:21 +0000
committerZach van Rijn <me@zv.io>2023-02-08 16:26:06 +0000
commit8458d2a1886cd6491bfc365a07b499f6ea8b6221 (patch)
treedba861aeac1f7f11c13c3c21274a089a53092f3c /system/perl-test-warnings
parentb0c0732364113e3ad5506b9529e8b73dbfd8b86c (diff)
downloadpackages-8458d2a1886cd6491bfc365a07b499f6ea8b6221.tar.gz
packages-8458d2a1886cd6491bfc365a07b499f6ea8b6221.tar.bz2
packages-8458d2a1886cd6491bfc365a07b499f6ea8b6221.tar.xz
packages-8458d2a1886cd6491bfc365a07b499f6ea8b6221.zip
{user => system}/perl-test-warnings: needed for perl-uri-5.17
Diffstat (limited to 'system/perl-test-warnings')
-rw-r--r--system/perl-test-warnings/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/system/perl-test-warnings/APKBUILD b/system/perl-test-warnings/APKBUILD
new file mode 100644
index 000000000..8dace4f45
--- /dev/null
+++ b/system/perl-test-warnings/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Dan Theisen <djt@hxx.in>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=perl-test-warnings
+_pkgreal=Test-Warnings
+_author=ETHER
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
+pkgver=0.031
+pkgrel=0
+pkgdesc="Test for warnings and the lack of them"
+url="https://metacpan.org/pod/Test::Warnings"
+arch="noarch"
+license="Artistic-1.0-Perl OR GPL-1.0+"
+depends="perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="02ddd342b6aa8771dd6ea3b7385c5eb970173633d49a3535bc46c3f98a66cd6e81895fc5f38cbe23366c8fa0f96121b51a8180b0d4ef0f2d8c658bb559c72c58 Test-Warnings-0.031.tar.gz"