summaryrefslogtreecommitdiff
path: root/system/perl-test-without-module/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-10-17 22:52:43 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-10-17 22:52:43 +0000
commit3401220890b38e9d9bd3c50bed2a88f98bc8e645 (patch)
tree3533c905623209cb1525c2c1a935d710b18d7efc /system/perl-test-without-module/APKBUILD
parentc665adb6aa1d2253d650989bd6f72ceca79747d1 (diff)
parentb163eb1b88e25226d5a45816367522bffac0a978 (diff)
downloadpackages-3401220890b38e9d9bd3c50bed2a88f98bc8e645.tar.gz
packages-3401220890b38e9d9bd3c50bed2a88f98bc8e645.tar.bz2
packages-3401220890b38e9d9bd3c50bed2a88f98bc8e645.tar.xz
packages-3401220890b38e9d9bd3c50bed2a88f98bc8e645.zip
Merge branch 'perl.authors' into 'master'
Modernise Perl packages See merge request adelie/packages!367
Diffstat (limited to 'system/perl-test-without-module/APKBUILD')
-rw-r--r--system/perl-test-without-module/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/system/perl-test-without-module/APKBUILD b/system/perl-test-without-module/APKBUILD
index b39692dc2..5f66fa835 100644
--- a/system/perl-test-without-module/APKBUILD
+++ b/system/perl-test-without-module/APKBUILD
@@ -2,30 +2,31 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-test-without-module
_pkgreal=Test-Without-Module
+_author=CORION
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.20
pkgrel=0
pkgdesc="Test fallback behaviour in absence of Perl modules"
url="https://metacpan.org/release/Test-Without-Module"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
-makedepends="perl-dev"
+depends="perl"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/C/CO/CORION/Test-Without-Module-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgreal-$pkgver
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}