summaryrefslogtreecommitdiff
path: root/system/perl-test-without-module
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 06:06:13 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-26 06:06:13 -0500
commit2cc203cfb9bbd48ed7919116718a183e5a164637 (patch)
treed14f41465dbf5fa01d71bff0b859ae95bd0999e2 /system/perl-test-without-module
parentbef8f58b3884cca60f4acddce22b62380d0729e9 (diff)
downloadpackages-2cc203cfb9bbd48ed7919116718a183e5a164637.tar.gz
packages-2cc203cfb9bbd48ed7919116718a183e5a164637.tar.bz2
packages-2cc203cfb9bbd48ed7919116718a183e5a164637.tar.xz
packages-2cc203cfb9bbd48ed7919116718a183e5a164637.zip
system/perl-test-without-module: pull in for perl-json-maybexs
Diffstat (limited to 'system/perl-test-without-module')
-rw-r--r--system/perl-test-without-module/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/system/perl-test-without-module/APKBUILD b/system/perl-test-without-module/APKBUILD
new file mode 100644
index 000000000..48eb1162f
--- /dev/null
+++ b/system/perl-test-without-module/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-test-without-module
+_pkgreal=Test-Without-Module
+pkgver=0.20
+pkgrel=0
+pkgdesc="Test fallback behaviour in absence of Perl modules"
+url="https://metacpan.org/pod/Test::Without::Module"
+arch="noarch"
+license="GPL-2.0-only OR Artistic-1.0-Perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/C/CO/CORION/Test-Without-Module-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgreal-$pkgver
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="e92353cee46e712ddc6515c5872a61a84eb4186f9ce736bbf0fcca2979bfa7143588c05e683d31fc22cbaaa792ce8364768310f9de621e881cc207b80cf14d87 Test-Without-Module-0.20.tar.gz"