summaryrefslogtreecommitdiff
path: root/system/perl-uri
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-16 17:32:05 -0400
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-17 13:45:34 -0400
commit8afb6ffbf97bc59a6b97d110bf88c9357be5ad83 (patch)
tree7ce023108734fe7872b54addbb4259050d6a0e0c /system/perl-uri
parente61f79983d1f626916f5f67e54b9d2ffecf4b2ee (diff)
downloadpackages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.gz
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.bz2
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.xz
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.zip
system/perl-*: modernise
Diffstat (limited to 'system/perl-uri')
-rw-r--r--system/perl-uri/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/system/perl-uri/APKBUILD b/system/perl-uri/APKBUILD
index 9d8fe204e..13763a256 100644
--- a/system/perl-uri/APKBUILD
+++ b/system/perl-uri/APKBUILD
@@ -1,6 +1,10 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-uri
+_pkgreal=URI
+_author=OALDERS
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=1.76
pkgrel=0
pkgdesc="Perl library for URI manipulation"
@@ -8,26 +12,23 @@ url="https://metacpan.org/release/URI"
arch="noarch"
license="GPL-1.0+ OR Artistic-1.0-Perl"
depends="perl"
-makedepends="$depends"
+makedepends=""
checkdepends="perl-test-needs"
subpackages="$pkgname-doc"
provides="perl-uri-escape=$pkgver-r$pkgrel"
-source="https://cpan.metacpan.org/authors/id/O/OA/OALDERS/URI-$pkgver.tar.gz"
-builddir="$srcdir/URI-$pkgver"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}