summaryrefslogtreecommitdiff
path: root/system/perl/APKBUILD
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-08-18 09:03:58 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:34:02 -0500
commit14b334385d2bd752b988f2fde7ff97690a8aed52 (patch)
tree951a6869234854e0e47f68f923aa1ad148cf6f45 /system/perl/APKBUILD
parent8bf016f47ea68e6a0f0d3d50480da8b0604bfd34 (diff)
downloadpackages-14b334385d2bd752b988f2fde7ff97690a8aed52.tar.gz
packages-14b334385d2bd752b988f2fde7ff97690a8aed52.tar.bz2
packages-14b334385d2bd752b988f2fde7ff97690a8aed52.tar.xz
packages-14b334385d2bd752b988f2fde7ff97690a8aed52.zip
system/perl: improve test speed. avoid race. fixes #782.
This may not fully mitigate a race condition, but has been shown to work consistently on platforms (e.g. pmmx) where this had been previously an issue.
Diffstat (limited to 'system/perl/APKBUILD')
-rw-r--r--system/perl/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/system/perl/APKBUILD b/system/perl/APKBUILD
index cc8a2c781..c63f7c2e2 100644
--- a/system/perl/APKBUILD
+++ b/system/perl/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl
pkgver=5.34.1
-pkgrel=0
+pkgrel=1
pkgdesc="Larry Wall's Practical Extraction and Report Language"
url="https://www.perl.org/"
arch="all"
@@ -89,7 +89,11 @@ build() {
}
check() {
- TEST_JOBS=$JOBS make test_harness
+ # https://perldoc.perl.org/perlhack.txt
+ export LC_ALL=C
+ export TEST_JOBS=${JOBS}
+ export PERL_TEST_HARNESS_ASAP=1
+ make -j${JOBS} test_harness_notty
}
package() {