summaryrefslogtreecommitdiff
path: root/system/perl/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 10:28:46 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 10:28:46 +0000
commitd6a8ba9c4f2c0dc8dfc3a5892b3e447fbf68da42 (patch)
tree20db48faad846c710e2a4c432d732e4773a2e389 /system/perl/APKBUILD
parentd896c7fcd2ada3cae147f70470c05ef5a0360acb (diff)
downloadpackages-d6a8ba9c4f2c0dc8dfc3a5892b3e447fbf68da42.tar.gz
packages-d6a8ba9c4f2c0dc8dfc3a5892b3e447fbf68da42.tar.bz2
packages-d6a8ba9c4f2c0dc8dfc3a5892b3e447fbf68da42.tar.xz
packages-d6a8ba9c4f2c0dc8dfc3a5892b3e447fbf68da42.zip
user/*: Modernise / fix syntax
Diffstat (limited to 'system/perl/APKBUILD')
-rw-r--r--system/perl/APKBUILD4
1 files changed, 0 insertions, 4 deletions
diff --git a/system/perl/APKBUILD b/system/perl/APKBUILD
index 0fc25d609..f65edd034 100644
--- a/system/perl/APKBUILD
+++ b/system/perl/APKBUILD
@@ -37,7 +37,6 @@ _archlib=/usr/lib/perl5/core_perl
prepare() {
chmod +w "$builddir"/*.c
default_prepare
- cd "$builddir"
sed -e 's/less -R/less/g' \
-e 's/libswanted="\(.*\) nsl\(.*\)"/libswanted="\1\2"/g' \
-i ./Configure ||
@@ -50,7 +49,6 @@ prepare() {
}
build() {
- cd "$builddir"
BUILD_ZLIB=0
BUILD_BZIP2=0
BZIP2_LIB=/usr/lib
@@ -89,12 +87,10 @@ build() {
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
if [ -n "$(find $pkgdir/usr/local -type f)" ]; then
error "files found under /usr/local"