summaryrefslogtreecommitdiff
path: root/system/python3/APKBUILD
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-01-11 12:51:26 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-01 17:05:43 -0500
commit5c5f97caca3c9a038732f2732f704d839665ef4e (patch)
treeafefcec5b123fc9b7dacbc290938f3efe7bb0426 /system/python3/APKBUILD
parentf17fb4e27d5014a3f582721cebd44bce6dbfa2ca (diff)
downloadpackages-5c5f97caca3c9a038732f2732f704d839665ef4e.tar.gz
packages-5c5f97caca3c9a038732f2732f704d839665ef4e.tar.bz2
packages-5c5f97caca3c9a038732f2732f704d839665ef4e.tar.xz
packages-5c5f97caca3c9a038732f2732f704d839665ef4e.zip
system/python3: bump { 3.6.10 --> 3.10.1 }. fixes #232, 450.
Diffstat (limited to 'system/python3/APKBUILD')
-rw-r--r--system/python3/APKBUILD28
1 files changed, 9 insertions, 19 deletions
diff --git a/system/python3/APKBUILD b/system/python3/APKBUILD
index a6d47495b..b3d971c8e 100644
--- a/system/python3/APKBUILD
+++ b/system/python3/APKBUILD
@@ -1,16 +1,15 @@
# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=python3
-pkgver=3.6.10
+pkgver=3.10.1
_basever="${pkgver%.*}"
-pkgrel=2
+pkgrel=0
pkgdesc="A high-level scripting language"
url="https://www.python.org"
arch="all"
license="Python-2.0"
provides="py3-pip"
-subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-tests::noarch
- $pkgname-wininst"
+subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-tests::noarch"
# If Python 3 is installed during the build, you get:
#
# Installing collected packages: setuptools, pip
@@ -40,7 +39,6 @@ makedepends="expat-dev openssl-dev zlib-dev ncurses-dev bzip2-dev xz-dev
source="https://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz
musl-find_library.patch
fix-xattrs-glibc.patch
- CVE-2019-18348.patch
"
builddir="$srcdir/Python-$pkgver"
@@ -70,7 +68,6 @@ prepare() {
# force system libs
rm -r Modules/expat \
- Modules/zlib \
Modules/_ctypes/darwin* \
Modules/_ctypes/libffi*
}
@@ -122,6 +119,7 @@ EOF
# musl related
fail="test__locale test_locale test_strptime test_re" # various musl locale deficiencies
+ fail="$fail test_c_locale_coercion"
fail="$fail test_datetime" # hangs if 'tzdata' installed
fail="$fail test_os" # fpathconf, ttyname errno values
fail="$fail test_posix" # sched_[gs]etscheduler not impl
@@ -168,9 +166,9 @@ dev() {
default_dev
# pyconfig.h is needed runtime so we move it back
- mkdir -p "$pkgdir"/usr/include/python${_basever}m
- mv "$subpkgdir"/usr/include/python${_basever}m/pyconfig.h \
- "$pkgdir"/usr/include/python${_basever}m/
+ mkdir -p "$pkgdir"/usr/include/python${_basever}
+ mv "$subpkgdir"/usr/include/python${_basever}/pyconfig.h \
+ "$pkgdir"/usr/include/python${_basever}/
}
tests() {
@@ -186,14 +184,6 @@ tests() {
"$subpkgdir"/usr/lib/python$_basever/
}
-wininst() {
- pkgdesc="Python wininst files"
- mkdir -p "$subpkgdir"/usr/lib/python$_basever/distutils/command
- mv "$pkgdir"/usr/lib/python$_basever/distutils/command/*.exe \
- "$subpkgdir"/usr/lib/python$_basever/distutils/command
-}
-
-sha512sums="26147099e1f1a0ffc85febad26e18e991f019599a150887ea0b925e34663fad8e03b3c2a941e2770c1a63960695e173ef32709572c9361e7f2cb862ccf75b28a Python-3.6.10.tar.xz
+sha512sums="1c559e33f1252e51bafb941c380de16f142c0735858363c84cb8dbed6767843de3af126889c2826ffb94bd4777d7cdfc31040301c8c74de56af52b80b1aa9e76 Python-3.10.1.tar.xz
ab8eaa2858d5109049b1f9f553198d40e0ef8d78211ad6455f7b491af525bffb16738fed60fc84e960c4889568d25753b9e4a1494834fea48291b33f07000ec2 musl-find_library.patch
-37b6ee5d0d5de43799316aa111423ba5a666c17dc7f81b04c330f59c1d1565540eac4c585abe2199bbed52ebe7426001edb1c53bd0a17486a2a8e052d0f494ad fix-xattrs-glibc.patch
-7a15409165feb60358455b711f978b7b1c4dea9ad53aa7b5be07c1f70262988e592e7a630f83125f37051bbed14d14b66d2acd775234a163ff5b048621b9a59c CVE-2019-18348.patch"
+4b4696d139e53aad184b72461478821335aadedc4811ec9e96cdea9a4f7ef19ebf0aac8c6afae6345f33c79fbd3ae2c63021de36044a2803d0dc8894fa291cf5 fix-xattrs-glibc.patch"