summaryrefslogtreecommitdiff
path: root/system/python3/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-09-28 19:20:44 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-09-28 19:20:44 +0000
commit7cec36c2876610cbfb5a8238b107ed0de479f978 (patch)
treeb237d6222e5beb8049ffd77850037281edbde353 /system/python3/APKBUILD
parent551b3650fcb5c065ca18f99fe8f2318ecad0209c (diff)
parent48545ebadf2369ca84622698234df68b8b36dba6 (diff)
downloadpackages-7cec36c2876610cbfb5a8238b107ed0de479f978.tar.gz
packages-7cec36c2876610cbfb5a8238b107ed0de479f978.tar.bz2
packages-7cec36c2876610cbfb5a8238b107ed0de479f978.tar.xz
packages-7cec36c2876610cbfb5a8238b107ed0de479f978.zip
Merge branch 'auto-system' into 'master'
Fixes for auto-building system/, part one See merge request adelie/packages!339
Diffstat (limited to 'system/python3/APKBUILD')
-rw-r--r--system/python3/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/system/python3/APKBUILD b/system/python3/APKBUILD
index f14f72b1c..250f259b6 100644
--- a/system/python3/APKBUILD
+++ b/system/python3/APKBUILD
@@ -136,7 +136,13 @@ EOF
# dumb
fail="$fail test_ssl" # tries to do SSLv2 which we have disabled in OpenSSL
- make quicktest TESTOPTS="--exclude $fail"
+ # needs network but doesn't declare it
+ fail="$fail test_normalization"
+
+ # defaults from Tools/scripts/run_tests.py, with -network added
+ use="all,-largefile,-audio,-gui,-network"
+
+ make quicktest TESTOPTS="--use '$use' --exclude $fail"
}
package() {