summaryrefslogtreecommitdiff
path: root/system/python3
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-09-10 14:39:19 -0500
committerMax Rees <maxcrees@me.com>2019-09-28 13:27:42 -0500
commit12fb37d5f3aee470b90c4ea04e369e288258ae5b (patch)
tree7badc62a67e238137f363b1c8ca684e64b66a239 /system/python3
parent551b3650fcb5c065ca18f99fe8f2318ecad0209c (diff)
downloadpackages-12fb37d5f3aee470b90c4ea04e369e288258ae5b.tar.gz
packages-12fb37d5f3aee470b90c4ea04e369e288258ae5b.tar.bz2
packages-12fb37d5f3aee470b90c4ea04e369e288258ae5b.tar.xz
packages-12fb37d5f3aee470b90c4ea04e369e288258ae5b.zip
system/python3: fix test suite network access
Diffstat (limited to 'system/python3')
-rw-r--r--system/python3/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/system/python3/APKBUILD b/system/python3/APKBUILD
index f14f72b1c..250f259b6 100644
--- a/system/python3/APKBUILD
+++ b/system/python3/APKBUILD
@@ -136,7 +136,13 @@ EOF
# dumb
fail="$fail test_ssl" # tries to do SSLv2 which we have disabled in OpenSSL
- make quicktest TESTOPTS="--exclude $fail"
+ # needs network but doesn't declare it
+ fail="$fail test_normalization"
+
+ # defaults from Tools/scripts/run_tests.py, with -network added
+ use="all,-largefile,-audio,-gui,-network"
+
+ make quicktest TESTOPTS="--use '$use' --exclude $fail"
}
package() {