summaryrefslogtreecommitdiff
path: root/system/python3
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-04-25 01:01:43 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-01 17:06:41 -0500
commitbc13861de96170d4f3f29678f719471779da7e56 (patch)
treea74867251d88e2dcc89841945fb5b2375d237eab /system/python3
parent22747bf024fec1bd6fb01cb711621253b08cc050 (diff)
downloadpackages-bc13861de96170d4f3f29678f719471779da7e56.tar.gz
packages-bc13861de96170d4f3f29678f719471779da7e56.tar.bz2
packages-bc13861de96170d4f3f29678f719471779da7e56.tar.xz
packages-bc13861de96170d4f3f29678f719471779da7e56.zip
system/python3: Revert back to 1 MB thread stacks
I cannot reproduce the failure on 3.10.2 or later. This may have been a bug in earlier 3.10 versions. Willing to re-investigate if anyone runs in to this at a later date.
Diffstat (limited to 'system/python3')
-rw-r--r--system/python3/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/system/python3/APKBUILD b/system/python3/APKBUILD
index ba29bea30..7c80d89a7 100644
--- a/system/python3/APKBUILD
+++ b/system/python3/APKBUILD
@@ -94,9 +94,9 @@ build() {
--with-system-ffi \
--with-threads
- # set thread stack size to 2MB so we don't segfault before we hit
+ # set thread stack size to 1MB so we don't segfault before we hit
# sys.getrecursionlimit()
- stacksize=0x200000;
+ stacksize=0x100000;
make EXTRA_CFLAGS="$CFLAGS -DTHREAD_STACK_SIZE=$stacksize"
}