summaryrefslogtreecommitdiff
path: root/system/python3
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-03-05 15:06:16 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-01 17:05:52 -0500
commit9337ed5e3c3ca0aac69674fdd40e97b6deb2686c (patch)
treef487a1f3b5a2e7aad3f744c3e87dce07eaa9bf65 /system/python3
parentc5fba6ea33d4953b4b3fa771c42dedef5a105013 (diff)
downloadpackages-9337ed5e3c3ca0aac69674fdd40e97b6deb2686c.tar.gz
packages-9337ed5e3c3ca0aac69674fdd40e97b6deb2686c.tar.bz2
packages-9337ed5e3c3ca0aac69674fdd40e97b6deb2686c.tar.xz
packages-9337ed5e3c3ca0aac69674fdd40e97b6deb2686c.zip
system/python3: bump { 3.10.1 --> 3.10.2 }. add patch for expat >= 2.4.5. fixes #520.
Diffstat (limited to 'system/python3')
-rw-r--r--system/python3/APKBUILD8
-rw-r--r--system/python3/fix-python-tests-expat-ge245.patch112
2 files changed, 117 insertions, 3 deletions
diff --git a/system/python3/APKBUILD b/system/python3/APKBUILD
index a4a44e6fb..e09001beb 100644
--- a/system/python3/APKBUILD
+++ b/system/python3/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=python3
-pkgver=3.10.1
+pkgver=3.10.2
_basever="${pkgver%.*}"
pkgrel=0
pkgdesc="A high-level scripting language"
@@ -39,6 +39,7 @@ makedepends="expat-dev openssl-dev zlib-dev ncurses-dev bzip2-dev xz-dev
source="https://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz
musl-find_library.patch
fix-xattrs-glibc.patch
+ fix-python-tests-expat-ge245.patch
"
builddir="$srcdir/Python-$pkgver"
@@ -188,6 +189,7 @@ tests() {
"$subpkgdir"/usr/lib/python$_basever/
}
-sha512sums="1c559e33f1252e51bafb941c380de16f142c0735858363c84cb8dbed6767843de3af126889c2826ffb94bd4777d7cdfc31040301c8c74de56af52b80b1aa9e76 Python-3.10.1.tar.xz
+sha512sums="215a7159face84788fe547c1e2689b8d0ae510275157cf01636bef2902d0ff465f844eb0328c9f39fd1cd03a1d1736d4cf258992f2788e492a801a372032c08b Python-3.10.2.tar.xz
ab8eaa2858d5109049b1f9f553198d40e0ef8d78211ad6455f7b491af525bffb16738fed60fc84e960c4889568d25753b9e4a1494834fea48291b33f07000ec2 musl-find_library.patch
-4b4696d139e53aad184b72461478821335aadedc4811ec9e96cdea9a4f7ef19ebf0aac8c6afae6345f33c79fbd3ae2c63021de36044a2803d0dc8894fa291cf5 fix-xattrs-glibc.patch"
+4b4696d139e53aad184b72461478821335aadedc4811ec9e96cdea9a4f7ef19ebf0aac8c6afae6345f33c79fbd3ae2c63021de36044a2803d0dc8894fa291cf5 fix-xattrs-glibc.patch
+a98b1c2b2520d996ad3181513e20bc8f1705f0ed3ec262d67d7f1a7d6dc3a90e8ef68078124c2ba008945bf07494fc978a6eaeb62309a9d1d48450fccab62671 fix-python-tests-expat-ge245.patch"
diff --git a/system/python3/fix-python-tests-expat-ge245.patch b/system/python3/fix-python-tests-expat-ge245.patch
new file mode 100644
index 000000000..f95b648a1
--- /dev/null
+++ b/system/python3/fix-python-tests-expat-ge245.patch
@@ -0,0 +1,112 @@
+From dd7da01325ca32796e139507a38da08886f8f972 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sun, 20 Feb 2022 20:39:07 +0100
+Subject: [PATCH 1/3] test_xml_etree.py: Drop mistaken test_issue3151
+
+Curly brackets were never allowed in namespace URIs
+according to RFC 3986, and so-called namespace-validating
+XML parsers have the right to reject them a invalid URIs.
+
+libexpat >=2.4.5 has become strcter in that regard due to
+related security issues; with ET.XML instantiating a
+namespace-aware parser under the hood, this test has no
+future in CPython.
+
+References:
+- https://datatracker.ietf.org/doc/html/rfc3968
+- https://www.w3.org/TR/xml-names/
+---
+ Lib/test/test_xml_etree.py | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/Lib/test/test_xml_etree.py b/Lib/test/test_xml_etree.py
+index a25f536134c7b..c5292b5e9ef68 100644
+--- a/Lib/test/test_xml_etree.py
++++ b/Lib/test/test_xml_etree.py
+@@ -2192,12 +2192,6 @@ def test_issue6233(self):
+ b"<?xml version='1.0' encoding='ascii'?>\n"
+ b'<body>t&#227;g</body>')
+
+- def test_issue3151(self):
+- e = ET.XML('<prefix:localname xmlns:prefix="${stuff}"/>')
+- self.assertEqual(e.tag, '{${stuff}}localname')
+- t = ET.ElementTree(e)
+- self.assertEqual(ET.tostring(e), b'<ns0:localname xmlns:ns0="${stuff}" />')
+-
+ def test_issue6565(self):
+ elem = ET.XML("<body><tag/></body>")
+ self.assertEqual(summarize_list(elem), ['tag'])
+
+From aa7523fef6e3759d02a02fa484acfebf9d0bd852 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sun, 20 Feb 2022 20:56:38 +0100
+Subject: [PATCH 2/3] test_minidom.py: Support Expat >=2.4.5
+
+---
+ Lib/test/test_minidom.py | 17 +++++++++++++++--
+ 1 file changed, 15 insertions(+), 2 deletions(-)
+
+diff --git a/Lib/test/test_minidom.py b/Lib/test/test_minidom.py
+index 1663b1f1143dd..97620258d82f6 100644
+--- a/Lib/test/test_minidom.py
++++ b/Lib/test/test_minidom.py
+@@ -6,10 +6,12 @@
+ from test import support
+ import unittest
+
++import pyexpat
+ import xml.dom.minidom
+
+ from xml.dom.minidom import parse, Node, Document, parseString
+ from xml.dom.minidom import getDOMImplementation
++from xml.parsers.expat import ExpatError
+
+
+ tstfile = support.findfile("test.xml", subdir="xmltestdata")
+@@ -1147,7 +1149,13 @@ def testEncodings(self):
+
+ # Verify that character decoding errors raise exceptions instead
+ # of crashing
+- self.assertRaises(UnicodeDecodeError, parseString,
++ if pyexpat.version_info >= (2, 4, 5):
++ self.assertRaises(ExpatError, parseString,
++ b'<fran\xe7ais></fran\xe7ais>')
++ self.assertRaises(ExpatError, parseString,
++ b'<franais>Comment \xe7a va ? Tr\xe8s bien ?</franais>')
++ else:
++ self.assertRaises(UnicodeDecodeError, parseString,
+ b'<fran\xe7ais>Comment \xe7a va ? Tr\xe8s bien ?</fran\xe7ais>')
+
+ doc.unlink()
+@@ -1609,7 +1617,12 @@ def testEmptyXMLNSValue(self):
+ self.confirm(doc2.namespaceURI == xml.dom.EMPTY_NAMESPACE)
+
+ def testExceptionOnSpacesInXMLNSValue(self):
+- with self.assertRaisesRegex(ValueError, 'Unsupported syntax'):
++ if pyexpat.version_info >= (2, 4, 5):
++ context = self.assertRaisesRegex(ExpatError, 'syntax error')
++ else:
++ context = self.assertRaisesRegex(ValueError, 'Unsupported syntax')
++
++ with context:
+ parseString('<element xmlns:abc="http:abc.com/de f g/hi/j k"><abc:foo /></element>')
+
+ def testDocRemoveChild(self):
+
+From 2dcb3051b243fff2f031c14eea50a649e8b7c7ea Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sun, 20 Feb 2022 21:03:40 +0100
+Subject: [PATCH 3/3] Add blurp file for bpo-46811 to section "Library"
+
+---
+ .../NEWS.d/next/Library/2022-02-20-21-03-31.bpo-46811.8BxgdQ.rst | 1 +
+ 1 file changed, 1 insertion(+)
+ create mode 100644 Misc/NEWS.d/next/Library/2022-02-20-21-03-31.bpo-46811.8BxgdQ.rst
+
+diff --git a/Misc/NEWS.d/next/Library/2022-02-20-21-03-31.bpo-46811.8BxgdQ.rst b/Misc/NEWS.d/next/Library/2022-02-20-21-03-31.bpo-46811.8BxgdQ.rst
+new file mode 100644
+index 0000000000000..6969bd1898f65
+--- /dev/null
++++ b/Misc/NEWS.d/next/Library/2022-02-20-21-03-31.bpo-46811.8BxgdQ.rst
+@@ -0,0 +1 @@
++Make test suite support Expat >=2.4.5