summaryrefslogtreecommitdiff
path: root/system/python3
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2023-04-01 22:14:13 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2023-04-01 22:14:13 -0500
commit3829532d512ff2a90cf3951c15b0f4adc4660c0a (patch)
tree7b3ad3385b2636a7b4ce083e5ccfb4cb08ec098e /system/python3
parent59f50eb4aea3e8c0ba74414ad1a1f09795d80e03 (diff)
downloadpackages-3829532d512ff2a90cf3951c15b0f4adc4660c0a.tar.gz
packages-3829532d512ff2a90cf3951c15b0f4adc4660c0a.tar.bz2
packages-3829532d512ff2a90cf3951c15b0f4adc4660c0a.tar.xz
packages-3829532d512ff2a90cf3951c15b0f4adc4660c0a.zip
system/python3: Update to 3.11.2
Diffstat (limited to 'system/python3')
-rw-r--r--system/python3/APKBUILD10
-rw-r--r--system/python3/CVE-2022-45061.patch95
-rw-r--r--system/python3/fix-xattrs-glibc.patch4
-rw-r--r--system/python3/musl-find_library.patch4
4 files changed, 8 insertions, 105 deletions
diff --git a/system/python3/APKBUILD b/system/python3/APKBUILD
index bf4fc4cc7..fcd6bd2ef 100644
--- a/system/python3/APKBUILD
+++ b/system/python3/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=python3
-pkgver=3.11.0
+pkgver=3.11.2
_basever="${pkgver%.*}"
pkgrel=0
pkgdesc="A high-level scripting language"
@@ -40,7 +40,6 @@ source="https://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz
musl-find_library.patch
musl-has-login_tty.patch
fix-xattrs-glibc.patch
- CVE-2022-45061.patch
"
builddir="$srcdir/Python-$pkgver"
@@ -191,8 +190,7 @@ tests() {
"$subpkgdir"/usr/lib/python$_basever/
}
-sha512sums="314eef88ae0d68760f34d7a32f238fd2ecb27c50963baa7357c42ad8159026ec50229a0b31d83c39710a472904a06422afc082f9658a90a1dc83ccb74c08039d Python-3.11.0.tar.xz
-ab8eaa2858d5109049b1f9f553198d40e0ef8d78211ad6455f7b491af525bffb16738fed60fc84e960c4889568d25753b9e4a1494834fea48291b33f07000ec2 musl-find_library.patch
+sha512sums="5684ec7eae2dce26facc54d448ccdb6901bbfa1cab03abbe8fd34e4268a2b701daa13df15903349492447035be78380d473389e8703b4e910a65b088d2462e8b Python-3.11.2.tar.xz
+df1c7096a7744c94312ee6cacdd54345e384bcdf2a17148163f5f4c70f0cfa80301efbcbb2398306401ec53106e5c6922ba582a7df226e718cedb53396cc4786 musl-find_library.patch
75c60afecba2e57f11d58c20aadc611ebbb5c68e05b14415c5cf2f7aa75e103986764ca22f76e6a58b2c08e2ff3acffdbf6d85d2c8c4589743a0b949a4c90687 musl-has-login_tty.patch
-4b4696d139e53aad184b72461478821335aadedc4811ec9e96cdea9a4f7ef19ebf0aac8c6afae6345f33c79fbd3ae2c63021de36044a2803d0dc8894fa291cf5 fix-xattrs-glibc.patch
-039982b5f35d5aa412596dba81b0666fdf979e6c120aefa3ae29333fbaa56f6f6ad69db513dcd93e06a66522405058be2e39e56350816abcb9febd8f5778036f CVE-2022-45061.patch"
+6e587012c59e276e2e309ee348059d76707543fdda48ed53ca374cc9d9ca3499ecdf644cee59ec23b18f101e8750cc973413ebd59c7f242f40aeefb69e75a374 fix-xattrs-glibc.patch"
diff --git a/system/python3/CVE-2022-45061.patch b/system/python3/CVE-2022-45061.patch
deleted file mode 100644
index 0b6faa7cb..000000000
--- a/system/python3/CVE-2022-45061.patch
+++ /dev/null
@@ -1,95 +0,0 @@
-From b8f89940de09a51fdbd8fe4705d3d1d7f1bb0c6a Mon Sep 17 00:00:00 2001
-From: "Miss Islington (bot)"
- <31488909+miss-islington@users.noreply.github.com>
-Date: Mon, 7 Nov 2022 18:57:10 -0800
-Subject: [PATCH] [3.11] gh-98433: Fix quadratic time idna decoding. (GH-99092)
- (GH-99222)
-
-There was an unnecessary quadratic loop in idna decoding. This restores
-the behavior to linear.
-
-(cherry picked from commit d315722564927c7202dd6e111dc79eaf14240b0d)
-
-(cherry picked from commit a6f6c3a3d6f2b580f2d87885c9b8a9350ad7bf15)
-
-Co-authored-by: Miss Islington (bot) <31488909+miss-islington@users.noreply.github.com>
-Co-authored-by: Gregory P. Smith <greg@krypto.org>
----
- Lib/encodings/idna.py | 32 +++++++++----------
- Lib/test/test_codecs.py | 6 ++++
- ...2-11-04-09-29-36.gh-issue-98433.l76c5G.rst | 6 ++++
- 3 files changed, 27 insertions(+), 17 deletions(-)
- create mode 100644 Misc/NEWS.d/next/Security/2022-11-04-09-29-36.gh-issue-98433.l76c5G.rst
-
-diff --git a/Lib/encodings/idna.py b/Lib/encodings/idna.py
-index ea4058512fe3..bf98f513366b 100644
---- a/Lib/encodings/idna.py
-+++ b/Lib/encodings/idna.py
-@@ -39,23 +39,21 @@ def nameprep(label):
-
- # Check bidi
- RandAL = [stringprep.in_table_d1(x) for x in label]
-- for c in RandAL:
-- if c:
-- # There is a RandAL char in the string. Must perform further
-- # tests:
-- # 1) The characters in section 5.8 MUST be prohibited.
-- # This is table C.8, which was already checked
-- # 2) If a string contains any RandALCat character, the string
-- # MUST NOT contain any LCat character.
-- if any(stringprep.in_table_d2(x) for x in label):
-- raise UnicodeError("Violation of BIDI requirement 2")
--
-- # 3) If a string contains any RandALCat character, a
-- # RandALCat character MUST be the first character of the
-- # string, and a RandALCat character MUST be the last
-- # character of the string.
-- if not RandAL[0] or not RandAL[-1]:
-- raise UnicodeError("Violation of BIDI requirement 3")
-+ if any(RandAL):
-+ # There is a RandAL char in the string. Must perform further
-+ # tests:
-+ # 1) The characters in section 5.8 MUST be prohibited.
-+ # This is table C.8, which was already checked
-+ # 2) If a string contains any RandALCat character, the string
-+ # MUST NOT contain any LCat character.
-+ if any(stringprep.in_table_d2(x) for x in label):
-+ raise UnicodeError("Violation of BIDI requirement 2")
-+ # 3) If a string contains any RandALCat character, a
-+ # RandALCat character MUST be the first character of the
-+ # string, and a RandALCat character MUST be the last
-+ # character of the string.
-+ if not RandAL[0] or not RandAL[-1]:
-+ raise UnicodeError("Violation of BIDI requirement 3")
-
- return label
-
-diff --git a/Lib/test/test_codecs.py b/Lib/test/test_codecs.py
-index 8edd5ac0633e..240756726133 100644
---- a/Lib/test/test_codecs.py
-+++ b/Lib/test/test_codecs.py
-@@ -1535,6 +1535,12 @@ def test_builtin_encode(self):
- self.assertEqual("pyth\xf6n.org".encode("idna"), b"xn--pythn-mua.org")
- self.assertEqual("pyth\xf6n.org.".encode("idna"), b"xn--pythn-mua.org.")
-
-+ def test_builtin_decode_length_limit(self):
-+ with self.assertRaisesRegex(UnicodeError, "too long"):
-+ (b"xn--016c"+b"a"*1100).decode("idna")
-+ with self.assertRaisesRegex(UnicodeError, "too long"):
-+ (b"xn--016c"+b"a"*70).decode("idna")
-+
- def test_stream(self):
- r = codecs.getreader("idna")(io.BytesIO(b"abc"))
- r.read(3)
-diff --git a/Misc/NEWS.d/next/Security/2022-11-04-09-29-36.gh-issue-98433.l76c5G.rst b/Misc/NEWS.d/next/Security/2022-11-04-09-29-36.gh-issue-98433.l76c5G.rst
-new file mode 100644
-index 000000000000..5185fac2e29d
---- /dev/null
-+++ b/Misc/NEWS.d/next/Security/2022-11-04-09-29-36.gh-issue-98433.l76c5G.rst
-@@ -0,0 +1,6 @@
-+The IDNA codec decoder used on DNS hostnames by :mod:`socket` or :mod:`asyncio`
-+related name resolution functions no longer involves a quadratic algorithm.
-+This prevents a potential CPU denial of service if an out-of-spec excessive
-+length hostname involving bidirectional characters were decoded. Some protocols
-+such as :mod:`urllib` http ``3xx`` redirects potentially allow for an attacker
-+to supply such a name.
diff --git a/system/python3/fix-xattrs-glibc.patch b/system/python3/fix-xattrs-glibc.patch
index d78428108..da0c6e3cb 100644
--- a/system/python3/fix-xattrs-glibc.patch
+++ b/system/python3/fix-xattrs-glibc.patch
@@ -1,14 +1,14 @@
diff -ur a/Modules/posixmodule.c b/Modules/posixmodule.c
--- a/Modules/posixmodule.c 2022-01-11 11:45:55.120000000 +0000
+++ b/Modules/posixmodule.c 2022-01-11 11:47:28.010000000 +0000
-@@ -247,8 +247,9 @@
+@@ -272,8 +272,9 @@
# undef HAVE_SCHED_SETAFFINITY
#endif
-#if defined(HAVE_SYS_XATTR_H) && defined(__GLIBC__) && !defined(__FreeBSD_kernel__) && !defined(__GNU__)
+#if defined(HAVE_SYS_XATTR_H) && defined(__linux__) && !defined(__FreeBSD_kernel__) && !defined(__GNU__)
# define USE_XATTRS
-+#include <linux/limits.h>
++# include <linux/limits.h>
#endif
#ifdef USE_XATTRS
diff --git a/system/python3/musl-find_library.patch b/system/python3/musl-find_library.patch
index 7899abb73..6181ede0a 100644
--- a/system/python3/musl-find_library.patch
+++ b/system/python3/musl-find_library.patch
@@ -1,13 +1,13 @@
diff -ru Python-2.7.12.orig/Lib/ctypes/util.py Python-2.7.12/Lib/ctypes/util.py
--- Python-2.7.12.orig/Lib/ctypes/util.py 2016-06-26 00:49:30.000000000 +0300
+++ Python-2.7.12/Lib/ctypes/util.py 2016-11-03 16:05:46.954665040 +0200
-@@ -204,6 +204,41 @@
+@@ -265,6 +265,41 @@
def find_library(name, is64 = False):
return _get_soname(_findLib_crle(name, is64) or _findLib_gcc(name))
+ elif True:
+
-+ # Patched for Alpine Linux / musl - search manually system paths
++ # Patched for musl to search manually system paths
+ def _is_elf(filepath):
+ try:
+ with open(filepath, 'rb') as fh: