summaryrefslogtreecommitdiff
path: root/system/python3
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-02-21 01:13:36 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-01 17:06:04 -0500
commitf4cea7ff0b3170a7383f4880ef33e1048d059352 (patch)
treef03d0a8f61de3dfaf6b89e74cd429da822a08b9c /system/python3
parenteb94fe94a53d082549ef0ab742e95f3c5ec2be00 (diff)
downloadpackages-f4cea7ff0b3170a7383f4880ef33e1048d059352.tar.gz
packages-f4cea7ff0b3170a7383f4880ef33e1048d059352.tar.bz2
packages-f4cea7ff0b3170a7383f4880ef33e1048d059352.tar.xz
packages-f4cea7ff0b3170a7383f4880ef33e1048d059352.zip
system/python3: Make stack size platform-agnostic
Diffstat (limited to 'system/python3')
-rw-r--r--system/python3/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/system/python3/APKBUILD b/system/python3/APKBUILD
index e09001beb..ba29bea30 100644
--- a/system/python3/APKBUILD
+++ b/system/python3/APKBUILD
@@ -94,12 +94,9 @@ build() {
--with-system-ffi \
--with-threads
- # set thread stack size to 1MB so we don't segfault before we hit
+ # set thread stack size to 2MB so we don't segfault before we hit
# sys.getrecursionlimit()
- stacksize=0x100000;
- case "$CARCH" in
- ppc64) stacksize=0x200000;;
- esac
+ stacksize=0x200000;
make EXTRA_CFLAGS="$CFLAGS -DTHREAD_STACK_SIZE=$stacksize"
}