summaryrefslogtreecommitdiff
path: root/system/rsync
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-03-02 18:49:06 -0600
committerMax Rees <maxcrees@me.com>2020-03-09 21:27:44 -0500
commit3c2bf265c6afba11823913a0d8f018782985f8d4 (patch)
treeeb785842aee3354f6b9cca8f198726c651876a82 /system/rsync
parente57fee0540a6a586ccd7c66fedc94752a7f06b59 (diff)
downloadpackages-3c2bf265c6afba11823913a0d8f018782985f8d4.tar.gz
packages-3c2bf265c6afba11823913a0d8f018782985f8d4.tar.bz2
packages-3c2bf265c6afba11823913a0d8f018782985f8d4.tar.xz
packages-3c2bf265c6afba11823913a0d8f018782985f8d4.zip
system/rsync: use system zlib to close some zlib CVEs
Diffstat (limited to 'system/rsync')
-rw-r--r--system/rsync/APKBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/system/rsync/APKBUILD b/system/rsync/APKBUILD
index e93da8552..728a32fbc 100644
--- a/system/rsync/APKBUILD
+++ b/system/rsync/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=rsync
pkgver=3.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="File transfer program to keep remote files in sync"
url="https://rsync.samba.org/"
arch="all"
license="GPL-3.0+"
depends=""
checkdepends="fakeroot"
-makedepends="perl acl-dev attr-dev popt-dev"
+makedepends="perl acl-dev attr-dev popt-dev zlib-dev"
subpackages="$pkgname-doc $pkgname-openrc rrsync::noarch"
source="https://download.samba.org/pub/$pkgname/$pkgname-$pkgver.tar.gz
rsyncd.initd
@@ -18,6 +18,13 @@ source="https://download.samba.org/pub/$pkgname/$pkgname-$pkgver.tar.gz
rsyncd.logrotate
"
+# secfixes:
+# 3.1.3-r2:
+# - CVE-2016-9840
+# - CVE-2016-9841
+# - CVE-2016-9842
+# - CVE-2016-9843
+
build() {
# Force IPv6 enabled, upstream bug https://bugzilla.samba.org/show_bug.cgi?id=10715
CFLAGS="$CFLAGS -DINET6" \
@@ -29,7 +36,8 @@ build() {
--mandir=/usr/share/man \
--localstatedir=/var \
--enable-acl-support \
- --enable-xattr-support
+ --enable-xattr-support \
+ --with-included-zlib=no
make
}