summaryrefslogtreecommitdiff
path: root/system/rsync
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-04-20 08:42:28 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-01 17:05:59 -0500
commit5c42b3c96342350f65799bccea8b22a93b6f09bc (patch)
tree89d928774b957b3243a61c89884dee19a058f04a /system/rsync
parenta63e2e915a42e2158c2e68e1f091c33e781b8219 (diff)
downloadpackages-5c42b3c96342350f65799bccea8b22a93b6f09bc.tar.gz
packages-5c42b3c96342350f65799bccea8b22a93b6f09bc.tar.bz2
packages-5c42b3c96342350f65799bccea8b22a93b6f09bc.tar.xz
packages-5c42b3c96342350f65799bccea8b22a93b6f09bc.zip
system/rsync: bump { 3.2.3 --> 3.2.4 }. fix source tarball URL.
Diffstat (limited to 'system/rsync')
-rw-r--r--system/rsync/APKBUILD10
-rw-r--r--system/rsync/CVE-2020-14387.patch21
2 files changed, 4 insertions, 27 deletions
diff --git a/system/rsync/APKBUILD b/system/rsync/APKBUILD
index a436eaed8..b56db051e 100644
--- a/system/rsync/APKBUILD
+++ b/system/rsync/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Sheila Aman <sheila@vulpine.house>
pkgname=rsync
-pkgver=3.2.3
+pkgver=3.2.4
pkgrel=0
pkgdesc="File transfer program to keep remote files in sync"
url="https://rsync.samba.org/"
@@ -12,12 +12,11 @@ checkdepends="fakeroot"
makedepends="perl acl-dev attr-dev lz4-dev openssl-dev popt-dev zlib-dev
zstd-dev"
subpackages="$pkgname-doc $pkgname-openrc rrsync::noarch"
-source="https://download.samba.org/pub/$pkgname/$pkgname-$pkgver.tar.gz
+source="https://download.samba.org/pub/$pkgname/src/$pkgname-$pkgver.tar.gz
rsyncd.initd
rsyncd.confd
rsyncd.conf
rsyncd.logrotate
- CVE-2020-14387.patch
"
# secfixes:
@@ -67,9 +66,8 @@ rrsync() {
install -D -m 755 "$builddir"/support/rrsync "$subpkgdir"/usr/bin/rrsync
}
-sha512sums="48b68491f3ef644dbbbfcaec5ab90a1028593e02d50367ce161fd9d3d0bd0a3628bc57c5e5dec4be3a1d213f784f879b8a8fcdfd789ba0f99837cba16e1ae70e rsync-3.2.3.tar.gz
+sha512sums="96318e2754fbddf84d16df671c721e577766969dfa415925c4dc1be2e4e60a51246623747a8aec0c6e9c0824e6aa7335235ccd07f3d6fd901f8cf28e2d6e91b6 rsync-3.2.4.tar.gz
638d87c9a753b35044f6321ccd09d2c0addaab3c52c40863eb6905905576b5268bec67b496df81225528c9e39fbd92e9225d7b3037ab1fda78508d452c78158f rsyncd.initd
c7527e289c81bee5e4c14b890817cdb47d14f0d26dd8dcdcbe85c7199cf27c57a0b679bdd1b115bfe00de77b52709cc5d97522a47f63c1bb5104f4a7220c9961 rsyncd.confd
3db8a2b364fc89132af6143af90513deb6be3a78c8180d47c969e33cb5edde9db88aad27758a6911f93781e3c9846aeadc80fffc761c355d6a28358853156b62 rsyncd.conf
-b8d6c0bb467a5c963317dc55478d2c10874564cd264d943d4a42037e2fce134fe001fabc92af5c6b5775e84dc310b1c8da147afaa61c99e5663c36580d8651a5 rsyncd.logrotate
-cebd8b23db8fb095e35e133ab828efecc385e159e429b3c2366f411572cdebb3444be0f60b42b2ce3d34476f1ebb4f194933d699978db385ac40c4fba6767991 CVE-2020-14387.patch"
+b8d6c0bb467a5c963317dc55478d2c10874564cd264d943d4a42037e2fce134fe001fabc92af5c6b5775e84dc310b1c8da147afaa61c99e5663c36580d8651a5 rsyncd.logrotate"
diff --git a/system/rsync/CVE-2020-14387.patch b/system/rsync/CVE-2020-14387.patch
deleted file mode 100644
index 7ed5e7a48..000000000
--- a/system/rsync/CVE-2020-14387.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Matt McCutchen <matt@mattmccutchen.net>
-Date: Wed, 26 Aug 2020 16:16:08 +0000 (-0400)
-Subject: rsync-ssl: Verify the hostname in the certificate when using openssl.
-X-Git-Url: http://git.samba.org/?p=rsync.git;a=commitdiff_plain;h=c3f7414;hp=4c4fce51072c9189cfb11b52aa54fed79f5741bd
-
-rsync-ssl: Verify the hostname in the certificate when using openssl.
----
-
-diff --git a/rsync-ssl b/rsync-ssl
-index 8101975a..46701af1 100755
---- a/rsync-ssl
-+++ b/rsync-ssl
-@@ -129,7 +129,7 @@ function rsync_ssl_helper {
- fi
-
- if [[ $RSYNC_SSL_TYPE == openssl ]]; then
-- exec $RSYNC_SSL_OPENSSL s_client $caopt $certopt -quiet -verify_quiet -servername $hostname -connect $hostname:$port
-+ exec $RSYNC_SSL_OPENSSL s_client $caopt $certopt -quiet -verify_quiet -servername $hostname -verify_hostname $hostname -connect $hostname:$port
- elif [[ $RSYNC_SSL_TYPE == gnutls ]]; then
- exec $RSYNC_SSL_GNUTLS --logfile=/dev/null $gnutls_cert_opt $gnutls_opts $hostname:$port
- else