summaryrefslogtreecommitdiff
path: root/system/ruby/test_insns-lower-recursion-depth.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-24 03:07:52 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-24 03:07:52 -0500
commit965d80ca4ac1c981343de938f066f5c6627a716a (patch)
treeeb2f89411cd5a5042e930d86871fa7dda84c833f /system/ruby/test_insns-lower-recursion-depth.patch
parentb34e6fe698af4901a2a662cc0ce671afa755e121 (diff)
downloadpackages-965d80ca4ac1c981343de938f066f5c6627a716a.tar.gz
packages-965d80ca4ac1c981343de938f066f5c6627a716a.tar.bz2
packages-965d80ca4ac1c981343de938f066f5c6627a716a.tar.xz
packages-965d80ca4ac1c981343de938f066f5c6627a716a.zip
system/ruby: pull in for asciidoctor
Diffstat (limited to 'system/ruby/test_insns-lower-recursion-depth.patch')
-rw-r--r--system/ruby/test_insns-lower-recursion-depth.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/system/ruby/test_insns-lower-recursion-depth.patch b/system/ruby/test_insns-lower-recursion-depth.patch
new file mode 100644
index 000000000..48e88dfd6
--- /dev/null
+++ b/system/ruby/test_insns-lower-recursion-depth.patch
@@ -0,0 +1,47 @@
+The patched test is a recursion function. We have lower stack size,
+so we hit SystemStackError sooner than on other platforms.
+
+ #361 test_insns.rb:389:in `block in <top (required)>':
+ # recursive once
+ def once n
+ return %r/#{
+ if n == 0
+ true
+ else
+ once(n-1) # here
+ end
+ }/ox
+ end
+ x = once(128); x = once(7); x = once(16);
+ x =~ "true" && $~
+ #=> "" (expected "true") once
+ Stderr output is not empty
+ bootstraptest.tmp.rb:3:in `once': stack level too deep (SystemStackError)
+ from bootstraptest.tmp.rb:7:in `block in once'
+ from bootstraptest.tmp.rb:3:in `once'
+ from bootstraptest.tmp.rb:7:in `block in once'
+ from bootstraptest.tmp.rb:3:in `once'
+ from bootstraptest.tmp.rb:7:in `block in once'
+ from bootstraptest.tmp.rb:3:in `once'
+ from bootstraptest.tmp.rb:7:in `block in once'
+ from bootstraptest.tmp.rb:3:in `once'
+ ... 125 levels...
+ from bootstraptest.tmp.rb:3:in `once'
+ from bootstraptest.tmp.rb:7:in `block in once'
+ from bootstraptest.tmp.rb:3:in `once'
+ from bootstraptest.tmp.rb:11:in `<main>'
+ Test_insns.rb FAIL 1/187
+ FAIL 1/1197 tests failed
+ Make: *** [uncommon.mk:666: yes-btest-ruby] Error 1
+
+--- a/bootstraptest/test_insns.rb
++++ b/bootstraptest/test_insns.rb
+@@ -248,7 +248,7 @@
+ end
+ }/ox
+ end
+- x = once(128); x = once(7); x = once(16);
++ x = once(32); x = once(7); x = once(16);
+ x =~ "true" && $~
+ },
+ [ 'once', <<~'},', ], # {