summaryrefslogtreecommitdiff
path: root/system/sed
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-18 22:00:51 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-18 22:00:51 -0500
commitf6d988ae031bf2d02716642e1c92c83e4f3abddd (patch)
tree1a8ee3404821816e0158a51e14c5bc023424417a /system/sed
parent50cbf2fa40515a2c059ba42c31125dbbdf17c22a (diff)
downloadpackages-f6d988ae031bf2d02716642e1c92c83e4f3abddd.tar.gz
packages-f6d988ae031bf2d02716642e1c92c83e4f3abddd.tar.bz2
packages-f6d988ae031bf2d02716642e1c92c83e4f3abddd.tar.xz
packages-f6d988ae031bf2d02716642e1c92c83e4f3abddd.zip
system/sed: just read the patch file in this commit, omg
Diffstat (limited to 'system/sed')
-rw-r--r--system/sed/APKBUILD4
-rw-r--r--system/sed/gnulib-tests-dont-require-gpg-passphrase.patch10
2 files changed, 13 insertions, 1 deletions
diff --git a/system/sed/APKBUILD b/system/sed/APKBUILD
index 1d33fdc39..4298ce8be 100644
--- a/system/sed/APKBUILD
+++ b/system/sed/APKBUILD
@@ -13,6 +13,7 @@ makedepends="perl"
install="$pkgname.post-deinstall"
source="http://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
disable-mbrtowc-test.patch
+ gnulib-tests-dont-require-gpg-passphrase.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -45,4 +46,5 @@ package() {
}
sha512sums="f95fb27e03b2301dae63878413b4c48e40341cc676945a612e1d0bd911da3192858ae142791292a99fbdaacbc7dab2d6fccb50787c06846f99b0b3740b40c196 sed-4.5.tar.xz
-aeb55f85a5c724f0dacbf2f39e0f99ae4c66159115b00aa36d65f234f87e52e660878cb18b772a494349632dfa1b616b9306a4cafe87e91182ea8936c308506a disable-mbrtowc-test.patch"
+aeb55f85a5c724f0dacbf2f39e0f99ae4c66159115b00aa36d65f234f87e52e660878cb18b772a494349632dfa1b616b9306a4cafe87e91182ea8936c308506a disable-mbrtowc-test.patch
+8dc38bbd731885c69e83d2ed45d5df28542d9401f196295871135aa157d48ac77f1f926afcaab3ee0098ab0eb6232efc4664060177c3bf109a3e673f5adf9b85 gnulib-tests-dont-require-gpg-passphrase.patch"
diff --git a/system/sed/gnulib-tests-dont-require-gpg-passphrase.patch b/system/sed/gnulib-tests-dont-require-gpg-passphrase.patch
new file mode 100644
index 000000000..002f4f9e7
--- /dev/null
+++ b/system/sed/gnulib-tests-dont-require-gpg-passphrase.patch
@@ -0,0 +1,10 @@
+--- sed-4.5/gnulib-tests/test-vc-list-files-git.sh.old 2018-01-03 18:36:29.000000000 -0600
++++ sed-4.5/gnulib-tests/test-vc-list-files-git.sh 2018-06-18 21:57:08.305562148 -0500
+@@ -32,6 +32,7 @@
+ touch d/a b c &&
+ git config user.email "you@example.com" &&
+ git config user.name "Your Name" &&
++ git config commit.gpgsign false &&
+ git add . > /dev/null &&
+ git commit -q -a -m log &&
+ printf '%s\n' b c d/a > expected &&