summaryrefslogtreecommitdiff
path: root/system/sed
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-06-18 05:03:20 -0500
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-06-18 05:04:33 -0500
commitce3e51c42b9988cc582d0c655c520dab1942f58e (patch)
treeb8cf132b580e83d11daccb57d6bad62c732739ec /system/sed
parent9011b5b6f7414784cf1d0d2fd1ecfb8a5c8610e4 (diff)
downloadpackages-ce3e51c42b9988cc582d0c655c520dab1942f58e.tar.gz
packages-ce3e51c42b9988cc582d0c655c520dab1942f58e.tar.bz2
packages-ce3e51c42b9988cc582d0c655c520dab1942f58e.tar.xz
packages-ce3e51c42b9988cc582d0c655c520dab1942f58e.zip
system/sed: [PD] fix maintainer, bump to 4.5
Diffstat (limited to 'system/sed')
-rw-r--r--system/sed/APKBUILD13
-rw-r--r--system/sed/localename-test-fix.patch34
2 files changed, 6 insertions, 41 deletions
diff --git a/system/sed/APKBUILD b/system/sed/APKBUILD
index 08fe6a55a..1d33fdc39 100644
--- a/system/sed/APKBUILD
+++ b/system/sed/APKBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=sed
-pkgver=4.4
-pkgrel=1
+pkgver=4.5
+pkgrel=0
subpackages="$pkgname-doc"
pkgdesc="GNU stream editor"
url="http://www.gnu.org/software/sed"
@@ -12,7 +13,6 @@ makedepends="perl"
install="$pkgname.post-deinstall"
source="http://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
disable-mbrtowc-test.patch
- localename-test-fix.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -44,6 +44,5 @@ package() {
rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
}
-sha512sums="4e1b0a7403913f1e25047eb2292a0a9b3488b15b4463ce2803e05eaecbc2da19f477a18e6a70c992461c38ced90774415091aa2d8ce85cb74e391610d9eedb70 sed-4.4.tar.xz
-aeb55f85a5c724f0dacbf2f39e0f99ae4c66159115b00aa36d65f234f87e52e660878cb18b772a494349632dfa1b616b9306a4cafe87e91182ea8936c308506a disable-mbrtowc-test.patch
-3fbf7f5fbdef19f1212c4efad560b85e62744eecfe60eceaba1c8d093764f34bff844d31d704afdc064ca3d31bb7e46860a4b91e671b96930554a72953e88edf localename-test-fix.patch"
+sha512sums="f95fb27e03b2301dae63878413b4c48e40341cc676945a612e1d0bd911da3192858ae142791292a99fbdaacbc7dab2d6fccb50787c06846f99b0b3740b40c196 sed-4.5.tar.xz
+aeb55f85a5c724f0dacbf2f39e0f99ae4c66159115b00aa36d65f234f87e52e660878cb18b772a494349632dfa1b616b9306a4cafe87e91182ea8936c308506a disable-mbrtowc-test.patch"
diff --git a/system/sed/localename-test-fix.patch b/system/sed/localename-test-fix.patch
deleted file mode 100644
index 8a5d68dde..000000000
--- a/system/sed/localename-test-fix.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- sed-4.4/gnulib-tests/localename.c.old 2016-12-31 13:54:43.000000000 +0000
-+++ sed-4.4/gnulib-tests/localename.c 2017-07-30 16:40:47.098541270 +0000
-@@ -40,7 +40,7 @@
- # if defined __APPLE__ && defined __MACH__
- # include <xlocale.h>
- # endif
--# if __GLIBC__ >= 2 && !defined __UCLIBC__
-+# if defined __linux__
- # include <langinfo.h>
- # endif
- # if !defined IN_LIBINTL
-@@ -2692,16 +2692,19 @@
- locale_t thread_locale = uselocale (NULL);
- if (thread_locale != LC_GLOBAL_LOCALE)
- {
--# if __GLIBC__ >= 2 && !defined __UCLIBC__
-+# if defined(_NL_LOCALE_NAME)
-+ const char *name = nl_langinfo(_NL_LOCALE_NAME(category));
-+# if __GLIBC__ >= 2 && !defined __UCLIBC__
- /* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
- glibc < 2.12.
- See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
-- const char *name =
-- nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
-+ if (name[0] == '\0')
-+ name = nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
- if (name[0] == '\0')
- /* Fallback code for glibc < 2.4, which did not implement
- nl_langinfo (_NL_LOCALE_NAME (category)). */
- name = thread_locale->__names[category];
-+# endif
- return name;
- # elif defined __FreeBSD__ || (defined __APPLE__ && defined __MACH__)
- /* FreeBSD, Mac OS X */