summaryrefslogtreecommitdiff
path: root/system/sp
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-19 01:17:14 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-19 01:17:14 -0500
commit58fd7c4b086617401c7116246d8b8f7ffcb2869f (patch)
tree3fa6c3958d8ce808fb869f523eee908dad76a362 /system/sp
parent14cb93171d9fd39627ef1cfae82207187a4a71b8 (diff)
downloadpackages-58fd7c4b086617401c7116246d8b8f7ffcb2869f.tar.gz
packages-58fd7c4b086617401c7116246d8b8f7ffcb2869f.tar.bz2
packages-58fd7c4b086617401c7116246d8b8f7ffcb2869f.tar.xz
packages-58fd7c4b086617401c7116246d8b8f7ffcb2869f.zip
user/sp => system/sp for tzdata
Diffstat (limited to 'system/sp')
-rw-r--r--system/sp/APKBUILD35
-rw-r--r--system/sp/configure.patch45
-rw-r--r--system/sp/nsgmls-c++-fix.patch11
3 files changed, 91 insertions, 0 deletions
diff --git a/system/sp/APKBUILD b/system/sp/APKBUILD
new file mode 100644
index 000000000..2802aed89
--- /dev/null
+++ b/system/sp/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=sp
+pkgver=1.3.4
+pkgrel=0
+pkgdesc="An SGML system conforming to ISO 8879"
+url="http://www.jclark.com/sp/"
+arch="all"
+license="X/Open"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+options="!check"
+subpackages=""
+source="ftp://ftp.jclark.com/pub/sp/sp-$pkgver.tar.gz
+ configure.patch
+ nsgmls-c++-fix.patch
+ "
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ # it will not create the prefix directory itself
+ mkdir -p "$pkgdir"/usr
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="3abf007fa366ddb50d2b7d8b9462915de973dc6c7abe8e44b679c745ce81f0a57373808398abca5856b38082ed1e44667658965a881a147d8f761a5c4f4794df sp-1.3.4.tar.gz
+aeabaf67a8e10b3674bbda3e258e95d80a7dcdca2d8001c1cd989cbc00b8163958bd4fe833d49079397ffbe6e46e3ffad07f0bb0bbfeb1ec149c7b0cb2034630 configure.patch
+38df9de011686990d927a495162011ac54ac6af58be3d73f8729ab74df9e112f42a0c4342a12dfdf43a3b47861a64a1b6b077e42072d0d4b9dd1bb159a4f200b nsgmls-c++-fix.patch"
diff --git a/system/sp/configure.patch b/system/sp/configure.patch
new file mode 100644
index 000000000..80dc61363
--- /dev/null
+++ b/system/sp/configure.patch
@@ -0,0 +1,45 @@
+--- sp-1.3.4/Makefile.old 1998-10-10 04:15:02.000000000 +0000
++++ sp-1.3.4/Makefile 2017-08-20 23:30:54.963652269 +0000
+@@ -1,19 +1,19 @@
+ # Copyright (c) 1994, 1995 James Clark
+ # See the file COPYING for copying permission.
+
+-prefix=/opt/local
++prefix=$(DESTDIR)/usr
+ exec_prefix=$(prefix)
+ # Where to install the binaries
+ bindir=$(exec_prefix)/bin
+-INSTALL=cp
++#INSTALL=cp
+ # You might want to uncomment this on BSD systems
+-#INSTALL=install
++INSTALL=install
+
+ # If you use gcc, then you must have at least version 2.6.1 and
+ # you must use -fno-implicit-templates
+ # and -O (or any optimization level >= 1).
+ # c++ is a front-end for gcc which takes care of linking with -lstdc++
+-CXX=c++ -fno-implicit-templates -O2
++CXX=c++ -O2
+ WARN=#-Wall -Wno-reorder -Wwrite-strings -Wpointer-arith -Wnested-externs -Woverloaded-virtual -Wbad-function-cast
+ # Executables will be *very* large if you use -g.
+ DEBUG=
+@@ -33,7 +33,7 @@
+ # Add -Dsig_atomic_t=int on SunOS 4.1.x with g++ (or any other platform
+ # which doesn't appropriately define sig_atomic_t).
+ # Add -DJADE_MIF to include the Jade MIF backend
+-XDEFINES=
++XDEFINES=-DSP_HAVE_LOCALE -DSP_MUTEX_PTHREADS -DSP_HAVE_SOCKET -DSP_HAVE_TYPENAME -DSP_DEFINE_TEMPLATES -Wno-deprecated
+ DEFINES=-DSP_HAVE_BOOL -DSP_ANSI_CLASS_INST -DSP_MULTI_BYTE $(XDEFINES)
+ CXXFLAGS=-ansi $(DEBUG) $(WARN)
+ # Flag to pass to CXX to make it output list of dependencies as a Makefile.
+--- sp-1.3.4/include/config.h.old 1999-10-13 05:02:46.000000000 +0000
++++ sp-1.3.4/include/config.h 2017-08-20 23:43:49.173227788 +0000
+@@ -26,7 +26,6 @@
+ #endif
+ #if __GNUC__ > 2 || (__GNUC__ == 2 && __GNUC_MINOR__ >= 8)
+ #define SP_ANSI_LIB
+-#define SP_NO_STD_NAMESPACE
+ #undef SP_NEW_H_MISSING
+ #endif
+
diff --git a/system/sp/nsgmls-c++-fix.patch b/system/sp/nsgmls-c++-fix.patch
new file mode 100644
index 000000000..eed72c633
--- /dev/null
+++ b/system/sp/nsgmls-c++-fix.patch
@@ -0,0 +1,11 @@
+--- sp-1.3.4/nsgmls/RastEventHandler.h.old 1997-01-17 06:08:26.000000000 +0000
++++ sp-1.3.4/nsgmls/RastEventHandler.h 2017-08-21 01:52:21.637009355 +0000
+@@ -102,7 +102,7 @@
+
+ class RastEventHandler : public ErrorCountEventHandler,
+ private RastSubdocState,
+- private Messenger {
++ public Messenger {
+ public:
+ RastEventHandler(SgmlParser *, Messenger *);
+ void data(DataEvent *);