summaryrefslogtreecommitdiff
path: root/system/ssmtp
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-08 02:02:24 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-08 02:02:24 -0500
commitfd2bb2f751c13b3c0c002b8e012810902b9da364 (patch)
tree17b2e38c966c9f96cfa568c1f572261a289590e6 /system/ssmtp
parentb0a5136bf3326ba38b360be288d06f9a27f2a4d2 (diff)
downloadpackages-fd2bb2f751c13b3c0c002b8e012810902b9da364.tar.gz
packages-fd2bb2f751c13b3c0c002b8e012810902b9da364.tar.bz2
packages-fd2bb2f751c13b3c0c002b8e012810902b9da364.tar.xz
packages-fd2bb2f751c13b3c0c002b8e012810902b9da364.zip
harmony -> system
Diffstat (limited to 'system/ssmtp')
-rw-r--r--system/ssmtp/APKBUILD52
-rw-r--r--system/ssmtp/generate_config.patch49
-rw-r--r--system/ssmtp/inet6-getaddrinfo.patch12
-rw-r--r--system/ssmtp/libcrypto-underlinking.patch11
4 files changed, 124 insertions, 0 deletions
diff --git a/system/ssmtp/APKBUILD b/system/ssmtp/APKBUILD
new file mode 100644
index 000000000..b7ae28bc7
--- /dev/null
+++ b/system/ssmtp/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+
+pkgname=ssmtp
+pkgver=2.64
+pkgrel=11
+pkgdesc="Extremely simple MTA to get mail off the system to a mail hub"
+subpackages="$pkgname-doc"
+arch="all"
+url="https://packages.debian.org/stable/mail/ssmtp"
+license="GPL2"
+depends=
+makedepends="openssl-dev autoconf"
+options="!check"
+provides="/usr/sbin/sendmail"
+source="http://ftp.debian.org/debian/pool/main/s/$pkgname/${pkgname}_${pkgver}.orig.tar.bz2
+ generate_config.patch
+ libcrypto-underlinking.patch
+ inet6-getaddrinfo.patch
+ "
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ sed -i -e 's:$(CC) -o:$(CC) @LDFLAGS@ -o:' Makefile.in
+ autoconf
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ --enable-ssl \
+ --enable-inet6 \
+ || return 1
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make prefix="$pkgdir"/usr \
+ etcdir="$pkgdir"/etc \
+ mandir="$pkgdir"/usr/share/man \
+ install
+ ln -s ssmtp "$pkgdir"/usr/sbin/sendmail
+}
+
+sha512sums="911752e744420adf58552b9cf3a6e558d8b39103e5ad33a9ed4429b9a3a2091f7674aac11fe9bbd66747a61cdabe6bd638b80efcaadc86b057c12e2e235cca72 ssmtp_2.64.orig.tar.bz2
+a4273d7c5b50984994b35de052c450a872f0014c45c1d3bfe36f2edd4f224281aacea234be61c6e966da2c4d3e033042628b79b2216340001487e6bb3a55b6cd generate_config.patch
+9da89ec5ea66dae8b7a22ffcf196c45005c0403e6505162dba05003feac38eb397f8aff4f140d720f826ea057f92e47302ec3c24bddf5786c10b214ec906e82f libcrypto-underlinking.patch
+92dc128b2f6ce234843e8f1e6ddb72653825652544cd68f693457b3fdc4ee22b0f9861feec0dfd123d012c294c7083dd8d24a9a589a3c2ae5bcdde697d30a290 inet6-getaddrinfo.patch"
diff --git a/system/ssmtp/generate_config.patch b/system/ssmtp/generate_config.patch
new file mode 100644
index 000000000..23285b193
--- /dev/null
+++ b/system/ssmtp/generate_config.patch
@@ -0,0 +1,49 @@
+--- ./generate_config 2004-07-23 05:58:48.000000000 +0000
++++ ./generate_config 2009-01-27 10:09:11.000000000 +0000
+@@ -4,7 +4,7 @@
+ # Figure out the system's mailname
+ #
+
+-syshostname=`hostname --fqdn`
++syshostname="localhost"
+ if test -f /etc/mailname
+ then
+ mailname="`head -1 /etc/mailname`"
+@@ -15,23 +15,7 @@
+ mailname=$syshostname
+ fi
+
+-echo "Please enter the mail name of your system."
+-echo "This is the hostname portion of the address to be shown"
+-echo "on outgoing news and mail messages headers."
+-echo "The default is $syshostname, your system's host name."
+-echo
+-echo -n "Mail name [$syshostname]: "
+-read mailname
+-echo
+-
+-echo -n "Please enter the SMTP port number [25]: "
+-read smtpport
+-if test -z "$smtpport"
+-then
+- mailhub=$mailhub
+-else
+- mailhub="$mailhub:$smtpport"
+-fi
++mailhub="$mailhub:$smtpport"
+
+ #
+ # Generate configuration file
+@@ -56,11 +40,5 @@
+ # Where will the mail seem to come from?
+ #rewriteDomain=`echo -n $mailname`
+ # The full hostname
+-hostname=`hostname --fqdn`
++#hostname="localhost"
+ EOF
+-
+-echo
+-echo
+-echo "Please check the configuration file $1 for correctness."
+-echo
+-echo
diff --git a/system/ssmtp/inet6-getaddrinfo.patch b/system/ssmtp/inet6-getaddrinfo.patch
new file mode 100644
index 000000000..bbc2d90ba
--- /dev/null
+++ b/system/ssmtp/inet6-getaddrinfo.patch
@@ -0,0 +1,12 @@
+diff -up ssmtp.orig/ssmtp.c ssmtp/ssmtp.c
+--- ssmtp.orig/ssmtp.c 2009-11-23 10:55:11.000000000 +0100
++++ ssmtp/ssmtp.c 2015-07-27 17:34:12.498140804 +0200
+@@ -1157,7 +1157,7 @@ int smtp_open(char *host, int port)
+ snprintf(servname, sizeof(servname), "%d", port);
+
+ /* Check we can reach the host */
+- if (getaddrinfo(host, servname, &hints, &ai0)) {
++ if (getaddrinfo(host, servname, &hints, &ai0) != 0) {
+ log_event(LOG_ERR, "Unable to locate %s", host);
+ return(-1);
+ }
diff --git a/system/ssmtp/libcrypto-underlinking.patch b/system/ssmtp/libcrypto-underlinking.patch
new file mode 100644
index 000000000..4928f271c
--- /dev/null
+++ b/system/ssmtp/libcrypto-underlinking.patch
@@ -0,0 +1,11 @@
+--- ./configure.in.orig
++++ ./configure.in
+@@ -52,7 +52,7 @@
+ [ --enable-ssl support for secure connection to mail server])
+ if test x$enableval = xyes ; then
+ AC_DEFINE(HAVE_SSL)
+- LIBS="$LIBS -lssl"
++ LIBS="$LIBS -lssl -lcrypto"
+ fi
+ enableval=""
+