summaryrefslogtreecommitdiff
path: root/system/syslinux/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-12 17:11:56 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-12 17:11:56 -0600
commit1377839255595ae4d2b493ad0c7d42e5e6afcb64 (patch)
treec84dd4e6f28bef0f0e2f62fcb4fba32a078cead9 /system/syslinux/APKBUILD
parent9d5276776fc3b29adaeeac90bea30d057dc2a3f6 (diff)
downloadpackages-1377839255595ae4d2b493ad0c7d42e5e6afcb64.tar.gz
packages-1377839255595ae4d2b493ad0c7d42e5e6afcb64.tar.bz2
packages-1377839255595ae4d2b493ad0c7d42e5e6afcb64.tar.xz
packages-1377839255595ae4d2b493ad0c7d42e5e6afcb64.zip
system/syslinux: bring over from aports fork
Diffstat (limited to 'system/syslinux/APKBUILD')
-rw-r--r--system/syslinux/APKBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/system/syslinux/APKBUILD b/system/syslinux/APKBUILD
new file mode 100644
index 000000000..25e7cb252
--- /dev/null
+++ b/system/syslinux/APKBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=syslinux
+pkgver=6.04_pre1
+pkgrel=2
+_ver=${pkgver/_/-}
+pkgdesc="Boot loader for the Linux operating system"
+url="http://syslinux.org"
+arch="x86 x86_64"
+license="GPL"
+makedepends="linux-headers nasm perl util-linux-dev gnu-efi-dev"
+depends="mtools blkid mawk"
+triggers="syslinux.trigger=/boot"
+install="syslinux.post-upgrade"
+options="!check textrels" # does not ship tests in tarball
+ldpath="/usr/share/syslinux"
+
+source="https://www.kernel.org/pub/linux/utils/boot/syslinux/Testing/${pkgver%_pre*}/syslinux-$_ver.tar.xz
+ update-extlinux.conf
+ update-extlinux
+ "
+subpackages="$pkgname-doc $pkgname-dev"
+
+_loaderarch=
+case "$CARCH" in
+x86) _loaderarch=efi32;;
+x86_64) _loaderarch=efi64;;
+esac
+
+builddir="$srcdir"/$pkgname-$_ver
+prepare() {
+ cd "$builddir"
+ for i in $source; do
+ i=${i%%::*}
+ case "$i" in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$builddir"
+ unset LDFLAGS
+ make $_loaderarch installer || return 1
+}
+
+package() {
+ cd "$builddir"
+ make -j1 INSTALLROOT="$pkgdir" MANDIR=/usr/share/man \
+ bios $_loaderarch install || return 1
+
+ mkdir -p "$pkgdir"/etc/update-extlinux.d
+ cp "$srcdir"/update-extlinux.conf "$pkgdir"/etc/
+ sed "/^version=/s/=.*/=$pkgver-r$pkgrel/" "$srcdir"/update-extlinux \
+ > "$pkgdir"/sbin/update-extlinux
+ chmod 755 "$pkgdir"/sbin/update-extlinux
+}
+
+sha512sums="7927dd39be8e2dcf4138a6fea33def67d19d938379d694f15b48fdd2f5924c028b7a9e7bd71d0c7c6630c203e9e2a54296628e530632ad5e6f55b1ebefe8fc98 syslinux-6.04-pre1.tar.xz
+9071be450e543597f6f95b9a5811869c5351a71f4c42f7879b9f7ec1b13e2e4d455e9f2900e3897d5e5870bd87c934b7168328186c5f17631f2b09a524e10a1a update-extlinux.conf
+23fd69b5f42af063744289f64e60eddd0fa35db83d988b24635e6eb47b5c8fada8585c9aea60f398cfc1e5be8565230a81192d71df705368a90e0927f35fb60d update-extlinux"