summaryrefslogtreecommitdiff
path: root/system/unzip/APKBUILD
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-03-21 14:41:57 -0500
committerMax Rees <maxcrees@me.com>2020-03-21 16:41:33 -0500
commita44b1ab6ad91b2ad5780e67cae3065648c0a78a8 (patch)
treeaa4626713cb7aca082e9d88d0508f3f608e96b30 /system/unzip/APKBUILD
parent3e7d2c3bb270b56c4b30a5e580146c7a87cd9bf4 (diff)
downloadpackages-a44b1ab6ad91b2ad5780e67cae3065648c0a78a8.tar.gz
packages-a44b1ab6ad91b2ad5780e67cae3065648c0a78a8.tar.bz2
packages-a44b1ab6ad91b2ad5780e67cae3065648c0a78a8.tar.xz
packages-a44b1ab6ad91b2ad5780e67cae3065648c0a78a8.zip
system/unzip: change upstream to Debian (#123)
Debian's patches close several CVEs, including a few of which I wasn't even aware. They also include the patches we were already carrying: These were plucked directly from Debian so the names are the same: 10-unzip-handle-pkware-verify.patch 20-unzip-uidgid-fix.patch Our unzip-6.0-heap-overflow-infloop.patch is covered by Debian's: 14-cve-2015-7696.patch 15-cve-2015-7697.patch 16-fix-integer-underflow-csiz-decrypted.patch
Diffstat (limited to 'system/unzip/APKBUILD')
-rw-r--r--system/unzip/APKBUILD31
1 files changed, 24 insertions, 7 deletions
diff --git a/system/unzip/APKBUILD b/system/unzip/APKBUILD
index e915966a0..ea8f7e6fa 100644
--- a/system/unzip/APKBUILD
+++ b/system/unzip/APKBUILD
@@ -4,7 +4,8 @@
pkgname=unzip
pkgver=6.0
_pkgver=$(printf '%s' "$pkgver" | tr -d .)
-pkgrel=3
+_debver=25
+pkgrel=4
pkgdesc="Extract PKZIP-compatible .zip files"
url="http://www.info-zip.org/UnZip.html"
arch="all"
@@ -12,12 +13,30 @@ license="Info-ZIP"
subpackages="$pkgname-doc"
# normally ftp://ftp.info-zip.org/pub/infozip/src/$pkgname$_pkgver.zip
source="$pkgname-$pkgver.tgz::https://distfiles.adelielinux.org/source/$pkgname$_pkgver.tgz
- 10-unzip-handle-pkware-verify.patch
- 20-unzip-uidgid-fix.patch
- unzip-6.0-heap-overflow-infloop.patch
+ http://deb.debian.org/debian/pool/main/u/unzip/unzip_$pkgver-$_debver.debian.tar.xz
"
builddir="$srcdir/$pkgname$_pkgver"
+# secfixes:
+# 6.0-r4:
+# - CVE-2014-8139
+# - CVE-2014-8140
+# - CVE-2014-8141
+# - CVE-2014-9636
+# - CVE-2014-9913
+# - CVE-2016-9844
+# - CVE-2018-18384
+# - CVE-2018-1000035
+# - CVE-2019-13232
+
+prepare() {
+ default_prepare
+ while read -r i; do
+ msg "$i"
+ patch -p1 -i "../debian/patches/$i"
+ done < ../debian/patches/series
+}
+
build() {
make -f unix/Makefile \
CC="${CHOST}-gcc" \
@@ -38,6 +57,4 @@ package() {
}
sha512sums="0694e403ebc57b37218e00ec1a406cae5cc9c5b52b6798e0d4590840b6cdbf9ddc0d9471f67af783e960f8fa2e620394d51384257dca23d06bcd90224a80ce5d unzip-6.0.tgz
-9d2914f22fb0075a2b6f72825c235f46eafd8d47b6fb6fcc8303fc69336e256b15923c002d2615bb6af733344c2315e4a8504d77bae301e10c11d4736faa2c81 10-unzip-handle-pkware-verify.patch
-57699582e9056af0817dcb67f8db67e6a1ff8208c137fbebcf559429e5f12b471b75d7e1ef938e5bbb5416074a51ac7342e4ce8057f4bbdcb0bf079b8d7832af 20-unzip-uidgid-fix.patch
-b1e3fac6a787828efaaef8ec7cc52e1573aea27a6f29830af37ec4ba8bcd2a6488c953ab10eee0561c78e82c7401833ef172bebee793405d93632ce788756301 unzip-6.0-heap-overflow-infloop.patch"
+13c16db420fa4a34be3090a9acdd79b01320da40ac5aa89a9dfca03e64b914b28eb72aff3882d02a8197457bcb8eeb9473c998cf6920e511883c9289a949fb21 unzip_6.0-25.debian.tar.xz"