summaryrefslogtreecommitdiff
path: root/system/unzip/APKBUILD
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-06-14 00:52:37 -0500
committerMax Rees <maxcrees@me.com>2020-06-14 00:52:37 -0500
commitcc8b68b5a796ff131289930ead8f4b0d0812b348 (patch)
tree14c2ddb945975f98747017d6a7575f6af0a875c7 /system/unzip/APKBUILD
parent4e53c51f591cbd62817c797c10d240c008182ab3 (diff)
downloadpackages-cc8b68b5a796ff131289930ead8f4b0d0812b348.tar.gz
packages-cc8b68b5a796ff131289930ead8f4b0d0812b348.tar.bz2
packages-cc8b68b5a796ff131289930ead8f4b0d0812b348.tar.xz
packages-cc8b68b5a796ff131289930ead8f4b0d0812b348.zip
system/unzip: miscellaneous fixes
* Make sure CFLAGS are respected by setting LOCAL_UNZIP instead of LOCAL_ZIP and unsetting CFLAGS_OPT in the configure script. * Don't strip too early by setting STRIP to a no-op and unsetting LFLAGS2 in the configure script. * Cherry-pick a patch from Fedora to fix format warnings. * Fix unzipsfx test on 32-bit arches by casting a literal argument to the correct type.
Diffstat (limited to 'system/unzip/APKBUILD')
-rw-r--r--system/unzip/APKBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/system/unzip/APKBUILD b/system/unzip/APKBUILD
index ea8f7e6fa..9b3f696f3 100644
--- a/system/unzip/APKBUILD
+++ b/system/unzip/APKBUILD
@@ -5,7 +5,7 @@ pkgname=unzip
pkgver=6.0
_pkgver=$(printf '%s' "$pkgver" | tr -d .)
_debver=25
-pkgrel=4
+pkgrel=5
pkgdesc="Extract PKZIP-compatible .zip files"
url="http://www.info-zip.org/UnZip.html"
arch="all"
@@ -14,6 +14,9 @@ subpackages="$pkgname-doc"
# normally ftp://ftp.info-zip.org/pub/infozip/src/$pkgname$_pkgver.zip
source="$pkgname-$pkgver.tgz::https://distfiles.adelielinux.org/source/$pkgname$_pkgver.tgz
http://deb.debian.org/debian/pool/main/u/unzip/unzip_$pkgver-$_debver.debian.tar.xz
+ cflags.patch
+ format-secure.patch
+ unzipsfx-bomb-32bit.patch
"
builddir="$srcdir/$pkgname$_pkgver"
@@ -30,17 +33,19 @@ builddir="$srcdir/$pkgname$_pkgver"
# - CVE-2019-13232
prepare() {
- default_prepare
+ cd "$builddir"
while read -r i; do
msg "$i"
patch -p1 -i "../debian/patches/$i"
done < ../debian/patches/series
+ default_prepare
}
build() {
make -f unix/Makefile \
CC="${CHOST}-gcc" \
- LOCAL_ZIP="${CFLAGS} ${CPPFLAGS}" \
+ LOCAL_UNZIP="${CFLAGS} ${CPPFLAGS}" \
+ STRIP=: \
prefix=/usr generic
}
@@ -57,4 +62,7 @@ package() {
}
sha512sums="0694e403ebc57b37218e00ec1a406cae5cc9c5b52b6798e0d4590840b6cdbf9ddc0d9471f67af783e960f8fa2e620394d51384257dca23d06bcd90224a80ce5d unzip-6.0.tgz
-13c16db420fa4a34be3090a9acdd79b01320da40ac5aa89a9dfca03e64b914b28eb72aff3882d02a8197457bcb8eeb9473c998cf6920e511883c9289a949fb21 unzip_6.0-25.debian.tar.xz"
+13c16db420fa4a34be3090a9acdd79b01320da40ac5aa89a9dfca03e64b914b28eb72aff3882d02a8197457bcb8eeb9473c998cf6920e511883c9289a949fb21 unzip_6.0-25.debian.tar.xz
+029447a48972234e60c6b45c58b01dbe411594b1ffe0db00d028810b0bcfa7244dcc89f765e1ee6e8805ba2d2db9bc1d05a1e30ef0d9dd08d33ff6f04af811ab cflags.patch
+4bdf55937a181d496261a8f426a97d63844ba96f23beea7906c5e4f7064f55c188ee5ec3ae2d6f2011b5f26b6ac0941dcffb83c06370ed9648b2262917cde64d format-secure.patch
+81777dfa1ad707046b238fa9205f8be0f48363f0f23bc0d2d83b67b143ceeba6818cc11058355195a03432cdd6ed4f392202ff3029e14d4b1435c9e2cb5ca6bf unzipsfx-bomb-32bit.patch"