summaryrefslogtreecommitdiff
path: root/system/utmps
diff options
context:
space:
mode:
authorLaurent Bercot <ska-adelie@skarnet.org>2023-01-15 12:35:39 +0000
committerLaurent Bercot <ska-adelie@skarnet.org>2023-01-15 12:35:39 +0000
commit34850fd823da1e55d445c6b8c824ec08c68d5f0c (patch)
tree32949d253430fc52a9dcda12be72e0b9083a1f77 /system/utmps
parentd6b4114ddf67ed19d05798990dd4d2ce8a8d2d0c (diff)
downloadpackages-34850fd823da1e55d445c6b8c824ec08c68d5f0c.tar.gz
packages-34850fd823da1e55d445c6b8c824ec08c68d5f0c.tar.bz2
packages-34850fd823da1e55d445c6b8c824ec08c68d5f0c.tar.xz
packages-34850fd823da1e55d445c6b8c824ec08c68d5f0c.zip
system/utmps: upgrade to 0.1.2.1
Diffstat (limited to 'system/utmps')
-rw-r--r--system/utmps/APKBUILD8
-rw-r--r--system/utmps/utmps.initd12
2 files changed, 9 insertions, 11 deletions
diff --git a/system/utmps/APKBUILD b/system/utmps/APKBUILD
index ccdc0c615..1410cee65 100644
--- a/system/utmps/APKBUILD
+++ b/system/utmps/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
pkgname=utmps
-pkgver=0.1.2.0
+pkgver=0.1.2.1
pkgrel=0
pkgdesc="A secure utmp/wtmp implementation"
url="https://skarnet.org/software/$pkgname/"
@@ -9,7 +9,7 @@ arch="all"
options="!check" # No test suite
license="ISC"
depends="execline s6"
-_skalibs_version=2.12
+_skalibs_version=2.13
makedepends="skalibs-dev>=$_skalibs_version"
subpackages="$pkgname-libs $pkgname-dev $pkgname-libs-dev:libsdev $pkgname-doc $pkgname-openrc"
install="$pkgname.post-upgrade"
@@ -91,8 +91,8 @@ doc() {
cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
}
-sha512sums="a89c054584680ec1abeb145d244488433cbb3e837fbd77e8914c402e84ce7bc50615c8cf13e7f97316096417fcd5ed84a24f618b4714c640cd8e39fb6749b00d utmps-0.1.2.0.tar.gz
+sha512sums="20bf9bfabfdd390377ca86d85da4a263a027ee5bdf5b7305bc6fb44d4aea7b4af886580f485d543895f85fb61d4f0ac711afba342a911c5ef928076c35746134 utmps-0.1.2.1.tar.gz
0ec30284c64c6ea9f25142c5f4a643bd48b137fe85781b650104f5137ffa4dfc35ca7be3e41e3acd3403ebe1d8c5378073afa4e2f3607d3d794fcd9f98ed51c4 utmpd.run
9e875a5cd37be531320a8e582afed2c980dd0a1bdfc2f6f3d826d5e5389fc6ab93f973ed1506edb23f4c73cf24a2357aefe856148eaacff86c2aafe376c575e2 wtmpd.run
503bdbb3d244243934b9b4e3deea0bf92a95f88417c822ad9cf6202584d4724d5e182a0d88d7f09069e435a8a97230b85d2b264736c85c893da193fd5ec34c71 btmpd.run
-3a658c7b078f3df4d20192b0719c2c8ac5b08083c7c36807ef39ab67232ffacc64429c63fba27a06d509048b3ebf47128885ef34aa4b6fac1ad8df894cbb604a utmps.initd"
+a14ab7527fa7a4c182a1f938452acf3ff9b578d39a3e9eb81d1dad6ad558cf41a870ccac614790d75d91879d063cf64ab5456d6b6916d28fb2a829c83ae45f62 utmps.initd"
diff --git a/system/utmps/utmps.initd b/system/utmps/utmps.initd
index c6f884a52..6091bbb10 100644
--- a/system/utmps/utmps.initd
+++ b/system/utmps/utmps.initd
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 2022 Adélie Linux
+# Copyright 2022-2023 Adélie Linux
description="boot script for the utmps wtmp and btmp services"
@@ -13,18 +13,16 @@ depend()
stop()
{
ebegin "Stopping the utmps wtmp and btmp services"
- touch /run/service/wtmpd/down /run/service/btmpd/down
- s6-svc -d /run/service/btmpd
- s6-svc -d /run/service/wtmpd
+ s6-svc -D /run/service/btmpd
+ s6-svc -D /run/service/wtmpd
eend $?
}
start()
{
ebegin "Starting the utmps wtmp and btmp services"
- rm -f /run/service/wtmpd/down /run/service/btmpd/down
s6-svlisten -U " /run/service/wtmpd" " /run/service/btmpd" "" \
- foreground " s6-svc" " -u" " /run/service/wtmpd" "" \
- s6-svc -u /run/service/btmpd
+ foreground " s6-svc" " -U" " /run/service/wtmpd" "" \
+ s6-svc -U /run/service/btmpd
eend $?
}