summaryrefslogtreecommitdiff
path: root/system/vim
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2019-01-27 01:30:26 -0600
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2019-01-27 01:30:26 -0600
commita8efa399d5161d66d7569ad6b57ee6fbf847022a (patch)
treecd6a9a834a1517a2f95009a1c5e013c05c0b05eb /system/vim
parent63b991b36046f8c219d67fa7d554803eb7ccd3bf (diff)
downloadpackages-a8efa399d5161d66d7569ad6b57ee6fbf847022a.tar.gz
packages-a8efa399d5161d66d7569ad6b57ee6fbf847022a.tar.bz2
packages-a8efa399d5161d66d7569ad6b57ee6fbf847022a.tar.xz
packages-a8efa399d5161d66d7569ad6b57ee6fbf847022a.zip
system/vim: upgrade to 8.1.0829
Diffstat (limited to 'system/vim')
-rw-r--r--system/vim/APKBUILD8
-rw-r--r--system/vim/no-default-mouse.patch16
-rw-r--r--system/vim/vimrc2
3 files changed, 21 insertions, 5 deletions
diff --git a/system/vim/APKBUILD b/system/vim/APKBUILD
index 7f62e86bd..13dff8ef9 100644
--- a/system/vim/APKBUILD
+++ b/system/vim/APKBUILD
@@ -4,7 +4,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=vim
-pkgver=8.1.0712
+pkgver=8.1.0829
pkgrel=0
pkgdesc="advanced text editor"
url="http://www.vim.org"
@@ -17,6 +17,7 @@ makedepends_host="acl-dev ncurses-dev"
subpackages="$pkgname-doc ${pkgname}diff::noarch"
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz
vimrc
+ no-default-mouse.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -80,5 +81,6 @@ vimdiff() {
mv "$pkgdir"/usr/bin/vimdiff "$subpkgdir"/usr/bin
}
-sha512sums="087d9d26898db718a0eb7a2bbaacfa87f4f907f2a89a21aff51688f5fd8a58284b075ba7f597c9c39f252e7b9aab8bc93f7bc9f2d67e486c17498be35443d10f vim-8.1.0712.tar.gz
-3a6c9bc187a6f45fd78e91dcc44d4d661c1ae1f2655e3a66bb36245ad1dc41e8d0e6061ec3aee6d323f96058b4a5501a87e3327e539cfd026f68cf81d455d721 vimrc"
+sha512sums="c5ae44a6ad45092abc1079b0543af3c34d49823a95f96bbb8dbe3f5426556ee9dbf78d2bda747286527977dafef7e6051a670d0095456263e853d424ddb2466c vim-8.1.0829.tar.gz
+12ee3f96c94d74215159fba379ed61907ec5982a9f1643575dcb7c3d5e30824665d683de95f97b5067718b3f2a1238fb7534a70803bc170614498ad026f352d8 vimrc
+16026a3ed3e080b3f8281948579ab678e9acd724ad594463279712fbf1024bcd923155a133bd08118848d2c6cdf11c69489d85b1c7438f60b4c279094714d181 no-default-mouse.patch"
diff --git a/system/vim/no-default-mouse.patch b/system/vim/no-default-mouse.patch
new file mode 100644
index 000000000..c34b9cae7
--- /dev/null
+++ b/system/vim/no-default-mouse.patch
@@ -0,0 +1,16 @@
+diff -Nurd vim-8.1.0712/runtime/defaults.vim vim-8.1.0712.new/runtime/defaults.vim
+--- vim-8.1.0712/runtime/defaults.vim 2019-01-09 16:02:43.000000000 -0600
++++ vim-8.1.0712.new/runtime/defaults.vim 2019-01-27 01:18:04.196123398 -0600
+@@ -73,12 +73,6 @@
+ " Revert with ":iunmap <C-U>".
+ inoremap <C-U> <C-G>u<C-U>
+
+-" In many terminal emulators the mouse works just fine. By enabling it you
+-" can position the cursor, Visually select and scroll with the mouse.
+-if has('mouse')
+- set mouse=a
+-endif
+-
+ " Switch syntax highlighting on when the terminal has colors or when using the
+ " GUI (which always has colors).
+ if &t_Co > 2 || has("gui_running")
diff --git a/system/vim/vimrc b/system/vim/vimrc
index 66b72282c..df08a4866 100644
--- a/system/vim/vimrc
+++ b/system/vim/vimrc
@@ -4,8 +4,6 @@ set ai " Always set auto-indenting on
set history=50 " keep 50 lines of command history
set ruler " Show the cursor position all the time
-set mouse="" " Use Vim 7 default of no mouse movements by default
-
" Don't use Ex mode, use Q for formatting
map Q gq