summaryrefslogtreecommitdiff
path: root/system/yaml/APKBUILD
diff options
context:
space:
mode:
authorzlg <zlg@zlg.space>2018-11-20 20:47:42 -0800
committerzlg <zlg@zlg.space>2018-11-20 20:54:33 -0800
commit78d40257bd969b58407a251d9746e8fcf0fe4879 (patch)
tree7e36bd1f80120f2043cf9357f0745ae7ececdae6 /system/yaml/APKBUILD
parent75c78e3366d98013cc1d0f897db658243cceb6c5 (diff)
downloadpackages-78d40257bd969b58407a251d9746e8fcf0fe4879.tar.gz
packages-78d40257bd969b58407a251d9746e8fcf0fe4879.tar.bz2
packages-78d40257bd969b58407a251d9746e8fcf0fe4879.tar.xz
packages-78d40257bd969b58407a251d9746e8fcf0fe4879.zip
system/yaml: Backport emitter fix from v0.2.2-pre1
These patches fix an emitter problem that prevents PyYAML 3.13's test suite from passing. They should not be necessary when libyaml v0.2.2 is released. Patch-Author: James Clarke <jrtc27@jrtc27.com> See-Also: https://github.com/yaml/pyyaml/issues/184 See-Also: https://github.com/yaml/libyaml/issues/60#issuecomment-311836709
Diffstat (limited to 'system/yaml/APKBUILD')
-rw-r--r--system/yaml/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/system/yaml/APKBUILD b/system/yaml/APKBUILD
index 323ac3b40..4dfac01b3 100644
--- a/system/yaml/APKBUILD
+++ b/system/yaml/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=yaml
pkgver=0.2.1
-pkgrel=0
+pkgrel=1
pkgdesc="YAML 1.1 parser and emitter written in C"
url="https://pyyaml.org/wiki/LibYAML"
arch="all"
@@ -10,7 +10,9 @@ license="MIT"
depends=""
makedepends=""
subpackages="$pkgname-dev"
-source="http://pyyaml.org/download/libyaml/yaml-$pkgver.tar.gz"
+source="http://pyyaml.org/download/libyaml/yaml-$pkgver.tar.gz
+ fix-emitter-$pkgver.patch
+ skip-trailing-doc-term-$pkgver.patch"
build() {
cd "$builddir"
@@ -35,4 +37,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="97ebeea2a2c877b24de2e1ffbf175d07d97d5c8b90e06d21fd057e1114d10b96c04fd92c2ed4e956db751b7ac1686b3fd5778927912ca5bb0d096908a1351235 yaml-0.2.1.tar.gz"
+sha512sums="97ebeea2a2c877b24de2e1ffbf175d07d97d5c8b90e06d21fd057e1114d10b96c04fd92c2ed4e956db751b7ac1686b3fd5778927912ca5bb0d096908a1351235 yaml-0.2.1.tar.gz
+ad35c3b893cfeb33fab748b39b06ad0c54215941f68d0df591b8e4e4edc3b67f27ea3206321b7621c0e9e6faf749255fd80209da017c77a91d8de68eec54fd2b fix-emitter-0.2.1.patch
+715ad72a4a74b19fdf03b8be96b9e5c3801bab5475eeee4c98b109eabcf86e193d5884ad6466b6765ccc2174ebaedade25e43fff711d9522fb8f370bcea5eef4 skip-trailing-doc-term-0.2.1.patch"