summaryrefslogtreecommitdiff
path: root/system/yaml
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-17 21:28:25 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-17 21:28:25 +0000
commit6b809a7e00e41cc5026cfd4896410783f5baec6f (patch)
tree4134b3d960b17bc7bab9f934b7ce26c7a3247413 /system/yaml
parent75168d1fdb3ba9556e26794d8e498c2e43cf702b (diff)
downloadpackages-6b809a7e00e41cc5026cfd4896410783f5baec6f.tar.gz
packages-6b809a7e00e41cc5026cfd4896410783f5baec6f.tar.bz2
packages-6b809a7e00e41cc5026cfd4896410783f5baec6f.tar.xz
packages-6b809a7e00e41cc5026cfd4896410783f5baec6f.zip
system/yaml: bump to 0.2.2
Diffstat (limited to 'system/yaml')
-rw-r--r--system/yaml/APKBUILD15
-rw-r--r--system/yaml/fix-emitter-0.2.1.patch35
-rw-r--r--system/yaml/skip-trailing-doc-term-0.2.1.patch30
3 files changed, 4 insertions, 76 deletions
diff --git a/system/yaml/APKBUILD b/system/yaml/APKBUILD
index f6e0dfd63..7542e1305 100644
--- a/system/yaml/APKBUILD
+++ b/system/yaml/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=yaml
-pkgver=0.2.1
-pkgrel=1
+pkgver=0.2.2
+pkgrel=0
pkgdesc="YAML 1.1 parser and emitter written in C"
url="https://pyyaml.org/wiki/LibYAML"
arch="all"
@@ -10,12 +10,9 @@ license="MIT"
depends=""
makedepends=""
subpackages="$pkgname-dev"
-source="https://pyyaml.org/download/libyaml/yaml-$pkgver.tar.gz
- fix-emitter-$pkgver.patch
- skip-trailing-doc-term-$pkgver.patch"
+source="https://pyyaml.org/download/libyaml/yaml-$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,15 +25,11 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="97ebeea2a2c877b24de2e1ffbf175d07d97d5c8b90e06d21fd057e1114d10b96c04fd92c2ed4e956db751b7ac1686b3fd5778927912ca5bb0d096908a1351235 yaml-0.2.1.tar.gz
-ad35c3b893cfeb33fab748b39b06ad0c54215941f68d0df591b8e4e4edc3b67f27ea3206321b7621c0e9e6faf749255fd80209da017c77a91d8de68eec54fd2b fix-emitter-0.2.1.patch
-715ad72a4a74b19fdf03b8be96b9e5c3801bab5475eeee4c98b109eabcf86e193d5884ad6466b6765ccc2174ebaedade25e43fff711d9522fb8f370bcea5eef4 skip-trailing-doc-term-0.2.1.patch"
+sha512sums="13d2197135946204323dbfccafa0ac7b3d05437e920545a56f46811fd7319c01419a58083090ce85fccd4d6901a620ceb9f1190078cc0830bc0ce769bb024f51 yaml-0.2.2.tar.gz"
diff --git a/system/yaml/fix-emitter-0.2.1.patch b/system/yaml/fix-emitter-0.2.1.patch
deleted file mode 100644
index f3614e349..000000000
--- a/system/yaml/fix-emitter-0.2.1.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Contributor Note: This patch will be part of v0.2.2 which hasn't been
-formally released as of 2018-11-20. It should be removed once this
-package is version bumped.
-
-From e5ebb70a01cc0fbd9e519050d51d704f58c2a33d Mon Sep 17 00:00:00 2001
-From: James Clarke <jrtc27@jrtc27.com>
-Date: Thu, 29 Jun 2017 02:26:09 +0100
-Subject: [PATCH 2/2] Skip trailing document terminator at the end of the
- stream
-
----
- src/emitter.c | 8 --------
- 1 file changed, 8 deletions(-)
-
-diff --git a/src/emitter.c b/src/emitter.c
-index c593a7d..1502590 100644
---- a/src/emitter.c
-+++ b/src/emitter.c
-@@ -649,14 +649,6 @@ yaml_emitter_emit_document_start(yaml_emitter_t *emitter,
-
- else if (event->type == YAML_STREAM_END_EVENT)
- {
-- if (emitter->open_ended)
-- {
-- if (!yaml_emitter_write_indicator(emitter, "...", 1, 0, 0))
-- return 0;
-- if (!yaml_emitter_write_indent(emitter))
-- return 0;
-- }
--
- if (!yaml_emitter_flush(emitter))
- return 0;
-
---
-2.13.2
diff --git a/system/yaml/skip-trailing-doc-term-0.2.1.patch b/system/yaml/skip-trailing-doc-term-0.2.1.patch
deleted file mode 100644
index 7e10cd9ea..000000000
--- a/system/yaml/skip-trailing-doc-term-0.2.1.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Contributor Note: As with fix-emitter-0.2.1.patch, this patch should
-not be necessary when v0.2.2 is released.
-
-From 7c2e6f47e1b12ca3dfa9ea2f6c65e9bd8a02e8c8 Mon Sep 17 00:00:00 2001
-From: James Clarke <jrtc27@jrtc27.com>
-Date: Thu, 29 Jun 2017 02:24:53 +0100
-Subject: [PATCH 1/2] Revert "This code is not needed and breaks tests"
-
-This reverts commit 56400d976a1999156b1abfd674c3122843980260.
----
- src/emitter.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/emitter.c b/src/emitter.c
-index a5b7ff8..c593a7d 100644
---- a/src/emitter.c
-+++ b/src/emitter.c
-@@ -1946,6 +1946,10 @@ yaml_emitter_write_plain_scalar(yaml_emitter_t *emitter,
-
- emitter->whitespace = 0;
- emitter->indention = 0;
-+ if (emitter->root_context)
-+ {
-+ emitter->open_ended = 1;
-+ }
-
- return 1;
- }
---
-2.13.2