summaryrefslogtreecommitdiff
path: root/system/zip
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 01:25:05 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 01:25:05 +0000
commit3ea118af1cd765fc11767538a4724bfa88ee4d14 (patch)
tree20ca87504ef803f47ef99f09347d6d3575a022f8 /system/zip
parente64e8125463de387720322e2fc84e2943811dfdf (diff)
downloadpackages-3ea118af1cd765fc11767538a4724bfa88ee4d14.tar.gz
packages-3ea118af1cd765fc11767538a4724bfa88ee4d14.tar.bz2
packages-3ea118af1cd765fc11767538a4724bfa88ee4d14.tar.xz
packages-3ea118af1cd765fc11767538a4724bfa88ee4d14.zip
system/the rest: modernise, fix metadata
Diffstat (limited to 'system/zip')
-rw-r--r--system/zip/APKBUILD3
1 files changed, 0 insertions, 3 deletions
diff --git a/system/zip/APKBUILD b/system/zip/APKBUILD
index ed060ef03..457dbac28 100644
--- a/system/zip/APKBUILD
+++ b/system/zip/APKBUILD
@@ -15,16 +15,13 @@ source="https://sourceforge.net/projects/infozip/files/Zip%203.x%20%28latest%29/
10-zip-3.0-build.patch
20-zip-3.0-exec-stack.patch
30-zip-3.0-pic.patch"
-
builddir="$srcdir"/${pkgname}30
build() {
- cd "$builddir"
make -f unix/Makefile LOCAL_ZIP="${CFLAGS} ${CPPFLAGS}" prefix=/usr generic
}
package() {
- cd "$builddir"
make -f unix/Makefile prefix=${pkgdir}/usr MANDIR=${pkgdir}/usr/share/man install
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}