summaryrefslogtreecommitdiff
path: root/system/zlib
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-04-19 15:41:37 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-01 17:05:56 -0500
commit35890573a59b72293977841f74ef998c8d77bd20 (patch)
tree0771a91056253f9b10c4b01d6c8e632d29fd32a3 /system/zlib
parente40c6b39b7390c91c055bd1f5443d71450bca925 (diff)
downloadpackages-35890573a59b72293977841f74ef998c8d77bd20.tar.gz
packages-35890573a59b72293977841f74ef998c8d77bd20.tar.bz2
packages-35890573a59b72293977841f74ef998c8d77bd20.tar.xz
packages-35890573a59b72293977841f74ef998c8d77bd20.zip
system/zlib: bump { 1.2.11 --> 1.2.12 }. fixes #527, #528, #529. become maintainer.
Diffstat (limited to 'system/zlib')
-rw-r--r--system/zlib/APKBUILD15
-rw-r--r--system/zlib/fix-configure-issue.patch24
-rw-r--r--system/zlib/keep-legacy-crc-behavior.patch51
3 files changed, 85 insertions, 5 deletions
diff --git a/system/zlib/APKBUILD b/system/zlib/APKBUILD
index 42233e86f..39490a78b 100644
--- a/system/zlib/APKBUILD
+++ b/system/zlib/APKBUILD
@@ -1,7 +1,7 @@
-# Maintainer:
+# Maintainer: Zach van Rijn <me@zv.io>
pkgname=zlib
-pkgver=1.2.11
-pkgrel=1
+pkgver=1.2.12
+pkgrel=0
pkgdesc="A compression/decompression Library"
arch="all"
license="Zlib"
@@ -9,7 +9,10 @@ url="https://zlib.net"
depends=""
makedepends=""
subpackages="$pkgname-dev $pkgname-doc"
-source="https://zlib.net/$pkgname-$pkgver.tar.gz"
+source="https://zlib.net/$pkgname-$pkgver.tar.gz
+ fix-configure-issue.patch
+ keep-legacy-crc-behavior.patch
+ "
build() {
CHOST="${CHOST}" ./configure \
@@ -29,4 +32,6 @@ package() {
DESTDIR="$pkgdir"
}
-sha512sums="73fd3fff4adeccd4894084c15ddac89890cd10ef105dd5e1835e1e9bbb6a49ff229713bd197d203edfa17c2727700fce65a2a235f07568212d820dca88b528ae zlib-1.2.11.tar.gz"
+sha512sums="cc2366fa45d5dfee1f983c8c51515e0cff959b61471e2e8d24350dea22d3f6fcc50723615a911b046ffc95f51ba337d39ae402131a55e6d1541d3b095d6c0a14 zlib-1.2.12.tar.gz
+078f85be91fa0051d50950148894356a4a3e179aea78163499f929c4f4f1d7b87087d082af4ba2f6fd7eb2574f3ec4082a32f8877a863ca20673717cb66e9f4d fix-configure-issue.patch
+38f0593a0bc17336d31191b7af684e31ec2eb34bd3add49bcb1f95c5e2bfb4405ffc341c2650d52c4fbf417ab4f80a0cc82fb868c9816b04d25210ae29a71f2c keep-legacy-crc-behavior.patch"
diff --git a/system/zlib/fix-configure-issue.patch b/system/zlib/fix-configure-issue.patch
new file mode 100644
index 000000000..0136071ea
--- /dev/null
+++ b/system/zlib/fix-configure-issue.patch
@@ -0,0 +1,24 @@
+From 05796d3d8d5546cf1b4dfe2cd72ab746afae505d Mon Sep 17 00:00:00 2001
+From: Mark Adler <madler@alumni.caltech.edu>
+Date: Mon, 28 Mar 2022 18:34:10 -0700
+Subject: [PATCH] Fix configure issue that discarded provided CC definition.
+
+---
+ configure | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/configure b/configure
+index 52ff4a04e..3fa3e8618 100755
+--- a/configure
++++ b/configure
+@@ -174,7 +174,10 @@ if test -z "$CC"; then
+ else
+ cc=${CROSS_PREFIX}cc
+ fi
++else
++ cc=${CC}
+ fi
++
+ cflags=${CFLAGS-"-O3"}
+ # to force the asm version use: CFLAGS="-O3 -DASMV" ./configure
+ case "$cc" in
diff --git a/system/zlib/keep-legacy-crc-behavior.patch b/system/zlib/keep-legacy-crc-behavior.patch
new file mode 100644
index 000000000..85a6a7e3a
--- /dev/null
+++ b/system/zlib/keep-legacy-crc-behavior.patch
@@ -0,0 +1,51 @@
+From ec3df00224d4b396e2ac6586ab5d25f673caa4c2 Mon Sep 17 00:00:00 2001
+From: Mark Adler <madler@alumni.caltech.edu>
+Date: Wed, 30 Mar 2022 11:14:53 -0700
+Subject: [PATCH] Correct incorrect inputs provided to the CRC functions.
+
+The previous releases of zlib were not sensitive to incorrect CRC
+inputs with bits set above the low 32. This commit restores that
+behavior, so that applications with such bugs will continue to
+operate as before.
+---
+ crc32.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/crc32.c b/crc32.c
+index a1bdce5c2..451887bc7 100644
+--- a/crc32.c
++++ b/crc32.c
+@@ -630,7 +630,7 @@ unsigned long ZEXPORT crc32_z(crc, buf, len)
+ #endif /* DYNAMIC_CRC_TABLE */
+
+ /* Pre-condition the CRC */
+- crc ^= 0xffffffff;
++ crc = (~crc) & 0xffffffff;
+
+ /* Compute the CRC up to a word boundary. */
+ while (len && ((z_size_t)buf & 7) != 0) {
+@@ -749,7 +749,7 @@ unsigned long ZEXPORT crc32_z(crc, buf, len)
+ #endif /* DYNAMIC_CRC_TABLE */
+
+ /* Pre-condition the CRC */
+- crc ^= 0xffffffff;
++ crc = (~crc) & 0xffffffff;
+
+ #ifdef W
+
+@@ -1077,7 +1077,7 @@ uLong ZEXPORT crc32_combine64(crc1, crc2, len2)
+ #ifdef DYNAMIC_CRC_TABLE
+ once(&made, make_crc_table);
+ #endif /* DYNAMIC_CRC_TABLE */
+- return multmodp(x2nmodp(len2, 3), crc1) ^ crc2;
++ return multmodp(x2nmodp(len2, 3), crc1) ^ (crc2 & 0xffffffff);
+ }
+
+ /* ========================================================================= */
+@@ -1112,5 +1112,5 @@ uLong crc32_combine_op(crc1, crc2, op)
+ uLong crc2;
+ uLong op;
+ {
+- return multmodp(op, crc1) ^ crc2;
++ return multmodp(op, crc1) ^ (crc2 & 0xffffffff);
+ }