summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-10-06 22:11:14 -0500
committerMax Rees <maxcrees@me.com>2019-10-14 17:06:06 -0500
commit2ed860677ddbfd8d4e3b5fd5e3e0213f33905992 (patch)
tree626fc2d5218b9a5bceea50e11da1f9697300b31a /system
parent7d9dfcf37dda8942fd1a84e42f13f351239b0712 (diff)
downloadpackages-2ed860677ddbfd8d4e3b5fd5e3e0213f33905992.tar.gz
packages-2ed860677ddbfd8d4e3b5fd5e3e0213f33905992.tar.bz2
packages-2ed860677ddbfd8d4e3b5fd5e3e0213f33905992.tar.xz
packages-2ed860677ddbfd8d4e3b5fd5e3e0213f33905992.zip
system/python3: patch CVE-2019-16935, run test_threading separately
Diffstat (limited to 'system')
-rw-r--r--system/python3/APKBUILD17
-rw-r--r--system/python3/CVE-2019-16935.patch80
2 files changed, 91 insertions, 6 deletions
diff --git a/system/python3/APKBUILD b/system/python3/APKBUILD
index 4fefa4e22..f5d28b236 100644
--- a/system/python3/APKBUILD
+++ b/system/python3/APKBUILD
@@ -3,7 +3,7 @@
pkgname=python3
pkgver=3.6.9
_basever="${pkgver%.*}"
-pkgrel=1
+pkgrel=2
pkgdesc="A high-level scripting language"
url="https://www.python.org"
arch="all"
@@ -41,6 +41,7 @@ source="https://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz
musl-find_library.patch
fix-xattrs-glibc.patch
CVE-2019-16056.patch
+ CVE-2019-16935.patch
"
builddir="$srcdir/Python-$pkgver"
@@ -60,6 +61,8 @@ builddir="$srcdir/Python-$pkgver"
# - CVE-2019-9948
# 3.6.9-r1:
# - CVE-2019-16056
+# 3.6.9-r2:
+# - CVE-2019-16935
prepare() {
default_prepare
@@ -139,13 +142,14 @@ EOF
# dumb
fail="$fail test_ssl" # tries to do SSLv2 which we have disabled in OpenSSL
- # needs network but doesn't declare it
- fail="$fail test_normalization"
+ # hangs when run with other tests - run separately
+ fail="$fail test_threading"
- # defaults from Tools/scripts/run_tests.py, with -network added
- use="all,-largefile,-audio,-gui,-network"
+ # defaults from Tools/scripts/run_tests.py + -network,-urlfetch
+ use="all,-largefile,-audio,-gui,-network,-urlfetch"
make quicktest TESTOPTS="--use '$use' --exclude $fail"
+ make test TESTOPTS="test_threading"
}
package() {
@@ -188,4 +192,5 @@ wininst() {
sha512sums="05de9c6f44d96a52bfce10ede4312de892573edaf8bece65926d19973a3a800d65eed7a857af945f69efcfb25efa3788e7a54016b03d80b611eb51c3ea074819 Python-3.6.9.tar.xz
ab8eaa2858d5109049b1f9f553198d40e0ef8d78211ad6455f7b491af525bffb16738fed60fc84e960c4889568d25753b9e4a1494834fea48291b33f07000ec2 musl-find_library.patch
37b6ee5d0d5de43799316aa111423ba5a666c17dc7f81b04c330f59c1d1565540eac4c585abe2199bbed52ebe7426001edb1c53bd0a17486a2a8e052d0f494ad fix-xattrs-glibc.patch
-1f1eb61355eb7832bef8e9c3915895cc3b2966a30c809371430b4416260452cd39c48ba593b2259574867bd1e8fea98efbc45c4b0bd95aeb0690c8514b380ea0 CVE-2019-16056.patch"
+1f1eb61355eb7832bef8e9c3915895cc3b2966a30c809371430b4416260452cd39c48ba593b2259574867bd1e8fea98efbc45c4b0bd95aeb0690c8514b380ea0 CVE-2019-16056.patch
+7f94d887c81f79d90afd4a9621547c13cbdd0232250f62a686b26a63160a4d286a6db9b342d06b9b63af64f994835b489c37bab499a2093c3c2585dc7a04d8a1 CVE-2019-16935.patch"
diff --git a/system/python3/CVE-2019-16935.patch b/system/python3/CVE-2019-16935.patch
new file mode 100644
index 000000000..567eb90fc
--- /dev/null
+++ b/system/python3/CVE-2019-16935.patch
@@ -0,0 +1,80 @@
+From 1698cacfb924d1df452e78d11a4bf81ae7777389 Mon Sep 17 00:00:00 2001
+From: Victor Stinner <vstinner@redhat.com>
+Date: Sat, 28 Sep 2019 09:33:00 +0200
+Subject: [PATCH] bpo-38243, xmlrpc.server: Escape the server_title (GH-16373)
+ (GH-16441)
+
+Escape the server title of xmlrpc.server.DocXMLRPCServer
+when rendering the document page as HTML.
+
+(cherry picked from commit e8650a4f8c7fb76f570d4ca9c1fbe44e91c8dfaa)
+---
+ Lib/test/test_docxmlrpc.py | 16 ++++++++++++++++
+ Lib/xmlrpc/server.py | 3 ++-
+ .../2019-09-25-13-21-09.bpo-38243.1pfz24.rst | 3 +++
+ 3 files changed, 21 insertions(+), 1 deletion(-)
+ create mode 100644 Misc/NEWS.d/next/Security/2019-09-25-13-21-09.bpo-38243.1pfz24.rst
+
+diff --git a/Lib/test/test_docxmlrpc.py b/Lib/test/test_docxmlrpc.py
+index 00903337c07c2..d2adb21af0fb3 100644
+--- a/Lib/test/test_docxmlrpc.py
++++ b/Lib/test/test_docxmlrpc.py
+@@ -1,5 +1,6 @@
+ from xmlrpc.server import DocXMLRPCServer
+ import http.client
++import re
+ import sys
+ from test import support
+ threading = support.import_module('threading')
+@@ -193,6 +194,21 @@ def test_annotations(self):
+ b'method_annotation</strong></a>(x: bytes)</dt></dl>'),
+ response.read())
+
++ def test_server_title_escape(self):
++ # bpo-38243: Ensure that the server title and documentation
++ # are escaped for HTML.
++ self.serv.set_server_title('test_title<script>')
++ self.serv.set_server_documentation('test_documentation<script>')
++ self.assertEqual('test_title<script>', self.serv.server_title)
++ self.assertEqual('test_documentation<script>',
++ self.serv.server_documentation)
++
++ generated = self.serv.generate_html_documentation()
++ title = re.search(r'<title>(.+?)</title>', generated).group()
++ documentation = re.search(r'<p><tt>(.+?)</tt></p>', generated).group()
++ self.assertEqual('<title>Python: test_title&lt;script&gt;</title>', title)
++ self.assertEqual('<p><tt>test_documentation&lt;script&gt;</tt></p>', documentation)
++
+
+ if __name__ == '__main__':
+ unittest.main()
+diff --git a/Lib/xmlrpc/server.py b/Lib/xmlrpc/server.py
+index 3e0dca027f068..efe593748968c 100644
+--- a/Lib/xmlrpc/server.py
++++ b/Lib/xmlrpc/server.py
+@@ -106,6 +106,7 @@ def export_add(self, x, y):
+
+ from xmlrpc.client import Fault, dumps, loads, gzip_encode, gzip_decode
+ from http.server import BaseHTTPRequestHandler
++import html
+ import http.server
+ import socketserver
+ import sys
+@@ -904,7 +905,7 @@ def generate_html_documentation(self):
+ methods
+ )
+
+- return documenter.page(self.server_title, documentation)
++ return documenter.page(html.escape(self.server_title), documentation)
+
+ class DocXMLRPCRequestHandler(SimpleXMLRPCRequestHandler):
+ """XML-RPC and documentation request handler class.
+diff --git a/Misc/NEWS.d/next/Security/2019-09-25-13-21-09.bpo-38243.1pfz24.rst b/Misc/NEWS.d/next/Security/2019-09-25-13-21-09.bpo-38243.1pfz24.rst
+new file mode 100644
+index 0000000000000..98d7be129573a
+--- /dev/null
++++ b/Misc/NEWS.d/next/Security/2019-09-25-13-21-09.bpo-38243.1pfz24.rst
+@@ -0,0 +1,3 @@
++Escape the server title of :class:`xmlrpc.server.DocXMLRPCServer`
++when rendering the document page as HTML.
++(Contributed by Dong-hee Na in :issue:`38243`.)