summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-03-02 17:26:03 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-03-02 17:26:03 -0600
commit1974ff8514a7e7ecd8c29918ed4c2a8ab28c6ead (patch)
tree86ee268ba7e8b7cb518c4f93c6e4200981342f78 /system
parentf173c49b01d34b7278a1056d47e67819c559d86f (diff)
downloadpackages-1974ff8514a7e7ecd8c29918ed4c2a8ab28c6ead.tar.gz
packages-1974ff8514a7e7ecd8c29918ed4c2a8ab28c6ead.tar.bz2
packages-1974ff8514a7e7ecd8c29918ed4c2a8ab28c6ead.tar.xz
packages-1974ff8514a7e7ecd8c29918ed4c2a8ab28c6ead.zip
system/abuild: actually push correct patch this time
Diffstat (limited to 'system')
-rw-r--r--system/abuild/APKBUILD1
-rw-r--r--system/abuild/adelie-customisations.patch12
2 files changed, 3 insertions, 10 deletions
diff --git a/system/abuild/APKBUILD b/system/abuild/APKBUILD
index 6eb1adcda..8dd1c12b6 100644
--- a/system/abuild/APKBUILD
+++ b/system/abuild/APKBUILD
@@ -74,4 +74,5 @@ _rootbld() {
sha512sums="bb9093d67942e3a63e4e053692c0bca30940cae05955518206cd9f7029211a188b7f442456ae126e61cbdca224eddb31e967d5cf0637e16893163cc963871a52 abuild-3.1.0.tar.xz
86194084e95cdb42d4b1bc3d4ff2b8144125aa4e7f74f8c97023c55f2304d27d8c377baf5075666c9b43323506357b962d83d4a30a3f41cde7b53542889adf2d posix-abuild.patch
705c393b37c37a364473590190122a43a2962946290a873e6685cd4eb43c4874bfdf7489e7b655f870b332dee38edca5dcf2d3906461001875a55b9e6549b824 newapkbuild-cmake.patch
+e27f29b94fe55fe59ab9dc28986cd1755a41221ad6b4457c7c0b268e561f7c6946ea6fcb8b7ace897acfde2e4660ec7150ef43fb0c71c6c20dfd38aa1d062140 adelie-customisations.patch
e02cc44c8ad9dd61c9b80684b8cf5b64477a6fd6221cde9efea2a7594c6e7ce01a51f8bd4b80d72f82f7caf93217979fb0b354c420983891fa93f34c4252a035 0001-abuild-add-env-option-to-require-tests.patch"
diff --git a/system/abuild/adelie-customisations.patch b/system/abuild/adelie-customisations.patch
index 178b2538c..db7280abc 100644
--- a/system/abuild/adelie-customisations.patch
+++ b/system/abuild/adelie-customisations.patch
@@ -2,7 +2,7 @@ diff --git a/functions.sh.in b/functions.sh.in
index 4f2c023..a4de25c 100644
--- a/functions.sh.in
+++ b/functions.sh.in
-@@ -5,20 +5,20 @@ program=${0##*/}
+@@ -5,16 +5,20 @@ program=${0##*/}
arch_to_hostspec() {
case "$1" in
@@ -10,10 +10,6 @@ index 4f2c023..a4de25c 100644
- armel) echo "armv5-alpine-linux-musleabi" ;;
- armhf) echo "armv6-alpine-linux-muslgnueabihf" ;;
- armv7) echo "armv7-alpine-linux-musleabihf" ;;
-- mips) echo "mips-alpine-linux-musl" ;;
-- mips64) echo "mips64-alpine-linux-musl" ;;
-- mipsel) echo "mipsel-alpine-linux-musl" ;;
-- mips64el) echo "mips64el-alpine-linux-musl" ;;
- ppc) echo "powerpc-alpine-linux-musl" ;;
- ppc64) echo "powerpc64-alpine-linux-musl" ;;
- ppc64le) echo "powerpc64le-alpine-linux-musl" ;;
@@ -37,15 +33,11 @@ index 4f2c023..a4de25c 100644
*) echo "unknown" ;;
esac
}
-@@ -29,11 +29,11 @@ hostspec_to_arch() {
+@@ -25,7 +29,11 @@ hostspec_to_arch() {
arm*-*-*-*eabi) echo "armel" ;;
armv6*-*-*-*eabihf) echo "armhf" ;;
armv7*-*-*-*eabihf) echo "armv7" ;;
- i[0-9]86-*-*-*) echo "x86" ;;
-- mips-*-*-*) echo "mips" ;;
-- mips64-*-*-*) echo "mips64" ;;
-- mipsel-*-*-*) echo "mipsel" ;;
-- mips64el-*-*-*) echo "mips64el" ;;
+ i486-*-*-*) echo "x86" ;;
+ i586-*-*-*) echo "pmmx" ;;
+ mips32*-*-*-*) echo "mips32" ;;