summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-23 17:47:14 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-23 17:47:40 -0500
commit5e8af11be96eeb359aaa93607233f6b9c475b213 (patch)
tree60bf9eb58c10c48f3576dc25d1aeadb3b52c67b7 /system
parentcd914cda236483a3818031d3122ae75e71f311e9 (diff)
downloadpackages-5e8af11be96eeb359aaa93607233f6b9c475b213.tar.gz
packages-5e8af11be96eeb359aaa93607233f6b9c475b213.tar.bz2
packages-5e8af11be96eeb359aaa93607233f6b9c475b213.tar.xz
packages-5e8af11be96eeb359aaa93607233f6b9c475b213.zip
system/gcc: actually remove ustat properly
Diffstat (limited to 'system')
-rw-r--r--system/gcc/332-gccgo-remove-ustat.patch73
-rw-r--r--system/gcc/APKBUILD2
2 files changed, 57 insertions, 18 deletions
diff --git a/system/gcc/332-gccgo-remove-ustat.patch b/system/gcc/332-gccgo-remove-ustat.patch
index 95b3cb1d2..90aa65ad7 100644
--- a/system/gcc/332-gccgo-remove-ustat.patch
+++ b/system/gcc/332-gccgo-remove-ustat.patch
@@ -108,24 +108,6 @@ index 3cee2c0f..1c192752 100644
AM_CONDITIONAL(HAVE_SYS_MMAN_H, test "$ac_cv_header_sys_mman_h" = yes)
AC_CHECK_FUNCS(strerror_r strsignal wait4 mincore setenv unsetenv dl_iterate_phdr)
-diff --git a/libgo/go/syscall/libcall_linux_ustat.go b/libgo/go/syscall/libcall_linux_ustat.go
-deleted file mode 100644
-index f515fce3..00000000
---- a/libgo/go/syscall/libcall_linux_ustat.go
-+++ /dev/null
-@@ -1,12 +0,0 @@
--// Copyright 2015 The Go Authors. All rights reserved.
--// Use of this source code is governed by a BSD-style
--// license that can be found in the LICENSE file.
--
--// GNU/Linux library ustat call.
--// This is not supported on some kernels, such as arm64.
--// +build !arm64,!nios2,!riscv64
--
--package syscall
--
--//sys Ustat(dev int, ubuf *Ustat_t) (err error)
--//ustat(dev _dev_t, ubuf *Ustat_t) _C_int
diff --git a/libgo/mksysinfo.sh b/libgo/mksysinfo.sh
index 92ecb479..48bc71db 100755
--- a/libgo/mksysinfo.sh
@@ -151,3 +133,58 @@ index 92ecb479..48bc71db 100755
# The utimbuf struct.
grep '^type _utimbuf ' gen-sysinfo.go | \
sed -e 's/_utimbuf/Utimbuf/' \
+--- gcc-6.4.0/libgo/Makefile.am.old 2016-02-03 15:58:02.419872000 -0600
++++ gcc-6.4.0/libgo/Makefile.am 2018-06-23 02:55:45.772611885 -0500
+@@ -1,4 +1,3 @@
+-# Makefile.am -- Go library Makefile.
+
+ # Copyright 2009 The Go Authors. All rights reserved.
+ # Use of this source code is governed by a BSD-style
+@@ -1989,17 +1988,6 @@
+ syscall_lsf_file =
+ endif
+
+-# GNU/Linux specific ustat support.
+-if LIBGO_IS_LINUX
+-if LIBGO_IS_ARM64
+-syscall_ustat_file =
+-else
+-syscall_ustat_file = go/syscall/libcall_linux_ustat.go
+-endif
+-else
+-syscall_ustat_file =
+-endif
+-
+ # GNU/Linux specific utimesnano support.
+ if LIBGO_IS_LINUX
+ syscall_utimesnano_file = go/syscall/libcall_linux_utimesnano.go
+@@ -2051,7 +2039,6 @@
+ $(syscall_uname_file) \
+ $(syscall_netlink_file) \
+ $(syscall_lsf_file) \
+- $(syscall_ustat_file) \
+ $(syscall_utimesnano_file) \
+ $(GO_LIBCALL_OS_FILE) \
+ $(GO_LIBCALL_OS_ARCH_FILE) \
+--- gcc-6.4.0/libgo/Makefile.in.old 2016-02-03 15:58:02.419872000 -0600
++++ gcc-6.4.0/libgo/Makefile.in 2018-06-23 02:56:04.842611681 -0500
+@@ -2080,11 +2080,6 @@
+
+ # GNU/Linux specific socket filters.
+ @LIBGO_IS_LINUX_TRUE@syscall_lsf_file = go/syscall/lsf_linux.go
+-@LIBGO_IS_ARM64_FALSE@@LIBGO_IS_LINUX_TRUE@syscall_ustat_file = go/syscall/libcall_linux_ustat.go
+-
+-# GNU/Linux specific ustat support.
+-@LIBGO_IS_ARM64_TRUE@@LIBGO_IS_LINUX_TRUE@syscall_ustat_file =
+-@LIBGO_IS_LINUX_FALSE@syscall_ustat_file =
+ @LIBGO_IS_LINUX_FALSE@syscall_utimesnano_file = go/syscall/libcall_posix_utimesnano.go
+
+ # GNU/Linux specific utimesnano support.
+@@ -2122,7 +2117,6 @@
+ $(syscall_uname_file) \
+ $(syscall_netlink_file) \
+ $(syscall_lsf_file) \
+- $(syscall_ustat_file) \
+ $(syscall_utimesnano_file) \
+ $(GO_LIBCALL_OS_FILE) \
+ $(GO_LIBCALL_OS_ARCH_FILE) \
diff --git a/system/gcc/APKBUILD b/system/gcc/APKBUILD
index aebf3b666..e1c1957c1 100644
--- a/system/gcc/APKBUILD
+++ b/system/gcc/APKBUILD
@@ -223,6 +223,7 @@ prepare() {
echo ${pkgver} > gcc/BASE-VER
echo "UNSUPPORTED=1" > libcilkrts/configure.tgt
+ rm libgo/go/syscall/libcall_linux_ustat.go
}
build() {
@@ -656,6 +657,7 @@ fa44c8158111627aa0e91c43e7cc3aa38642c2041c96532dd4f0932dae4d6f92ea2850b683abcf10
f4ef08454e28c8732db69115e4998ec153399e8d229dd27f923dbdcf57b68128a65640d026cc7f45b58ba8764ab1eb575d4eb6d6dfc550a87a183f8b94e76181 320-libffi-gnulinux.patch
8efd028febb962ae100be32f72f7450c4f77d67ad96a5f47072136cdf47043f9d54835a87c7ab5aaa0fa0108c4c7a97ba2d7732d5aaf2efce70fe1f7e1c39d6e 330-gccgo-link-to-ucontext.patch
24c8708f64b9b7945b3f07e9bbecf17ab8bcde2524f49cbd694ca2f6146ccc3f13bb027db282f326525ea79d50a2868fa3fa2b0d688a914b5ea77bbfd7e5cbe4 331-gccgo-use-real-off_t-type.patch
+cf19fcc6abee70210a9061e5385fe361a5eb59a74f7d34297420a53e351400da23a060164bef5b322daba4be90019481731acf93c45fb5a93430018f1aa7ce35 332-gccgo-remove-ustat.patch
01c71cd5881fc07ea3b9b980697e89b3ca0fe98502958ceafc3fca18b2604c844e2f457feab711baf8e03f00a5383b0e38aac7eb954034e306f43d4a37f165ed fix-rs6000-pie.patch
1860593584f629d24d5b6db14b0a3412e9f93449b663aaa4981301a0923db0159314905e694f27366fbfef72dce06636ab6df86862b7e9e9564847e03bee82c1 add-classic_table-support.patch
4e1b421ed72668b66ecbcb0a34afa99d2a34cb2ea9ee51c4aad605fc8a0e94e3bfbabae4ebe236efc5ec86fc01a472cbe93f36fe25cf579714939d8102a9b84a lra-pentium.patch"