summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-04-12 21:52:58 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-04-12 21:52:58 -0500
commit8520e5d42ea95a71d7a67c142d7a1abc76c2a98d (patch)
tree55449257cb07025937bbc9196a93fd7b68a4cdad /system
parentbf6b2138ddbfc2d030bc5c76ecf6d0b91e6091d9 (diff)
downloadpackages-8520e5d42ea95a71d7a67c142d7a1abc76c2a98d.tar.gz
packages-8520e5d42ea95a71d7a67c142d7a1abc76c2a98d.tar.bz2
packages-8520e5d42ea95a71d7a67c142d7a1abc76c2a98d.tar.xz
packages-8520e5d42ea95a71d7a67c142d7a1abc76c2a98d.zip
system/syslinux: bump pkgrel, modernise, fix checksum
Diffstat (limited to 'system')
-rw-r--r--system/syslinux/APKBUILD19
1 files changed, 5 insertions, 14 deletions
diff --git a/system/syslinux/APKBUILD b/system/syslinux/APKBUILD
index 25e7cb252..43ac057b1 100644
--- a/system/syslinux/APKBUILD
+++ b/system/syslinux/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=syslinux
pkgver=6.04_pre1
-pkgrel=2
+pkgrel=3
_ver=${pkgver/_/-}
pkgdesc="Boot loader for the Linux operating system"
url="http://syslinux.org"
-arch="x86 x86_64"
+arch="pmmx x86 x86_64"
license="GPL"
makedepends="linux-headers nasm perl util-linux-dev gnu-efi-dev"
depends="mtools blkid mawk"
@@ -27,26 +27,17 @@ x86_64) _loaderarch=efi64;;
esac
builddir="$srcdir"/$pkgname-$_ver
-prepare() {
- cd "$builddir"
- for i in $source; do
- i=${i%%::*}
- case "$i" in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
build() {
cd "$builddir"
unset LDFLAGS
- make $_loaderarch installer || return 1
+ make $_loaderarch installer
}
package() {
cd "$builddir"
make -j1 INSTALLROOT="$pkgdir" MANDIR=/usr/share/man \
- bios $_loaderarch install || return 1
+ bios $_loaderarch install
mkdir -p "$pkgdir"/etc/update-extlinux.d
cp "$srcdir"/update-extlinux.conf "$pkgdir"/etc/
@@ -57,4 +48,4 @@ package() {
sha512sums="7927dd39be8e2dcf4138a6fea33def67d19d938379d694f15b48fdd2f5924c028b7a9e7bd71d0c7c6630c203e9e2a54296628e530632ad5e6f55b1ebefe8fc98 syslinux-6.04-pre1.tar.xz
9071be450e543597f6f95b9a5811869c5351a71f4c42f7879b9f7ec1b13e2e4d455e9f2900e3897d5e5870bd87c934b7168328186c5f17631f2b09a524e10a1a update-extlinux.conf
-23fd69b5f42af063744289f64e60eddd0fa35db83d988b24635e6eb47b5c8fada8585c9aea60f398cfc1e5be8565230a81192d71df705368a90e0927f35fb60d update-extlinux"
+8f4f003053a3a265a11522b5bd6c71998ae3bf7ef1fbc2ed51675e432485ba4453f707b1bc1a1ed2089cf226456a56e7742b197b45b015099820b7fed5c2f153 update-extlinux"