summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-05-04 03:36:35 +0000
committerZach van Rijn <me@zv.io>2022-05-06 12:37:31 -0500
commitb1ce3eefa7f462f4f4b7bf7465fa41dd486061c0 (patch)
treea6f609aa466d2447703e6e338c9b7516a9cdeae7 /system
parent5b9db64207cfdcc0e31b63b55eca088f0453390b (diff)
downloadpackages-b1ce3eefa7f462f4f4b7bf7465fa41dd486061c0.tar.gz
packages-b1ce3eefa7f462f4f4b7bf7465fa41dd486061c0.tar.bz2
packages-b1ce3eefa7f462f4f4b7bf7465fa41dd486061c0.tar.xz
packages-b1ce3eefa7f462f4f4b7bf7465fa41dd486061c0.zip
system/libuv: bump { 1.28.0 --> 1.44.1 }. fixes #655.
Diffstat (limited to 'system')
-rw-r--r--system/libuv/APKBUILD11
-rw-r--r--system/libuv/disable-process-priority.patch22
-rw-r--r--system/libuv/disable-setuid-test.patch46
3 files changed, 3 insertions, 76 deletions
diff --git a/system/libuv/APKBUILD b/system/libuv/APKBUILD
index ef071f093..be514a5a4 100644
--- a/system/libuv/APKBUILD
+++ b/system/libuv/APKBUILD
@@ -2,7 +2,7 @@
# Conttributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libuv
-pkgver=1.28.0
+pkgver=1.44.1
pkgrel=0
pkgdesc="Cross-platform asychronous I/O"
url="https://libuv.org"
@@ -10,10 +10,7 @@ arch="all"
license="MIT AND BSD-2-Clause AND BSD-3-Clause AND ISC"
makedepends="automake autoconf libtool linux-headers"
subpackages="$pkgname-dev"
-source="https://dist.libuv.org/dist/v$pkgver/$pkgname-v$pkgver.tar.gz
- disable-process-priority.patch
- disable-setuid-test.patch
- "
+source="https://dist.libuv.org/dist/v$pkgver/$pkgname-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
prepare() {
@@ -42,6 +39,4 @@ package() {
"$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-sha512sums="d7f635ab99569e96db9ae97d29a302f5eec1fd75c71b035ec597a6b978a3fc797a37c7406fed81a27d4d706fe21cbfe919d829d6dae67399cd5cddd107ad6949 libuv-v1.28.0.tar.gz
-58bc259a0f703fa6b8dda14909f718e14dfb9ddc9039ae13378f7e32e0ff7096774cbfb2964a0abb06f8a64a71cf298cc77b7475927df0fb50ce3f0e414a7787 disable-process-priority.patch
-478d25c8905cd393b9ced0f1b16e70794a7ef20fb9eb212fd74e50beca3f5a33a6a5267616abecf470426ed3d00efec51df468745ff43c0de05c0ad8234f1eb3 disable-setuid-test.patch"
+sha512sums="b4f8944e2c79e3a6a31ded6cccbe4c0eeada50db6bc8a448d7015642795012a4b80ffeef7ca455bb093c59a8950d0e1430566c3c2fa87b73f82699098162d834 libuv-v1.44.1.tar.gz"
diff --git a/system/libuv/disable-process-priority.patch b/system/libuv/disable-process-priority.patch
deleted file mode 100644
index f0f41fc95..000000000
--- a/system/libuv/disable-process-priority.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- libuv-v1.23.0/test/test-list.h.old 2018-08-17 02:05:34.000000000 +0000
-+++ libuv-v1.23.0/test/test-list.h 2018-09-05 19:06:26.360000000 +0000
-@@ -214,7 +214,9 @@
- TEST_DECLARE (pipe_set_non_blocking)
- TEST_DECLARE (pipe_set_chmod)
- TEST_DECLARE (process_ref)
-+#if 0
- TEST_DECLARE (process_priority)
-+#endif
- TEST_DECLARE (has_ref)
- TEST_DECLARE (active)
- TEST_DECLARE (embed)
-@@ -690,7 +692,9 @@
- TEST_ENTRY (pipe_ref4)
- TEST_HELPER (pipe_ref4, pipe_echo_server)
- TEST_ENTRY (process_ref)
-+#if 0
- TEST_ENTRY (process_priority)
-+#endif
- TEST_ENTRY (has_ref)
-
- TEST_ENTRY (loop_handles)
diff --git a/system/libuv/disable-setuid-test.patch b/system/libuv/disable-setuid-test.patch
deleted file mode 100644
index 3c6e01611..000000000
--- a/system/libuv/disable-setuid-test.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff --git a/test/test-list.h b/test/test-list.h
-index 3a1e82a..dd25e69 100644
---- a/test/test-list.h
-+++ b/test/test-list.h
-@@ -240,8 +240,10 @@ TEST_DECLARE (spawn_detached)
- TEST_DECLARE (spawn_and_kill_with_std)
- TEST_DECLARE (spawn_and_ping)
- TEST_DECLARE (spawn_preserve_env)
-+#if 0
- TEST_DECLARE (spawn_setuid_fails)
- TEST_DECLARE (spawn_setgid_fails)
-+#endif
- TEST_DECLARE (spawn_stdout_to_file)
- TEST_DECLARE (spawn_stdout_and_stderr_to_file)
- TEST_DECLARE (spawn_stdout_and_stderr_to_file2)
-@@ -351,7 +353,9 @@ TEST_DECLARE (win32_signum_number)
- TEST_DECLARE (emfile)
- TEST_DECLARE (close_fd)
- TEST_DECLARE (spawn_fs_open)
-+#if 0
- TEST_DECLARE (spawn_setuid_setgid)
-+#endif
- TEST_DECLARE (we_get_signal)
- TEST_DECLARE (we_get_signals)
- TEST_DECLARE (signal_multiple_loops)
-@@ -669,8 +673,10 @@ TASK_LIST_START
- TEST_ENTRY (spawn_and_kill_with_std)
- TEST_ENTRY (spawn_and_ping)
- TEST_ENTRY (spawn_preserve_env)
-+#if 0
- TEST_ENTRY (spawn_setuid_fails)
- TEST_ENTRY (spawn_setgid_fails)
-+#endif
- TEST_ENTRY (spawn_stdout_to_file)
- TEST_ENTRY (spawn_stdout_and_stderr_to_file)
- TEST_ENTRY (spawn_stdout_and_stderr_to_file2)
-@@ -701,7 +707,9 @@ TASK_LIST_START
- TEST_ENTRY (emfile)
- TEST_ENTRY (close_fd)
- TEST_ENTRY (spawn_fs_open)
-+#if 0
- TEST_ENTRY (spawn_setuid_setgid)
-+#endif
- TEST_ENTRY (we_get_signal)
- TEST_ENTRY (we_get_signals)
- TEST_ENTRY (signal_multiple_loops)