summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-07-10 17:52:00 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-07-10 17:52:00 -0500
commit3755330e649f458fceb44ba3213b4b1323909522 (patch)
tree35cd9ab10009c3ca2f4ea212b767c79298333e49 /system
parent183a5143c394ff6f3d25bf7ad95cd7daf549b1b3 (diff)
downloadpackages-awilfox/gcc-next.tar.gz
packages-awilfox/gcc-next.tar.bz2
packages-awilfox/gcc-next.tar.xz
packages-awilfox/gcc-next.zip
system/binutils: Add upstream fix for x86_64 testsawilfox/gcc-next
Closes: #1222
Diffstat (limited to 'system')
-rw-r--r--system/binutils/APKBUILD2
-rw-r--r--system/binutils/x86_64-mark-plt.patch37
2 files changed, 39 insertions, 0 deletions
diff --git a/system/binutils/APKBUILD b/system/binutils/APKBUILD
index 1eb4617b3..06f7c4cb6 100644
--- a/system/binutils/APKBUILD
+++ b/system/binutils/APKBUILD
@@ -30,6 +30,7 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
remove-pr19553c-test.patch
visibility-musl.patch
vsb-hammer.patch
+ x86_64-mark-plt.patch
x86_64-missing-test.patch
BTS-170.patch
BTS-196.patch
@@ -159,6 +160,7 @@ b4bd7b5d2ad3705c7db0924c73bd91d5f8ef07e73f146c250af7d794387ab219b02254b1b61060a5
06f9df891a4ae0e9f6f8b3282d3691ede7cc0f08d63bf722f942f3c94dd4d7f3907b7bb5a8087e63639569e61aed6c39b5f5da7ad6566e7ef278524aa32ada63 remove-pr19553c-test.patch
075565f9bc85c0fc4bd36c7a848f6b876b71fbbe0f572b5c21961687ab4e2cd00c784fba09fe92b214c4b1df871ebd6409e6c93dde5a0a6c1ef6e41a30b24520 visibility-musl.patch
55bdb08f93563449b170ba8623cd7d4409c8f22abb15fca23bc87f23cc43cd580fa149e68271e65fdf2c29ddb0a15cd78d6f0de1a50332fdc026ea1b7d0ec7b8 vsb-hammer.patch
+fcd71dc0e664bce0d1066b6adec9b8eebb85eb589061ad7e88934dbda4d5f8849ff6db97299a8026840515e44a73de5e131e3209052be45e807706e79ef8a045 x86_64-mark-plt.patch
f524acb49e7ce14133a11b237858aaadc84f4c3290b6e59335ec293fc6cc0e65c9bdd47c2b68bf75bb3a39ebe2e61df4f7bf941acec69d79968aa68915ade4d5 x86_64-missing-test.patch
c62365110dd0a550e55f1445b197f1f968849b1079439cda0d44778772964779b4ab1142ccc662ba75ebb040e09ef4b4bfc253f4632db24ed783155be2f5f3b1 BTS-170.patch
ab7d0c1fa74862bf9364d5e2228200054a2c5c4351c979dc7a9850f630d74034edffba740b468e009c5419a3cec110322364303f8af28dcdbfbe672c3c16f450 BTS-196.patch
diff --git a/system/binutils/x86_64-mark-plt.patch b/system/binutils/x86_64-mark-plt.patch
new file mode 100644
index 000000000..29e1bd3bc
--- /dev/null
+++ b/system/binutils/x86_64-mark-plt.patch
@@ -0,0 +1,37 @@
+From 6ef47613129c9251a5b8d5fa15ce6ea3ebe81ec1 Mon Sep 17 00:00:00 2001
+From: "H.J. Lu" <hjl.tools@gmail.com>
+Date: Wed, 10 Jul 2024 15:19:23 -0700
+Subject: [PATCH] x86-64: Skip -z mark-plt tests on MUSL
+
+Skip -z mark-plt tests, which are specific to glibc, on MUSL.
+
+ PR ld/31970
+ * ld/testsuite/ld-x86-64/x86-64.exp: Skip -z mark-plt tests on
+ MUSL.
+
+Signed-off-by: H.J. Lu <hjl.tools@gmail.com>
+---
+ ld/testsuite/ld-x86-64/x86-64.exp | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/ld/testsuite/ld-x86-64/x86-64.exp b/ld/testsuite/ld-x86-64/x86-64.exp
+index dddac4375e1..57a1cc44e2c 100644
+--- a/ld/testsuite/ld-x86-64/x86-64.exp
++++ b/ld/testsuite/ld-x86-64/x86-64.exp
+@@ -2274,6 +2274,13 @@ run_dump_test "ibt-plt-3a-x32"
+ run_dump_test "ibt-plt-3b-x32"
+ run_dump_test "ibt-plt-3c-x32"
+ run_dump_test "ibt-plt-3d-x32"
++
++# Skip -z mark-plt tests on MUSL.
++if { [istarget "x86_64-*-musl*"]} {
++ set ASFLAGS "$saved_ASFLAGS"
++ return
++}
++
+ run_dump_test "mark-plt-1a"
+ run_dump_test "mark-plt-1b"
+ run_dump_test "mark-plt-1c"
+--
+2.45.2
+