summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-10-04 17:54:03 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-10-04 17:54:03 +0000
commite21600c2762dffef8a31efad44cf9e172fdf6a72 (patch)
tree7824fd090bab27b1e8144b351ae682a05a154638 /system
parent72faf6a61ea307660f79d43519eadb952d853db5 (diff)
parentbadaa27d5febffd453f89d2f1a3bd3f5338bfef0 (diff)
downloadpackages-e21600c2762dffef8a31efad44cf9e172fdf6a72.tar.gz
packages-e21600c2762dffef8a31efad44cf9e172fdf6a72.tar.bz2
packages-e21600c2762dffef8a31efad44cf9e172fdf6a72.tar.xz
packages-e21600c2762dffef8a31efad44cf9e172fdf6a72.zip
Merge branch 'remove-paxmark' into 'master'
Move system/paxmark to legacy/ See merge request adelie/packages!335
Diffstat (limited to 'system')
-rw-r--r--system/paxmark/APKBUILD23
-rw-r--r--system/paxmark/paxmark33
-rw-r--r--system/pcre2/APKBUILD2
3 files changed, 1 insertions, 57 deletions
diff --git a/system/paxmark/APKBUILD b/system/paxmark/APKBUILD
deleted file mode 100644
index 3c9c69400..000000000
--- a/system/paxmark/APKBUILD
+++ /dev/null
@@ -1,23 +0,0 @@
-# Contributor: Timo Teräs <timo.teras@iki.fi>
-# Maintainer: A. Wilcox <awilfox@adelielinux.org>
-pkgname=paxmark
-pkgver=0.11
-pkgrel=1
-pkgdesc="Manage PaX marking of executables"
-url="https://alpinelinux.org"
-arch="noarch"
-options="!check"
-license="GPL-2.0-only"
-depends="attr bash"
-makedepends=""
-install=""
-subpackages=""
-source="paxmark"
-
-package() {
- mkdir -p "$pkgdir"/usr/sbin
- install -m755 "$srcdir"/paxmark "$pkgdir"/usr/sbin
- ln -s paxmark "$pkgdir"/usr/sbin/paxmark.sh
-}
-
-sha512sums="ed904790bfa6c86e216e2c8c1ed8fb1f997b7d1a55f997459655e402d8eec6447095709e38472cf909ea4d03e623e3e0eeddc0da57378901fe9d18d8c14b68d8 paxmark"
diff --git a/system/paxmark/paxmark b/system/paxmark/paxmark
deleted file mode 100644
index 87a84f4f7..000000000
--- a/system/paxmark/paxmark
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/bash
-
-ret=0
-flags="${1//[!zPpEeMmRrSs]}"
-[ -n "${flags}" ] || exit 0
-shift
-
-# Create XATTR_PAX marking using attr
-xval=""
-[ "${flags//[!P]}" ] && xval="${xval}P"
-[ "${flags//[!p]}" -a -z "${flags//[!P]}" ] && xval="${xval}p"
-[ "${flags//[!E]}" ] && xval="${xval}E"
-[ "${flags//[!e]}" -a -z "${flags//[!E]}" ] && xval="${xval}e"
-[ -z "${flags//[!zEe]}" ] && xval="${xval}e"
-[ "${flags//[!M]}" ] && xval="${xval}M"
-[ "${flags//[!m]}" -a -z "${flags//[!M]}" ] && xval="${xval}m"
-[ "${flags//[!R]}" ] && xval="${xval}R"
-[ "${flags//[!r]}" -a -z "${flags//[!R]}" ] && xval="${xval}r"
-[ "${flags//[!S]}" ] && xval="${xval}S"
-[ "${flags//[!s]}" -a -z "${flags//[!S]}" ] && xval="${xval}s"
-
-for f in "$@"; do
- if [ -n "FAKEROOTKEY" ]; then
- # fakeroot does not set xattr's on disk.
- # explicitly do that, because the marked binary might
- # be executed next during install.
- LD_PRELOAD="" FAKEROOTKEY="" attr -q -s pax.flags -V "${xval}" "${f}" >/dev/null || ret=1
- fi
- attr -q -s pax.flags -V "${xval}" "${f}" >/dev/null || ret=1
-done
-
-exit $ret
-
diff --git a/system/pcre2/APKBUILD b/system/pcre2/APKBUILD
index ef1fa1492..7bca0e450 100644
--- a/system/pcre2/APKBUILD
+++ b/system/pcre2/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
license="BSD-3-Clause"
depends=""
depends_dev="libedit-dev zlib-dev"
-makedepends="$depends_dev paxmark"
+makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools
libpcre2-16:_libpcre libpcre2-32:_libpcre"
source="https://ftp.pcre.org/pub/pcre/$pkgname-$pkgver.tar.gz"