summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-05-04 06:26:07 +0000
committerZach van Rijn <me@zv.io>2022-05-06 12:37:31 -0500
commit51c66111e099f7baf4000a8e1f124c36b5f915f0 (patch)
tree1080905dd48c148865a514dd9a14023b128e0d14 /system
parentffc9796da04c86c21664b5fa82df65052c5512b2 (diff)
downloadpackages-51c66111e099f7baf4000a8e1f124c36b5f915f0.tar.gz
packages-51c66111e099f7baf4000a8e1f124c36b5f915f0.tar.bz2
packages-51c66111e099f7baf4000a8e1f124c36b5f915f0.tar.xz
packages-51c66111e099f7baf4000a8e1f124c36b5f915f0.zip
system/pax-utils: bump { 1.2.4 --> 1.3.4 }.
Diffstat (limited to 'system')
-rw-r--r--system/pax-utils/APKBUILD20
-rw-r--r--system/pax-utils/fix-eitype.patch28
2 files changed, 10 insertions, 38 deletions
diff --git a/system/pax-utils/APKBUILD b/system/pax-utils/APKBUILD
index 86ad26f44..9d306faf2 100644
--- a/system/pax-utils/APKBUILD
+++ b/system/pax-utils/APKBUILD
@@ -1,19 +1,20 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer:
+# Maintainer: Zach van Rijn <me@zv.io>
pkgname=pax-utils
-pkgver=1.2.4
+pkgver=1.3.4
pkgrel=0
pkgdesc="ELF related utils for ELF 32/64 binaries"
url="https://wiki.gentoo.org/wiki/Hardened/PaX_Utilities"
arch="all"
-options="!check" # Requires unpackaged dependencies
+options="!check" # depends on nx package(s)
license="GPL-2.0-only"
depends="scanelf"
-makedepends_build=""
-makedepends_host="linux-headers libcap-dev"
-makedepends="$makedepends_build $makedepends_host"
-source="https://distfiles.adelielinux.org/source/upstream/pax-utils-$pkgver.tar.xz
- fix-eitype.patch"
+makedepends="linux-headers libcap-dev"
+# ATTENTION MAINTAINERS: Generate a new tarball from upstream sources:
+# git clone https://anongit.gentoo.org/git/proj/pax-utils.git
+# cd pax-utils
+# ./make-tarball.sh v$pkgver
+source="https://distfiles.adelielinux.org/source/upstream/$pkgname-$pkgver.tar.xz"
subpackages="$pkgname-doc scanelf:_scanelf"
build() {
@@ -35,5 +36,4 @@ _scanelf() {
mv "$pkgdir"/usr/bin/scanelf "$subpkgdir"/usr/bin/
}
-sha512sums="03b84054c59e8ce64d2c07276c61245c8e9b3eca2fc430269531e2dafe120009b541ebb6adc4ff54c13a1da63caf0755fb026ba272cf17d04f75e06b893a3e95 pax-utils-1.2.4.tar.xz
-8076d3a7ae17b49945fb21bb2aa1f488f12cdca31514cc7d9b1195c93448a627dd58234fe8495c29206816d5bd04f409b2349fc050717bc8884657aaadbc1707 fix-eitype.patch"
+sha512sums="44a475860823e8b70b1d09d69e5fba3ed8298511d07e1e7b09ce62237cb8b1ecee8fc2fc550d6853d0b9f8db3c350bf78ced49d5f210997b294dc10e36627fcd pax-utils-1.3.4.tar.xz"
diff --git a/system/pax-utils/fix-eitype.patch b/system/pax-utils/fix-eitype.patch
deleted file mode 100644
index a9ea57963..000000000
--- a/system/pax-utils/fix-eitype.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-elf->data is 'signed char' and casting it to 'int' will sign extend.
-Most non-intrusive fix is to just have get_elfeitype() take type as
-'unsigned char' to make implicit cast.
-
-diff -ru pax-utils-1.2.2.orig/paxelf.c pax-utils-1.2.2/paxelf.c
---- pax-utils-1.2.2.orig/paxelf.c 2017-01-24 20:24:53.000000000 +0000
-+++ pax-utils-1.2.2/paxelf.c 2017-09-26 07:01:00.115498082 +0000
-@@ -65,7 +65,7 @@
- QUERY(ELFOSABI_STANDALONE),
- { 0, 0 }
- };
--const char *get_elfeitype(int ei_type, int type)
-+const char *get_elfeitype(int ei_type, unsigned char type)
- {
- switch (ei_type) {
- case EI_CLASS: return find_pairtype(elf_ei_class, type);
-diff -ru pax-utils-1.2.2.orig/paxelf.h pax-utils-1.2.2/paxelf.h
---- pax-utils-1.2.2.orig/paxelf.h 2017-01-24 20:24:53.000000000 +0000
-+++ pax-utils-1.2.2/paxelf.h 2017-09-26 07:00:44.941879820 +0000
-@@ -56,7 +56,7 @@
- extern elfobj *_readelf(const char *filename, int read_only);
- #define readelf(filename) _readelf(filename, 1)
- extern void unreadelf(elfobj *elf);
--extern const char *get_elfeitype(int ei_type, int type);
-+extern const char *get_elfeitype(int ei_type, unsigned char type);
- extern const char *get_elfetype(const elfobj *elf);
- extern const char *get_endian(const elfobj *elf);
- extern const char *get_elfosabi(const elfobj *elf);