summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-12-27 00:14:59 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-12-27 00:50:46 +0000
commit7e1f58eff231562a3633dd654a2ba158cf241e49 (patch)
tree3dfafc5022d5459b9d8e3f326f6387b7a28319cc /system
parente9ea939bc00ecf49a7bffd4d2253cba2c6726210 (diff)
downloadpackages-7e1f58eff231562a3633dd654a2ba158cf241e49.tar.gz
packages-7e1f58eff231562a3633dd654a2ba158cf241e49.tar.bz2
packages-7e1f58eff231562a3633dd654a2ba158cf241e49.tar.xz
packages-7e1f58eff231562a3633dd654a2ba158cf241e49.zip
system/nghttp2: Split apps to user/nghttp2-utils
The tools need libraries that should not be pulled into system/. Additionally, since c-ares needs CMake now, it causes a dep cycle. Fixes: #936
Diffstat (limited to 'system')
-rw-r--r--system/nghttp2/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/system/nghttp2/APKBUILD b/system/nghttp2/APKBUILD
index 8f9e55404..830a4231f 100644
--- a/system/nghttp2/APKBUILD
+++ b/system/nghttp2/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
options="!check" # Requires cunit, which we don't currently ship
license="MIT"
depends=""
-makedepends="c-ares-dev libev-dev libxml2-dev openssl-dev zlib-dev"
+makedepends=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
source="https://github.com/tatsuhiro-t/$pkgname/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz"
@@ -30,7 +30,7 @@ build() {
--without-neverbleed \
--without-jemalloc \
--disable-python-bindings \
- --enable-app
+ --enable-lib-only
make
}