summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-08-05 01:31:58 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-08-05 01:31:58 +0000
commit8a6e7b726fc93908618526a83d8243365ff3ae46 (patch)
tree90367516eae2c2fb80909b8df2e2aaa06fb6456c /system
parent42b5c5b3b14fc62fb14f529035e24f62862a781c (diff)
parentc3a4b6cb60e71fc6eba379e858b846859cd46e9a (diff)
downloadpackages-8a6e7b726fc93908618526a83d8243365ff3ae46.tar.gz
packages-8a6e7b726fc93908618526a83d8243365ff3ae46.tar.bz2
packages-8a6e7b726fc93908618526a83d8243365ff3ae46.tar.xz
packages-8a6e7b726fc93908618526a83d8243365ff3ae46.zip
Merge branch 'arm-fixes' into 'master'
Fixes for issues found on the armv7 builder See merge request adelie/packages!308
Diffstat (limited to 'system')
-rw-r--r--system/apk-tools/APKBUILD2
-rw-r--r--system/apk-tools/dash.patch14
-rw-r--r--system/findutils/APKBUILD4
-rw-r--r--system/findutils/sysmacros.patch10
-rw-r--r--system/heirloom-pax/APKBUILD6
-rw-r--r--system/heirloom-pax/sysmacros.patch14
-rw-r--r--system/jfsutils/APKBUILD7
-rw-r--r--system/jfsutils/sysmacros.patch10
-rw-r--r--system/lvm2/APKBUILD2
-rw-r--r--system/lvm2/dash.patch64
-rw-r--r--system/parted/APKBUILD2
-rw-r--r--system/parted/sysmacros.patch10
-rw-r--r--system/rhash/APKBUILD2
-rw-r--r--system/zip/APKBUILD8
14 files changed, 145 insertions, 10 deletions
diff --git a/system/apk-tools/APKBUILD b/system/apk-tools/APKBUILD
index 5305ed1cb..c20759d7c 100644
--- a/system/apk-tools/APKBUILD
+++ b/system/apk-tools/APKBUILD
@@ -13,6 +13,7 @@ makedepends_host="zlib-dev openssl openssl-dev linux-headers"
makedepends="$makedepends_build $makedepends_host"
subpackages="$pkgname-static"
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
+ dash.patch
pmmx.patch
search.patch
virtual.patch
@@ -70,6 +71,7 @@ static() {
}
sha512sums="d2d9fde0aae9059236f68a3fc2f2186104bb9a099b15d296a6202a20ab2912638f10bb3b9edb70f359d060c5839573c3d50ef37d13095fa01c66dc3219ab6e39 apk-tools-2.10.4.tar.xz
+7f2559e72cb3a6fc7752971e65c1888fb867da07d0aa7d53af56f41ee8716f6cfe0b8c3589840032233094a31d63ac4a0a2f7681c9a5ecf72eff90b2ff826e88 dash.patch
78f863c83af8b245aa38416c47016bcbe95ea8e33802123f6ea54b3752eb3c1ee79e5d6fc76ddedd2fba522b82a7367837f4596321085d54397b27fd5edf3b2f pmmx.patch
5ac09eadabe44fe05c952c25df8f6daca292c63e6e5e3481d57603b8b3f1980385ccd87ad4a87b617353d1f936591afb9ee8815e4d8ec3e33913be2b3e3a3f84 search.patch
4e2a8db82e6e40ae4863d12ee55151468d6e8c383e2e2001015f469e07f47057bc9055ab52a4a04f2bffa41ec225f77a9bd6042d5e1fcbd2908d7393e3aed2a1 virtual.patch"
diff --git a/system/apk-tools/dash.patch b/system/apk-tools/dash.patch
new file mode 100644
index 000000000..811427d3c
--- /dev/null
+++ b/system/apk-tools/dash.patch
@@ -0,0 +1,14 @@
+--- apk-tools-2.10.4/test/solver.sh
++++ apk-tools-2.10.4/test/solver.sh
+@@ -11,9 +11,9 @@ TEST_TO_RUN="$@"
+ fail=0
+ pass=0
+ for test in ${TEST_TO_RUN:-*.test}; do
+- get_block ARGS < $test | xargs $APK_TEST &> .$test.got
++ get_block ARGS < $test | xargs $APK_TEST > .$test.got 2>&1
+
+- if ! get_block EXPECT < $test | cmp .$test.got &> /dev/null; then
++ if ! get_block EXPECT < $test | cmp .$test.got > /dev/null 2>&1; then
+ fail=$((fail+1))
+ echo "FAIL: $test"
+ get_block EXPECT < $test | diff -ru - .$test.got
diff --git a/system/findutils/APKBUILD b/system/findutils/APKBUILD
index c64c309e2..05a9d955a 100644
--- a/system/findutils/APKBUILD
+++ b/system/findutils/APKBUILD
@@ -15,6 +15,7 @@ subpackages="$pkgname-doc $pkgname-lang"
source="https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz
localename-test-fix.patch
gnulib-tests-dont-require-gpg-passphrase.patch
+ sysmacros.patch
"
build() {
@@ -40,4 +41,5 @@ package() {
sha512sums="41fcd4197c1efbd77f7420e5754e2cf9332dfef19f90c65a8fa1844bb4bc5d529c8393ee0ff979a054e9ac65ff71d7fe3921ea079f9960843412fc9a71f8afd4 findutils-4.6.0.tar.gz
39fc0bc7602dd5300cf0b5488a7d14b6d00e05fedd6067ff45a229e65ff020d0003c0bb8e43807d9874afeb39c1dae6d612182caeb7de76156e1bc6ceb50adfc localename-test-fix.patch
-96351821572bee9e23760568b5a9f326c8727b6904a8b9f6fc8e5b8e14b42265c632cea09a913db830844f3015f91a03b9c4dd72862f40a3c3814556497434e2 gnulib-tests-dont-require-gpg-passphrase.patch"
+96351821572bee9e23760568b5a9f326c8727b6904a8b9f6fc8e5b8e14b42265c632cea09a913db830844f3015f91a03b9c4dd72862f40a3c3814556497434e2 gnulib-tests-dont-require-gpg-passphrase.patch
+2e214511de4be47dc0df46a83d4102e4b59b5f02c4b8356a1ed0b26d481e17c6604bbf07071960f219ef85e1687878cce69a8be28c46638ee4ebe9f4ce0ed487 sysmacros.patch"
diff --git a/system/findutils/sysmacros.patch b/system/findutils/sysmacros.patch
new file mode 100644
index 000000000..40fe2170f
--- /dev/null
+++ b/system/findutils/sysmacros.patch
@@ -0,0 +1,10 @@
+--- findutils-4.6.0/gl/lib/mountlist.c
++++ findutils-4.6.0/gl/lib/mountlist.c
+@@ -32,6 +32,7 @@
+ #include <fcntl.h>
+
+ #include <unistd.h>
++#include <sys/sysmacros.h>
+
+ #if HAVE_SYS_PARAM_H
+ # include <sys/param.h>
diff --git a/system/heirloom-pax/APKBUILD b/system/heirloom-pax/APKBUILD
index af918e06f..7b91e0235 100644
--- a/system/heirloom-pax/APKBUILD
+++ b/system/heirloom-pax/APKBUILD
@@ -12,7 +12,8 @@ depends=""
makedepends="bsd-compat-headers bzip2-dev zlib-dev"
replaces="pax"
subpackages="$pkgname-doc"
-source="https://distfiles.adelielinux.org/source/${pkgname}-$pkgver.tar.xz"
+source="https://distfiles.adelielinux.org/source/${pkgname}-$pkgver.tar.xz
+ sysmacros.patch"
build() {
cd "$builddir"
@@ -31,4 +32,5 @@ package() {
mv "$pkgdir"/usr/bin/cpio "$pkgdir"/usr/5bin/cpio
}
-sha512sums="7b0ad20cc51b5bcec9c07e84c603e4891f636944f6f6bd13d3decb0e9d6b23d6164b663468ee2293b37721aae20334774f4e56fd8541ffceee934050e819b642 heirloom-pax-1.0.tar.xz"
+sha512sums="7b0ad20cc51b5bcec9c07e84c603e4891f636944f6f6bd13d3decb0e9d6b23d6164b663468ee2293b37721aae20334774f4e56fd8541ffceee934050e819b642 heirloom-pax-1.0.tar.xz
+bcc12138ebed707e165a1ac5dac815acd85770974e19f62610e0fe32a96879fb1173fc4e7beafde12b7bc1ed03f2751b2839eeb3ccacbe209d8cbcfe0307eac3 sysmacros.patch"
diff --git a/system/heirloom-pax/sysmacros.patch b/system/heirloom-pax/sysmacros.patch
new file mode 100644
index 000000000..3a4feb996
--- /dev/null
+++ b/system/heirloom-pax/sysmacros.patch
@@ -0,0 +1,14 @@
+--- heirloom-pax-1.0/cpio/cpio.c
++++ heirloom-pax-1.0/cpio/cpio.c
+@@ -91,9 +91,9 @@
+ #include <sfile.h>
+ #include <atoll.h>
+
+-#ifdef _AIX
++#ifndef major
+ #include <sys/sysmacros.h>
+-#endif /* _AIX */
++#endif /* !major */
+
+ #ifndef major
+ #include <sys/mkdev.h>
diff --git a/system/jfsutils/APKBUILD b/system/jfsutils/APKBUILD
index 55ff4139e..31cf3ee35 100644
--- a/system/jfsutils/APKBUILD
+++ b/system/jfsutils/APKBUILD
@@ -12,7 +12,9 @@ makedepends="util-linux-dev" # libuuid is needed
subpackages="$pkgname-doc"
source="http://jfs.sourceforge.net/project/pub/jfsutils-$pkgver.tar.gz
musl-fix-includes.patch
- missing-stdinth.patch"
+ missing-stdinth.patch
+ sysmacros.patch
+ "
build() {
cd "$builddir"
@@ -36,4 +38,5 @@ package() {
sha512sums="fa8ba7f4997471da3e6ea7239564f3395046222cfbb2b10e37b24ad0bd107b7eadbb51ce328d89d193034360b4035ca5e0e5b0b416a74483d7a2c0a2b9c65858 jfsutils-1.1.15.tar.gz
fb0d7348e2e13a6a9c3a987d161e0cf05363649515366ef49a45e3580b8f6135fce8465b99ff8a351231d970371c00bea6ceb9edb1d0f24da20d261b06ec85bd musl-fix-includes.patch
-a8e2332f2dec37affa8404b31e7e68399d815d450422ad342243c51d117e4d7ef4aaa0e30d1389380a81ed076a7ef1e1d41fcf260fa05ce4d823aa779628982d missing-stdinth.patch"
+a8e2332f2dec37affa8404b31e7e68399d815d450422ad342243c51d117e4d7ef4aaa0e30d1389380a81ed076a7ef1e1d41fcf260fa05ce4d823aa779628982d missing-stdinth.patch
+9e5006bcee7595ee978bdd6791867a22de26b241dcd8d19b84a7694b3de11b20adcfd46d7999062663bdabf985abe3a53865089fdc219ecfe5476f2dcb93eaff sysmacros.patch"
diff --git a/system/jfsutils/sysmacros.patch b/system/jfsutils/sysmacros.patch
new file mode 100644
index 000000000..8c69d7bfa
--- /dev/null
+++ b/system/jfsutils/sysmacros.patch
@@ -0,0 +1,10 @@
+--- jfsutils-1.1.15/libfs/devices.c
++++ jfsutils-1.1.15/libfs/devices.c
+@@ -38,6 +38,7 @@
+ #endif
+
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <sys/stat.h>
+ #include <sys/ioctl.h>
+ #if defined(__DragonFly__)
diff --git a/system/lvm2/APKBUILD b/system/lvm2/APKBUILD
index fc491a70a..f0cb77a92 100644
--- a/system/lvm2/APKBUILD
+++ b/system/lvm2/APKBUILD
@@ -16,6 +16,7 @@ makedepends_host="$depends_dev util-linux-dev"
makedepends="$makedepends_build $makedepends_host"
replaces="device-mapper $pkgname-dmeventd"
source="https://mirrors.kernel.org/sourceware/$pkgname/LVM2.$pkgver.tgz
+ dash.patch
fix-stdio-usage.patch
mallinfo.patch
mlockall-default-config.patch
@@ -88,6 +89,7 @@ udev() {
sha512sums="3b00f53771e99faa6459ae73353bff06ae37c64bd2659586ec25d0bb43bc3ff8ba5f713c68617fd7662a5f6cb65bca1ad0aea554819048d79c1cce20bf67c50a LVM2.2.03.05.tgz
+9dbdda2b5b35777ea22be5eedd585de6594e856bf168416f11d003683dad9cc3d8dae5a14e5ae22f251d20809960173cd2e7ea0889949d5d1c1d1e2d10f81508 dash.patch
6ea4efad03f8632f2883f33f9d9f8ca295f7d8d2aa1bfbfa7738e7d711727a511758848dde5776b222bd74e6fb60bed8b56a3cd2f74ca448b8d86f50470a42b9 fix-stdio-usage.patch
9272ec8c5184ef5dc776ead8f74132e072b7563b5119a3a38b712f00d92a1e3878c9b3a54eb2b01dcba038110c686b39d4c17ecd0eb258537e9217d7ed03c408 mallinfo.patch
d190c40a137b006d7b63298069c93ff08d2804b990e85d44739cd7c48beec9a569903b98f0d940895fc7365723ba886acd7ef0e08f1f65a1a391d1c448ce080e mlockall-default-config.patch
diff --git a/system/lvm2/dash.patch b/system/lvm2/dash.patch
new file mode 100644
index 000000000..d2ab014f8
--- /dev/null
+++ b/system/lvm2/dash.patch
@@ -0,0 +1,64 @@
+--- LVM2.2.03.05/configure
++++ LVM2.2.03.05/configure
+@@ -3077,7 +3077,7 @@ if test -z "$CFLAGS"; then :
+ fi
+ case "$host_os" in
+ linux*)
+- CLDFLAGS="${CLDFLAGS:"$LDFLAGS"} -Wl,--version-script,.export.sym"
++ CLDFLAGS="${CLDFLAGS:-"$LDFLAGS"} -Wl,--version-script,.export.sym"
+ # equivalent to -rdynamic
+ ELDFLAGS="-Wl,--export-dynamic"
+ # FIXME Generate list and use --dynamic-list=.dlopen.sym
+@@ -3098,7 +3098,7 @@ case "$host_os" in
+ ;;
+ darwin*)
+ CFLAGS="$CFLAGS -no-cpp-precomp -fno-common"
+- CLDFLAGS="${CLDFLAGS:"$LDFLAGS"}"
++ CLDFLAGS="${CLDFLAGS:-"$LDFLAGS"}"
+ ELDFLAGS=
+ CLDWHOLEARCHIVE="-all_load"
+ CLDNOWHOLEARCHIVE=
+@@ -3111,7 +3111,7 @@ case "$host_os" in
+ BLKDEACTIVATE=no
+ ;;
+ *)
+- CLDFLAGS="${CLDFLAGS:"$LDFLAGS"}"
++ CLDFLAGS="${CLDFLAGS:-"$LDFLAGS"}"
+ ;;
+ esac
+
+--- LVM2.2.03.05/tools/Makefile.in
++++ LVM2.2.03.05/tools/Makefile.in
+@@ -167,7 +167,7 @@ liblvm2cmd.$(LIB_SUFFIX).$(LIB_VERSION): liblvm2cmd.$(LIB_SUFFIX)
+
+ command-count.h: $(srcdir)/command-lines.in Makefile
+ @echo " [GEN] $@"
+- $(Q) set -o pipefail && \
++ $(Q) \
+ ( cat $(top_srcdir)/tools/license.inc && \
+ echo "/* Do not edit. This file is generated by the Makefile. */" && \
+ echo -n "#define COMMAND_COUNT " && \
+@@ -176,7 +176,7 @@ command-count.h: $(srcdir)/command-lines.in Makefile
+
+ cmds.h: $(srcdir)/command-lines.in Makefile
+ @echo " [GEN] $@"
+- $(Q) set -o pipefail && \
++ $(Q) \
+ ( cat $(top_srcdir)/tools/license.inc && \
+ echo "/* Do not edit. This file is generated by the Makefile. */" && \
+ echo "cmd(CMD_NONE, none)" && \
+@@ -186,11 +186,11 @@ cmds.h: $(srcdir)/command-lines.in Makefile
+
+ command-lines-input.h: $(srcdir)/command-lines.in Makefile
+ @echo " [GEN] $@"
+- $(Q) set -o pipefail && \
++ $(Q) \
+ ( cat $(top_srcdir)/tools/license.inc && \
+ echo "/* Do not edit. This file is generated by the Makefile. */" && \
+- echo -en "const char _command_input[] =\n\n\"" && \
++ printf "const char _command_input[] =\n\n\"" && \
+ $(EGREP) -v '^#|\-\-\-|^$$' $(srcdir)/command-lines.in | $(AWK) 'BEGIN {ORS = "\\n\"\n\""} //' && \
+- echo "\\n\";" \
++ printf "%s\n" "\\n\";" \
+ ) > $@
+
diff --git a/system/parted/APKBUILD b/system/parted/APKBUILD
index ff9eb6c76..6f0e135ea 100644
--- a/system/parted/APKBUILD
+++ b/system/parted/APKBUILD
@@ -15,6 +15,7 @@ source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
disable-two-tests.patch
fix-includes.patch
fix-libintl-header-s390x.patch
+ sysmacros.patch
tests-call-name-correctly.patch
tests-python3.patch
"
@@ -50,5 +51,6 @@ sha512sums="4e37dbdd6f5032c9ebfec43704f6882379597d038167b9c4d04053efa083c68a7051
b49eb0211c405a4ef69e1bb0079621c22fec4adf0309f0a58b5d881540913de01d05ccd3eb521f35c3cf6f4eb8aa0f4c5270ce3dea47270a5c3fe8fae635c6f0 disable-two-tests.patch
55ee63c218d1867c0f2c596e7c3eec5c42af160181456cc551fe3d432eabed0ac2dd3a3955ff0c375f76aeec8071e7f55a32834b87a0d39b8ef30361f671bfdd fix-includes.patch
444a7e2fb3235dfd218f6b71fb25adde107d001f638d988ee1fa79686d8efee94a9499e27bdfdd75f9718760b448938b70a90a74285b93a39338d21f4ab4c9dc fix-libintl-header-s390x.patch
+5d2e8f22b6cd5bdd3289996848279a945ca09acd2862e82283bb769c2e4d61a24a31e1793d81385e8f3f1f4d48417e2308c5ea39dac47e832666363dde044ba7 sysmacros.patch
8bd86d2b0401566e7757c43d849b7f913cc4ec1bf50d5641dc72d7e278ca38db2ac746cd8dcc756b245021ea1f9738875b6a831f05185b9217d3f1c287944748 tests-call-name-correctly.patch
7486f98d535380a9e6598b9ac6153564319d5effa25456dc393cf3540ea47ac5b462be79cbd7d8efbd1fc2d2ef240a00873a2e2b138d4b4b0bb1494893de1eac tests-python3.patch"
diff --git a/system/parted/sysmacros.patch b/system/parted/sysmacros.patch
new file mode 100644
index 000000000..b33767c66
--- /dev/null
+++ b/system/parted/sysmacros.patch
@@ -0,0 +1,10 @@
+--- parted-3.2/libparted/arch/linux.c
++++ parted-3.2/libparted/arch/linux.c
+@@ -37,6 +37,7 @@
+ #include <dirent.h>
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <sys/utsname.h> /* for uname() */
+ #include <scsi/scsi.h>
diff --git a/system/rhash/APKBUILD b/system/rhash/APKBUILD
index 4f30a7845..1a3d8d0f1 100644
--- a/system/rhash/APKBUILD
+++ b/system/rhash/APKBUILD
@@ -27,7 +27,7 @@ check() {
}
package() {
- make DESTDIR="$pkgdir" install install-gmo install-lib-headers install-lib-so-link install-man
+ make -j1 DESTDIR="$pkgdir" install install-gmo install-lib-headers install-lib-so-link install-man
}
sha512sums="9dba4fa4dd49d323f2e440c5b93eac1ef62eb4046ec4ef611f0978c12c1739002f1ac1f1ec5e61bd359dc89e9ed612db71be91a795184ac5d5433280d27fa4c1 rhash-1.3.8.tar.gz"
diff --git a/system/zip/APKBUILD b/system/zip/APKBUILD
index 98e60671b..ed060ef03 100644
--- a/system/zip/APKBUILD
+++ b/system/zip/APKBUILD
@@ -11,10 +11,10 @@ license="Info-ZIP"
depends=""
makedepends=""
subpackages="$pkgname-doc"
-source="ftp://ftp.info-${pkgname}.org/pub/info${pkgname}/src/${pkgname}30.zip
- 10-zip-3.0-build.patch
- 20-zip-3.0-exec-stack.patch
- 30-zip-3.0-pic.patch"
+source="https://sourceforge.net/projects/infozip/files/Zip%203.x%20%28latest%29/3.0/${pkgname}30.zip
+ 10-zip-3.0-build.patch
+ 20-zip-3.0-exec-stack.patch
+ 30-zip-3.0-pic.patch"
builddir="$srcdir"/${pkgname}30